-   Linux - Wireless Networking (
-   -   Trying everything, but cannot connect D-Link/Atheros 0023 wireless card to network (

Feelin' Fine 03-07-2007 10:22 PM

Trying everything, but cannot connect D-Link/Atheros 0023 wireless card to network
Just took the plunge and wiped XP to install Ubuntu 6.10. So far I'm liking everything I see.
BUT - I can't seem to get the wireless network card to connect to my wireless router.

Wireless card is D-Link DWA 542 / chipset is Atheros 0023

Using ndiswrapper -l: I know that the net5416.inf driver is installed and that the system is seeing the wireless card.

iwlist scan:

wlan0 Scan completed :
Cell 01 - Address: 00:19:5B:04:CD:90
ESSID:"Hudson Family Network"
Protocol:IEEE 802.11g
Frequency:2.452 GHz (Channel 9)
Quality:0/100 Signal level:-1 dBm Noise level:-256 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s


wlan0 IEEE 802.11g ESSID:off/any Nickname:"Hudson Family Network"
Mode:Managed Frequency:2.422 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

To me.....this says that the system sees the wireless card and the wireless card sees the router/network. I have also employed wifi radar and it reports a good, strong signal. However, when I ask it to connect ot the network, it returns "Could not get IP address!"

Why is this? If it's not already apparent, I'm very new to Linux, and really need some detailed help here. (READ: talk to me like I'm 4 years old).
Even some pointers on how to better diagnose what the problem is would be most appreciated.

Quakeboy02 03-07-2007 10:25 PM

Have you run "ifconfig wlan0 up"?

Feelin' Fine 03-08-2007 10:47 PM

ok. Just tried that and got the result:

alphaomega@alphaomega-desktop:~$ ifconfig wlan0 up
SIOCSIFFLAGS: Permission denied

I haven't the slightest idea what SIOCSIFFLAGS is, but it doesn't sound good.

No change in connectivity. I connect with a hard-line just fine, but through wireless...nothing.

Feelin' a little helpless....

jschiwal 03-08-2007 10:49 PM

Run the ifup command as root. Also, you need to configure encryption before you can associate with your router.

Quakeboy02 03-08-2007 11:07 PM

Thanks J. :)

"Permission denied"

My bad. I need to put a sign on my monitor to remind me that the new user may not automatically know to run these commands as root. It's probably better to get into the habit of running these things as sudo, though. It'll ask for the root password, but will help keep you from doing really bad things like doing "rm -rf *" while logged in as root.


sudo ifconfig wlan0 up
The system prompts for password. You enter the root password, and it's good to go.

It looks to me like your AP's encryption key is actually off, but that's a different issue at this point.

Feelin' Fine 03-11-2007 09:06 PM

Okay....feelin' better.

With all security protocols turned off (open network), I have successfully connected to the router and can go on the net. Huzzah! Thanks so much for your help!

Now if I could prevail upon you to help me secure the network.
Every time I switch the router to WPA security, I can no longer connect. I'm thinking this is because I am somehow not entering the right info into Wifi Radar or other connection tool.

....or if there is something else that I need to be doing?

Feelin' a little more confident, but still going to need basic instructions.

2Gnu 03-11-2007 10:52 PM

WPA requires a software utility called a supplicant. There are two choices for Linux- XSupplicant and wpa_supplicant. wpa_supplicant is the more common of the two. If it's not already installed, grab wpa_supplicant with Synaptic, along with NetworkManager (a GUI for setting up the wireless device).

Feelin' Fine 03-11-2007 11:17 PM

ok. got both. Not sure what to do now.

Incidentally, I have the NetworkManager applet up in the top right corner of my screen. It is not detecting my wireless connection, even though I am connected.
When I hard-wire into the router, the applet says connected and all is good. When the hard-line is disconnected, I'm moving about wirelessly, but the applet still indicates "No Network Connection" and has the little red 'x' through the icon.

Related at all?

2Gnu 03-11-2007 11:23 PM

Hmm. Don't know if it's related or not. I've only used Ubuntu a little - mostly just so I could be a little more help to people who use it - and NM worked fine with an Atheros card and wpa_supplicant.

I manually configured wpa_supplicant and used NM. Both worked, but since you're having trouble with the GUI, you may want to try manually editing /etc/wpa_supplicant.conf. The file is pretty well documented.

All times are GMT -5. The time now is 02:17 AM.