LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 11-12-2009, 03:55 PM   #1
Boffy
Member
 
Registered: Jul 2003
Location: Durham, UK
Distribution: Ubuntu 8.04
Posts: 419

Rep: Reputation: 30
Trouble setting up command line wlan that works fine on gnome (ubuntu 9.10)


I've a wireless network card that works fine on the ubuntu gui with network manager but I can't get to work having tried everything I can think of on the command line.

My /etc/network/interfaces looks like:
Code:
auto wlan0 
iface wlan0 inet dhcp
wireless-essid "NETWORKNAME"
wireless-key KEY0000
wireless-channel 9
wireless-mode master
When I restart the network I get an error saying it can't set the mode (i only know it's master from iwlist). Then the DHCP cannot find an IP.

As I mentioned it works fine under the GUI, is there any way I can copy the settings network manager uses to the commend line setup.

(oh and I'm trying to operate a server without gui, thus my need for it to work from the CLI)
 
Old 11-12-2009, 04:34 PM   #2
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
May be that thread will help you: http://www.linuxquestions.org/questi...12#post3749212

P. S. Especially at the end.

Last edited by nimnull22; 11-12-2009 at 04:35 PM.
 
Old 11-13-2009, 03:20 AM   #3
Boffy
Member
 
Registered: Jul 2003
Location: Durham, UK
Distribution: Ubuntu 8.04
Posts: 419

Original Poster
Rep: Reputation: 30
Thanks nimnull22, network-manager was getting in the way. I'm very close now. The following bash script works but the above network interfaces file doesn't. What am I doing wrong?

Code:
ifconfig wlan0 down
ifconfig wlan0 up
iwconfig wlan0 essid "NETWORKNAME"
iwconfig wlan0 key C00C00C00
iwconfig wlan0 channel 9
dhclient
How can I convert that bash file so I can get the network to load on boot?
 
Old 11-13-2009, 03:08 PM   #4
Boffy
Member
 
Registered: Jul 2003
Location: Durham, UK
Distribution: Ubuntu 8.04
Posts: 419

Original Poster
Rep: Reputation: 30
Turns out my problem was with the quote (") in the /etc/network/interfaces file. You don't need to wrap them around your ESSID
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shell pgm works fine in command line but not in Crontab oracledba_raja Linux - General 2 11-24-2006 12:14 AM
Trouble with K3B and DVD Nero works fine ShaneK Linux - Software 0 12-29-2005 12:02 PM
alsamixer in trouble, sound works fine Cdzin Slackware 1 01-02-2005 11:28 AM
SED command doesn't works fine on AIX JSnake AIX 4 07-01-2004 12:32 PM
'command not found' but works fine anyway HickorySlim Linux - General 11 08-03-2002 06:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 04:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration