LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=41)
-   -   tethereal and tcpdump: -y invalid data link type 1 (http://www.linuxquestions.org/questions/showthread.php?t=187865)

murugesan 05-30-2004 11:28 PM

tethereal and tcpdump: -y invalid data link type 1
 
Hello all,
This post is with respect to ethereal protocol analyzer and tcpdump Network Monitoring tool.

In older version of ethereal ( version 0.10.0 ) the command
tethereal -y 1
gives me
Code:

# tethereal -y 1 -c 2
Capturing on lan0
  0.000000 172.16.1.11 -> 172.16.1.12  TELNET Telnet Data ...
  0.001271 172.16.1.11 -> 172.16.1.12  TELNET Telnet Data ...

when I do the same with latest version of ethereal
I am getting
Code:

# tethereal -y 1
tethereal: The specified data link type "1" is not valid

Similarly
for tcpdump, where the older version 0.7.2 does not support this option, with newer version 3.8.3, I am getting the same error as tethereal
That is,
Code:

# tcpdump -y 1
tcpdump: invalid data link type 1

My questions is
What parameter should I use to get the output for the option -y ( for tcpdump and ethereal ) ?
I have tried all the values from -5000 to 5000.
I am using HPUX 11.2* on PA and IPF and 11i on PA.
All produces the same result.

Thanks in advance for the help.

-Murugesan


All times are GMT -5. The time now is 07:51 AM.