LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 09-16-2005, 04:12 PM   #1
jgriffith
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
SuSE 9.3 update disables use of ndiswrapper


Under SuSE 9.3 Pro, I had my Linksys WMP54G wireless card working perfectly using ndiswrapper version 1.3rc1 (thanks in no small part to this forum). I consistently had internet access over many sessions.

I then performed an online update through YaST. I just recently installed SuSE, and this was the first online update I'd performed. After the online update, I no longer had access to the internet.

The windows drivers are still installed, and
Code:
ndiswrapper -l
still returns

Code:
Installed ndis drivers:
[driver name] driver present, hardware present
I can find only two major differences relating to ndiswrapper between the system now and the system before the update:

First, dmesg now returns

Code:
ndiswrapper version 1.1 loaded.
which is the version included with SuSE 9.3 Pro. The first time I tried setting up my wireless card I faced the same problem; I remember muddling about until I got it to report that 1.3rc1 was loaded instead. I don't remember how I did this and haven't been able to recreate it. At the time, I tried uninstalling version 1.1 through YaST, and YaST still reports version 1.1 as uninstalled. I have also reinstalled version 1.3rc1. The system log still reports that version 1.1 is loaded.

How do I eliminate ndiswrapper version 1.1 entirely from my system and force the recognition of version 1.3rc1?

Second, modprobe'ing ndiswrapper now returns a fatal error and says that the module cannot be inserted. This operation worked perfectly before the online update.

How do I correct this?

Also, if and when I finally get my wireless card working again, how can I ensure that future updates do not wipe out all of this work? I have set YaST never to install ndiswrapper 1.1 by labelling it 'taboo', but I doubt that alone will work. I don't want to have to go through this again.

I'm rather new at this, so please respond in newbie terms.
Thanks in advance!
 
Old 09-16-2005, 10:08 PM   #2
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Re: ndiswrapper and Suse 9.3

I've only had Suse 9.3 up and running for a week now, so I'd still consider myself a Suse newbie. But I think I know what the problem is. First off, since you've had it working before, you know you have the right driver. Since it quit after the online update, I think the problem involves the kernel. When you installed ndiswrapper, it was compiled against the standard kernel and kernel-source files for Suse 9.3. But when you did the online update, odds are it updated the kernel to the newest version with the newest kernel-source files. So your ndiswrapper is configured for the wrong kernel (the old one). This is likely the reason for your modprobe issue. Any time you update the kernel or kernel source file, you will kill ndiswrapper. End of story. So you have to tell YaST not to touch your kernel and kernel-source files as well as ndiswrapper if you don't want to redo it. To fix, I would simply go to the terminal and use "ndiswrapper -e" and the name of your installed wireless driver to remove it. Next, run "ndiswrapper -l" to make sure no drivers are installed. Then, I would go into YaST and remove ndiswrapper altogether. Next, I would find out the version of the kernel you are currently running, then make sure the kernel-source file for that kernel is installed in YaST. If you just type "kernel" in the search line of YaST, you will find them. Check to see if your "kernel-default" and "kernel-source" numbers match up in the "Installed Version" column. MAKE SURE the kernel-source file you install or that is already installed matches your kernel number or else you will have issues again. Once that is complete, reinstall ndiswrapper and install your driver.inf file again. Go through the same process you did before to get the driver working. I know this is lengthy, but hopefully it will help. If you have questions, just post them in here again and I'll check back to see if I can help. Good Luck!
 
Old 09-16-2005, 10:20 PM   #3
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Re: ndiswrapper version

Sorry, forgot to mention, if YaST shows ndiswrapper 1.1 as uninstalled, I'd assume it is. I would reinstall your ndiswrapper 1.3 release client AFTER you make sure your kernel and kernel-source files are matched up. I'm not sure how to make Suse know the difference, but if Yast says ndiswrapper 1.1 is removed, it shouldn't find it anymore. Once you reinstall the newer ndiswrapper, it should just see that one. I do know that I've read that different versions of ndiswrapper installed together will not get along well, so I'd see if maybe you can get Suse to only recognize your newer version. However, I'm currently using ndiswrapper-1.1 installed via YaST after I updated my kernel-source files and my wireless works great! Once again, Good Luck!
 
Old 09-18-2005, 04:59 PM   #4
jgriffith
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Original Poster
Rep: Reputation: 0
That worked. Thanks a bunch!
For the benefit of others in my situation, I'll post what I did:
1) Uninstall the driver with " ndiswrapper -e <name of driver> "
2) Use " ndiswrapper -l " to make sure the driver is removed. This should return " no drivers installed " or something to that effect.
3) Uninstall ndiswrapper by going to the installation directory (the directory that was created when and where you unpacked the ndiswrapper archive file) and using the command " make uninstall ".
4) Do what Agentvenom said about making sure all your kernel numbers match up. You can find out exactly which kernel version you're using with the command " uname -r ". Mine checked out (I think the update installation took care of all of this), so I can't tell you what to do if your numbers don't match up.
5) Reinstall ndiswrapper by going to the aforementioned directory and typing " make distclean ", " make ", and then " make install ".
6) ndiswrapper your driver again and (if necessary) configure your wireless card again. I didn't have to reconfigure the card, though, so hopefully you won't either.
7) Insert the ndiswrapper module again by using " modprobe ndiswrapper ".
Everything is working fine for me now after this. Thanks again.
 
Old 09-18-2005, 05:16 PM   #5
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Glad to help!
 
Old 10-13-2005, 09:49 PM   #6
Troodon
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa, ON
Distribution: Suse 9.3 Pro & CentOS 4.1 (a.k.a. RHEL 4.1)
Posts: 8

Rep: Reputation: 0
Re: SuSE 9.3 update disables use of ndiswrapper

Quote:
Originally posted by jgriffith
Under SuSE 9.3 Pro, I had my Linksys WMP54G wireless card working perfectly using ndiswrapper version 1.3rc1 (thanks in no small part to this forum). I consistently had internet access over many sessions.
jgriffith, I too am struggling with a WMP54G v4 wireless card installation under Suse 9.3 Pro + updates. The cards runs perfect without encryption using the native rt2500 driver/module. However, I can't seem to set up WPA-PSK corectly. What worries me is, upon manually running the "/etc/init.d/network restart" script I get a message reading "ERROR: WPA-PSK is not supported yet for this device". Also, to my surprise the encryption key I provided for my wireless card using Yast2, and in /etc/wpa_supplicant.conf, is different from that shown upon issuing "iwconfig" (but perhaps that is to be expected). I guess either the native rt2500 driver does not support WPA-PSK, or my configuration is wrong. I have also tried, unsuccessfully, to set up the card using the km-ndiswrapper module and ndiswrapper-1.1 package provided by Suse 9.3 along with the .INF file in the most recent Linksys driver release for the WMP54G v4 card. My router is a Linksys BEFW11S4.

Any help would be greatly appreciated.

Last edited by Troodon; 10-14-2005 at 01:18 AM.
 
Old 10-13-2005, 09:51 PM   #7
Troodon
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa, ON
Distribution: Suse 9.3 Pro & CentOS 4.1 (a.k.a. RHEL 4.1)
Posts: 8

Rep: Reputation: 0
(duplicate, deleted)

Last edited by Troodon; 10-14-2005 at 01:19 AM.
 
Old 10-14-2005, 02:29 AM   #8
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Yeah, my guess is that the driver simply doesn't support WPA yet. Maybe an updated driver will. I'm not sure what to tell you in the mean time, though. *twidles thumbs*
 
Old 10-14-2005, 10:53 AM   #9
Troodon
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa, ON
Distribution: Suse 9.3 Pro & CentOS 4.1 (a.k.a. RHEL 4.1)
Posts: 8

Rep: Reputation: 0
Quote:
Originally posted by Agentvenom
Yeah, my guess is that the driver simply doesn't support WPA yet. Maybe an updated driver will. I'm not sure what to tell you in the mean time, though. *twidles thumbs*
You are right, I guess, so I am trying to configure the WMP54G v4 adapter using ndiswrapper and the most recent Linksys .INF file instead. Uninstalled ndiswrapper, km_ndiswrapper and wpa_supplicant packages provided by Suse; downloaded kernel-sources and the most recent stable versions of ndiswrapper and wpa_supplicant tarballs; rebuilt both packages from source.

There is one thing that puzzles me: issuing "ndiswrapper -m" generates an alias to wlan0, not ra0 -- is that normal? Thanks.

Last edited by Troodon; 10-14-2005 at 10:59 AM.
 
Old 10-14-2005, 12:48 PM   #10
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
As far as I know, that's fine. Suse tend to pick up wireless devices as wlan0. That's what I'm using right now.
 
Old 10-14-2005, 02:28 PM   #11
marcelo61
LQ Newbie
 
Registered: Oct 2005
Posts: 6

Rep: Reputation: 0
Hi all,

I'm following this thread and trying to set the wireless lan on a Compaq V2424NR (turion64)

I have installed ndiswrapper and the driver seems to be there:

# ndiswrapper -l
Installed ndis drivers:
bcmwl5 driver present, hardware present

--

Then I did

# /usr/sbin/ndiswrapper -m

Edited the file /etc/ndiswrapper/bcmwl5/14E4:4318.5.conf
EnableAutoConnect|1
RadioState|1

Next, I try

# modprobe ndiswrapper
FATAL: module ndiswrapper not found


????

Any suggestion what to do...

Many thanks,
Marcelo.
 
Old 10-14-2005, 07:42 PM   #12
Troodon
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa, ON
Distribution: Suse 9.3 Pro & CentOS 4.1 (a.k.a. RHEL 4.1)
Posts: 8

Rep: Reputation: 0
WMP54G v4 on Suse 9.3 Pro & WPA-PSK- works with native driver!!! :)

The good news: I finally managed to get this thing running -- Linksys WMP54G v4 wireless network adapter, on Suse 9.3 Pro + updates (as of Oct 14, 2005), with WPA-PSK encryption using a native ra2500 driver for Linux (not the one supplied by Suse, but the latest driver from ralinktech.com). Router is a Linksys BEFW11S4.

It actually pretty simple: the ra2500 in the distro does not support WPA-PSK and the kinternet utility will not let you know when the adapter does not accept a particular passphrase; you need the ralinktech configuration utility that comes with the driver for that.

Should anyone be interested in the details I will post a HOW-TO here.

Last edited by Troodon; 10-14-2005 at 11:57 PM.
 
Old 10-14-2005, 07:48 PM   #13
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Sure, show us the how-to.
 
Old 10-15-2005, 11:07 AM   #14
Troodon
LQ Newbie
 
Registered: Oct 2005
Location: Ottawa, ON
Distribution: Suse 9.3 Pro & CentOS 4.1 (a.k.a. RHEL 4.1)
Posts: 8

Rep: Reputation: 0
Briefly, here are the steps to follow when setting up the Linksys WMP54G v4 (PCI) wireless network adapter with WPA-PSK encryption under Linux Suse 9.3 Pro (might also work on other distros):

Prerequisites:

- install the kernel-sources package using the "install and remove software tool" in yast
- make sure you have the wpa_supplicant package installed (otherwise install it)
- update your system using the "online update tool" in yast
- you don't need the ndiswrapper or km_ndiswrapper packages or any windows drivers
- if you have another network card on your machine make sure it is inactive at boot time (at least when you try connecting to your wlan, after you have installed everything)

1. download the updated rt2500 package (includes the module and configuration utility) from ralinktech.com (look it up in the "support" section, drivers, linux, scroll down to PCI/MiniPCI/CardBus(Source Code)). the file I downloaded is http://www.ralinktech.com/drivers/Li...1.4.6.2.tar.gz (if you can't find it there, do a google search on RT2500-Linux-STA-1.4.6.2.tar.gz)

2. "uninstall" the rt2500 module provided with the distribution, which works fine in "open" configuration but does not support wpa-psk encryption (what I did was, search for that file using "find / -name 'rt2500*'" and renamed it to "rt2500.o.orig" and moved it to the /root directory). NOTE: if, for some reason, the rt2500 module is already loaded into memory (try 'lsmod | grep r2500') then you must remove it before attempting to install a new one: bring the ra0 card down with 'ifdown ra0' then remove the module with 'rmmod rt2500'

3. unpack and build the Module and Utility following the instructions in the README file provided in the Module folder in the tarball. carefully choose the /path/to/source directory, which is something like "usr/src/<kernel-version>-obj" (so in my case I have issued ''make -C /usr/src/linux-2.6.11.4-21.9-obj SUBDIRS=$PWD modules"). if you cannot find qmake on your system (needed to build the utility) then you need to install gt3-devel and perhaps some other development packages. copy the RaConfig2500 utility to the /usr/local/bin directory

4. now you have to insert the updated module into the kernel: issue '/sbin/insmod rt2500.ko' and then 'modprobe rt2500'

5. set up the config file for the configuration utility: just copy the relevant section from the README file and save it as indicated there. use a 8-63 character ascii "passphrase" (apparently, "passphrase" means an ascii string, as opposed to a 64 character hexadecimal string "key"; my router only accepts a "passphrase", not a hexadecimal "key", in wpa-psk mode). NOTE: for convenience, i used the WEPKeyGenerator freeware on Windows to generate my WAP "passphrase", but any random 63 ascii string (excluding spaces!) will do

6. use the yast configuration utility for your wireless card to set it up in wpa-psk mode; this is pretty straightforward. select the dhcp configuration to let the router automatically assign an IP to your wireless card. pick a ssid for your wlan. use the "passphrase" at #5. you might be propted to install 2-3 more packages; accept

7. to have your wireless card brought up at boot time read the instructions in the README file in the Module folder. check the /etc/sysconfig/network folder for a file named "ifcfg-ra0" or a file whose name begins with "ifcfg-ra-...". it might not be there; you might find a "ifcfg-wlan..." file instead. if that is the case then rename it to "ifcfg-ra0" and configure it as indicated in the README file (with ssid and "passphrase" at #6). escape characters such as inverted commas and semicolons in the passphrase string. note: this script brings the wireless networking card up at boot time but it is unclear to me whether it also actually configures the card as indicated in the README file; you might still need to run the RaConfig2500 utility once (see below).

make sure no other network card will be active when you reboot the system.

reboot.

login as root. the kinternet utility (see the toolbar) may show your card is not connected yet. run the RaConfig2500 utility, configure your card (you might have to reenter the "passphrase" here) and save the newly created profile. browse available networks and connect to your wlan. close the RaConfig2500 window and check that the kinternet utility shows you are connected to your wlan. that's it, now your card will be up and running every time you (re)start your computer.

you can also check the status of your newtwork in the console:
Code:
  ifconfig
  iwconfig
  /etc/init.d/network status
succesfully tested with a Linksys BEFW11S4 router. kernel version is 2.6.11.4-21.9-default

good luck!


UPDATE! UPDATE! UPDATE! please install updated rt2500 driver from the rt2x00 Open Source Project at rt2x00.serialmonkey.com as the ralinktech 1.4.6.2 release seems to have a bug that prevents this card from working in static ip mode (symptom: system freezes). release 1.1.0-b3 from rt2x00.serialmonkey.com/wiki/index.php/Downloads worked for me. also, with this updated driver you no longer need your router to broadcast the SSID of your WLAN for the client to connect.

Last edited by Troodon; 10-25-2005 at 01:40 PM.
 
Old 10-15-2005, 11:15 AM   #15
Agentvenom
Member
 
Registered: Sep 2005
Distribution: PCLinuxOS 2007 / Suse 10.3
Posts: 228

Rep: Reputation: 30
Thank you for taking the time to enter your step-by-step. I'm sure it will be very helpful to others with this card!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NDISWrapper + Suse 9.2 Agizor SUSE / openSUSE 16 03-17-2006 12:11 AM
Suse 9.1: suse-build-key (cannot update packages) bodhiopolis Linux - Distributions 1 06-09-2005 03:22 PM
Suse 9.1 and ndiswrapper keith2045 Linux - Wireless Networking 5 02-21-2005 11:29 AM
Does SuSE 9.2 contain ndiswrapper? JWHolloway Linux - Software 4 12-17-2004 09:44 AM
FC3 ndiswrapper - not working after udev update? trey85stang Fedora 0 11-23-2004 09:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration