LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Closed Thread
  Search this Thread
Old 09-06-2005, 07:42 PM   #1
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
Suse 9.3 / 10.0 betas Working Linksys wpc54g card with NDISWRAPPER


Here's how to set up NDISWRAPPER for Linksys wpc54g cards (Broadcomm chipset).
(all actions done as ROOT) Works for 9.3, 10.0 betas 3 and 4.

1) Ensure Ndiswrapper is installed via YAST.
2) copy the 2 files from your LINKSYS windows CD driver to /tmp/linksys -- lsbcmnds.inf and bcmwl5.sys
3) ensure your card is inserted and type ndiswrapper -i /tmp/linksys/lsbcmnds.inf

4) type ndiswrapper -l you should see the following

# ndiswrapper -l
Installed ndis drivers:
lsbcmnds driver present, hardware present

5) enable the wireless network interface -- type modprobe ndiswrapper

6) configure your interface -- edit etc/sysconfig/network/ifcfg-wlan0 so it looks something like this (test it the first few times with no encryption etc etc).

NAME='Linksys WPC54G'
STARTMODE='auto'
WIRELESS_AUTH_MODE='open'
WIRELESS_ESSID='jimbo'
WIRELESS_MODE='Managed'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'
BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK=''



absolutely ensure the 2 DHCLIENT lines are as in the example

7) ensure the interface is recognized by command iwconfig

you should see something like this
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"jimbo" Nickname:"redfox"
Mode:Managed Frequency:2.462 GHz Access Point: 00:0F:3D:97:10:00
Bit Rate=54 Mb/s Tx-Power:15 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption keyff
Power Managementff
Link Quality:100/100 Signal level:-37 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:14 Invalid misc:117 Missed beacon:0

8) if any problems try seeing if your card at least can communicate with the wireless access point by using the command iwlist wlan0 scan

you should get output like this
# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:0F:3D:97:10:00
ESSID:"jimbo"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-42 dBm Noise level:-256 dBm
Encryption keyff
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:22 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=200
Extra:atim=0

9) now we want the module to be loaded at boot time so go into YAST and select system ==> /etc/sysconfig editor

scroll down to SYSTEM==>KERNEL==>MODULES_LOADED_ON_BOOT

add ndiswrapper to the list (if there are any entries just leave a space and type ndiswrapper otherise if it's the only entry just type it in.

10) Now I re-booted as I wanted to make sure it all worked from boot

11) after boot try PING 192.168.1.1 or whatever your router is

12) connect to Internet WIRELESSLY --and enjoy.

BTW loads of other cards work as well -- the main probs are usually

1) not having the correct etc/sysconfig/network/ifcg-wlan0 file

2) using the wrong Windows drivers --doesn't matter if there are newer one's for your device use the one's that came with your CD as these generally seem to work better.

3) Failing to update the /etc/sysconfig to load ndiswrapper on boot.

Cheers

-K

Last edited by 1kyle; 09-06-2005 at 07:48 PM.
 
Old 09-06-2005, 09:53 PM   #2
AndyC
LQ Newbie
 
Registered: Sep 2005
Location: Houston, Tx
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
At last - someone who got the Windows driver installed for me! Thanks, Kyle - I'm still not up and running yet, tho...here's where I am as per your instructions:

4. # ndiswrapper -l
Installed ndis drivers: lsbcmnds driver present
(it doesn't mention that the hardware is present).

5. On doing a modprobe ndiswrapper the response seems fine - I just get the normal prompt, so I continued...

6. edit etc/sysconfig/network/ifcfg-wlan0 - I have no such file, and when I try to create one, I'm told it's not permitted.

What am I missing here?

Andy
 
Old 09-07-2005, 02:50 AM   #3
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Original Poster
Rep: Reputation: 32
Hi Andy

1) the output of your command should look like this

# ndiswrapper -l

Installed ndis drivers:
lsbcmnds driver present, hardware present

2) use YAST to create wlan0 -- chose Network card ===> Other Not detected ===>configure

3) select device type to Wireless, enter wlan0 in configuration name , blank out any names in module name , hardware configuration name , options

4) select pcmcia (X) in the box changing the configuration name back to wlan0 (top row of boxes) if it changes

5) click NEXT

6) fill in the other parameters e.g ESSID, and DHCP (I'm using a D-LINK Wireless adsl router which has a built in DHCP sertver)

7) save this lot

8) NOW edit your file ifcg-wlan0 as per previous post.

9) re-boot -- not really necessary as you can restart wireless with some combinations of ifup, ifdown etc but I can never remember the commands so I just re-boot.

While testing just skip any encryption etc, etc -- just get the card to work and then you can add all the security afterwards.


Hope this helps

Cheers

-K

Last edited by 1kyle; 09-07-2005 at 02:51 AM.
 
Old 09-07-2005, 08:40 AM   #4
AndyC
LQ Newbie
 
Registered: Sep 2005
Location: Houston, Tx
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
Hi, Kyle

Thanks for that info - it's getting there slowly. I've reset the card as wlan0 as specified, edited the ifcg-wlan0 file, made sure ndiswrapper is loaded into the kernel on boot, etc.

I have a suspicion that the results of the ndiswrapper -l command is a clue - there's no mention of hardware being present and the LEDs on the device don't come on as they are now while in Windows. I'm trying to think of anything that I've missed.
 
Old 09-07-2005, 09:14 AM   #5
1kyle
Member
 
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Original Poster
Rep: Reputation: 32
Hi andy --did you install Wireless tools etc --go back into YAST and select everything with WIRELESS --could be you are missing stuff.

I'd re-install NDISWRAPPER again ( remove ndiswrapper by typing rpm -e ndiswrapper or use YAST). Then re-installl with YAST (and at the same time select all the Wireless options).

The LED's should actually come on the card once the PCMCIA service has started (insert the card before booting) even before any networking services are started.


After the PCMCIA service has started you should see the LED on the left of the card as you are looking at it stay on GREEN.

The other Led will flash once it has connected to your WAP (Access point).

Cheers

-K
 
Old 09-08-2005, 11:52 AM   #6
AndyC
LQ Newbie
 
Registered: Sep 2005
Location: Houston, Tx
Distribution: Suse 9.3
Posts: 3

Rep: Reputation: 0
Thanks, Kyle - I'll give that a go and let you know what happens :-)

Andy
 
Old 02-05-2006, 05:13 PM   #7
jdchvacr
LQ Newbie
 
Registered: Jan 2005
Location: Terre Haute, IN
Posts: 8

Rep: Reputation: 0
SUSE linux 10.0 linksys WPC54g card

I installed per the directions and I can't get my wireless card to connect to my router and when you type in: edit
etc/sysconfig/network/ifcfg-wlan0
how do I get the network, which is not listed in the system config file to edit my interface? or how do I get it to connect to the net because it already states that it is connected to the router, it actually says local IP unavailable, how do I make it local IP available? Any assistance would be greatly appreciated.

Thanks
 
Old 02-10-2006, 11:40 PM   #8
youngjan
LQ Newbie
 
Registered: Jan 2006
Location: Czech Republic
Distribution: Suse 10.3 / 64bit
Posts: 13

Rep: Reputation: 0
Hello Kyle,

I am trying to have my D-Link DWL-G650+ having set up at SuSe 10 using your instructions as well as ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.2. I have performed succesfully all steps up to step number 5:

Quote:
Originally Posted by 1kyle
5) enable the wireless network interface -- type modprobe ndiswrapper
Where I am getting the following error: FATAL: Could not open '/lib/modules/2.6.13-15.7-default/extra/ndiswrapper.ko' : No such file or directory.

Please advise what am I doing wrong. I am new to Linux.

Thank you, Jan
 
Old 02-11-2006, 10:13 PM   #9
agilbreath
LQ Newbie
 
Registered: Feb 2006
Location: Birmingham, AL
Distribution: SuSe, RHEL
Posts: 2

Rep: Reputation: 0
Thanks!

Kyle, thanks so much for the clear, easy-to-understand, complete instructions you posted here.

I've gotten the ndiswrapper happily installed and, IF I can ever get the driver for the darned Cisco card in this Thinkpad, with these instructions, I'll be good to go.

I'm a new convert and it has been driving me crazy that this wireless card will work with the SuSE live CD, yet even though the system sees and configures it, the card never sees my wireless network. I've been living on a cat 5 leash for two weeks now and have spent countless hours reading and working on this. I'm giving up and going the ndiswrapper route. Your post is so easy to understand. What a relief!
 
Old 02-13-2006, 01:27 AM   #10
youngjan
LQ Newbie
 
Registered: Jan 2006
Location: Czech Republic
Distribution: Suse 10.3 / 64bit
Posts: 13

Rep: Reputation: 0
Ok, so I have finally managed to have my D-LINK wifi working. The lights are on and I am connected to the router. After entering:

dhcpcd wlan0 -n

I have also obtained my IP address, Gateway address and I can ping it.

Only problem I encountered was that I am not able to obtain my DNS nameserver AUTOMATICALLY. I did some workaround: I logged in using my Windows installation and got the DNS server address from there. Than I went back to Linux and entered it to the /etc/resolv.conf. Now I am up and running on the internet.

My question is, how can I obtain my DNS server automatically using linux? What about if I am in a hotel and so, where it is hard to find out all the details regarding the router. Why Windows connects automatically, however, in Linux, you have to do it manually? Why, when I connect using my wired LAN card via linux I do obtain all things automatically, but I do not obtain them via the wireless interface?
 
Old 02-23-2006, 10:10 PM   #11
_rg
LQ Newbie
 
Registered: Feb 2006
Posts: 3

Rep: Reputation: 0
This is the method I used on Suse 10 to get the WPC54G ver. 1.2 working. It uses Yast instead of the manual configuration edit in the first example.

Install NDISWRAPPER using YAST (Just search for it in YAST CC Software Management)
Copy driver files from CD root (or website); bcmwl5.sys, lsbcmnds.cat, lsbcmnds.inf.
Open root shell
Install Driver
ndiswrapper -i lsbcmnds.inf
ndiswrapper -m
modprobe ndiswrapper
Configure the new hardware with Yast CC
Network Devices
Network Card
Add
Device Type:Wireless
Module: ndiswrapper
On next several pages enter your networks information (Wizard Driven)

Reboot
 
Old 03-16-2006, 03:10 PM   #12
aoberoi
LQ Newbie
 
Registered: Mar 2006
Posts: 17

Rep: Reputation: 0
I'm also having the same problem as Andy.

I have the driver installed but the hardware isnt found.

The lights on my WPC54G are also off.

i tried removing ndiswrapper and reinstalling it as well as any packages with "wireless" in them including wireless-tools.

this is my output of ndiswrapper -l:

Quote:
Installed ndis drivers:
lsbcmnds driver present
 
Old 03-16-2006, 03:19 PM   #13
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Have you thought about posting this in the Tutorials section? It would be easier to find there.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help configuring linksys WPC54G v.2 wireless card on SUSE linux 9.1 izquierdista Linux - Wireless Networking 1 09-15-2005 05:06 AM
Need help setting up Linksys WPC54G with ndiswrapper (SuSE 9.1) niima Linux - Wireless Networking 8 01-03-2005 10:17 AM
WPC54G Linksys card problems with SuSE 9.1 Oostertoaster Linux - Wireless Networking 14 08-04-2004 07:45 AM
Linksys WPC54G - Got card to work with ndiswrapper, after reboot....not working osirus Linux - Wireless Networking 6 06-24-2004 11:31 PM
linksys wpc54g and ndiswrapper mdegerne Linux - Wireless Networking 1 04-23-2004 11:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 02:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration