LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Suse 9.3 Linksys wpc54g card with NDISWRAPPER (https://www.linuxquestions.org/questions/linux-wireless-networking-41/suse-9-3-linksys-wpc54g-card-with-ndiswrapper-360874/)

1kyle 09-06-2005 08:42 PM

Suse 9.3 / 10.0 betas Working Linksys wpc54g card with NDISWRAPPER
 
Here's how to set up NDISWRAPPER for Linksys wpc54g cards (Broadcomm chipset).
(all actions done as ROOT) Works for 9.3, 10.0 betas 3 and 4.

1) Ensure Ndiswrapper is installed via YAST.
2) copy the 2 files from your LINKSYS windows CD driver to /tmp/linksys -- lsbcmnds.inf and bcmwl5.sys
3) ensure your card is inserted and type ndiswrapper -i /tmp/linksys/lsbcmnds.inf

4) type ndiswrapper -l you should see the following

# ndiswrapper -l
Installed ndis drivers:
lsbcmnds driver present, hardware present

5) enable the wireless network interface -- type modprobe ndiswrapper

6) configure your interface -- edit etc/sysconfig/network/ifcfg-wlan0 so it looks something like this (test it the first few times with no encryption etc etc).

NAME='Linksys WPC54G'
STARTMODE='auto'
WIRELESS_AUTH_MODE='open'
WIRELESS_ESSID='jimbo'
WIRELESS_MODE='Managed'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'
BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
USERCONTROL='no'
WIRELESS_AP=''
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK=''



absolutely ensure the 2 DHCLIENT lines are as in the example

7) ensure the interface is recognized by command iwconfig

you should see something like this
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"jimbo" Nickname:"redfox"
Mode:Managed Frequency:2.462 GHz Access Point: 00:0F:3D:97:10:00
Bit Rate=54 Mb/s Tx-Power:15 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-37 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:14 Invalid misc:117 Missed beacon:0

8) if any problems try seeing if your card at least can communicate with the wireless access point by using the command iwlist wlan0 scan

you should get output like this
# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:0F:3D:97:10:00
ESSID:"jimbo"
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-42 dBm Noise level:-256 dBm
Encryption key:off
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5.5 Mb/s
Bit Rate:11 Mb/s
Bit Rate:22 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:12 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=200
Extra:atim=0

9) now we want the module to be loaded at boot time so go into YAST and select system ==> /etc/sysconfig editor

scroll down to SYSTEM==>KERNEL==>MODULES_LOADED_ON_BOOT

add ndiswrapper to the list (if there are any entries just leave a space and type ndiswrapper otherise if it's the only entry just type it in.

10) Now I re-booted as I wanted to make sure it all worked from boot

11) after boot try PING 192.168.1.1 or whatever your router is

12) connect to Internet WIRELESSLY --and enjoy.

BTW loads of other cards work as well -- the main probs are usually

1) not having the correct etc/sysconfig/network/ifcg-wlan0 file

2) using the wrong Windows drivers --doesn't matter if there are newer one's for your device use the one's that came with your CD as these generally seem to work better.

3) Failing to update the /etc/sysconfig to load ndiswrapper on boot.

Cheers

-K

AndyC 09-06-2005 10:53 PM

At last - someone who got the Windows driver installed for me! Thanks, Kyle - I'm still not up and running yet, tho...here's where I am as per your instructions:

4. # ndiswrapper -l
Installed ndis drivers: lsbcmnds driver present
(it doesn't mention that the hardware is present).

5. On doing a modprobe ndiswrapper the response seems fine - I just get the normal prompt, so I continued...

6. edit etc/sysconfig/network/ifcfg-wlan0 - I have no such file, and when I try to create one, I'm told it's not permitted.

What am I missing here?

Andy

1kyle 09-07-2005 03:50 AM

Hi Andy

1) the output of your command should look like this

# ndiswrapper -l

Installed ndis drivers:
lsbcmnds driver present, hardware present

2) use YAST to create wlan0 -- chose Network card ===> Other Not detected ===>configure

3) select device type to Wireless, enter wlan0 in configuration name , blank out any names in module name , hardware configuration name , options

4) select pcmcia (X) in the box changing the configuration name back to wlan0 (top row of boxes) if it changes

5) click NEXT

6) fill in the other parameters e.g ESSID, and DHCP (I'm using a D-LINK Wireless adsl router which has a built in DHCP sertver)

7) save this lot

8) NOW edit your file ifcg-wlan0 as per previous post.

9) re-boot -- not really necessary as you can restart wireless with some combinations of ifup, ifdown etc but I can never remember the commands so I just re-boot.

While testing just skip any encryption etc, etc -- just get the card to work and then you can add all the security afterwards.


Hope this helps

Cheers

-K

AndyC 09-07-2005 09:40 AM

Hi, Kyle

Thanks for that info - it's getting there slowly. I've reset the card as wlan0 as specified, edited the ifcg-wlan0 file, made sure ndiswrapper is loaded into the kernel on boot, etc.

I have a suspicion that the results of the ndiswrapper -l command is a clue - there's no mention of hardware being present and the LEDs on the device don't come on as they are now while in Windows. I'm trying to think of anything that I've missed.

1kyle 09-07-2005 10:14 AM

Hi andy --did you install Wireless tools etc --go back into YAST and select everything with WIRELESS --could be you are missing stuff.

I'd re-install NDISWRAPPER again ( remove ndiswrapper by typing rpm -e ndiswrapper or use YAST). Then re-installl with YAST (and at the same time select all the Wireless options).

The LED's should actually come on the card once the PCMCIA service has started (insert the card before booting) even before any networking services are started.


After the PCMCIA service has started you should see the LED on the left of the card as you are looking at it stay on GREEN.

The other Led will flash once it has connected to your WAP (Access point).

Cheers

-K

AndyC 09-08-2005 12:52 PM

Thanks, Kyle - I'll give that a go and let you know what happens :-)

Andy

jdchvacr 02-05-2006 06:13 PM

SUSE linux 10.0 linksys WPC54g card
 
I installed per the directions and I can't get my wireless card to connect to my router and when you type in: edit
etc/sysconfig/network/ifcfg-wlan0
how do I get the network, which is not listed in the system config file to edit my interface? or how do I get it to connect to the net because it already states that it is connected to the router, it actually says local IP unavailable, how do I make it local IP available? Any assistance would be greatly appreciated.

Thanks

youngjan 02-11-2006 12:40 AM

Hello Kyle,

I am trying to have my D-Link DWL-G650+ having set up at SuSe 10 using your instructions as well as ndiswrapper.sourceforge.net/mediawiki/index.php/Suse_Professional_9.2. I have performed succesfully all steps up to step number 5:

Quote:

Originally Posted by 1kyle
5) enable the wireless network interface -- type modprobe ndiswrapper

Where I am getting the following error: FATAL: Could not open '/lib/modules/2.6.13-15.7-default/extra/ndiswrapper.ko' : No such file or directory.

Please advise what am I doing wrong. I am new to Linux.

Thank you, Jan

agilbreath 02-11-2006 11:13 PM

Thanks!
 
Kyle, thanks so much for the clear, easy-to-understand, complete instructions you posted here.

I've gotten the ndiswrapper happily installed and, IF I can ever get the driver for the darned Cisco card in this Thinkpad, with these instructions, I'll be good to go.

I'm a new convert and it has been driving me crazy that this wireless card will work with the SuSE live CD, yet even though the system sees and configures it, the card never sees my wireless network. I've been living on a cat 5 leash for two weeks now and have spent countless hours reading and working on this. I'm giving up and going the ndiswrapper route. Your post is so easy to understand. What a relief!

youngjan 02-13-2006 02:27 AM

Ok, so I have finally managed to have my D-LINK wifi working. The lights are on and I am connected to the router. After entering:

dhcpcd wlan0 -n

I have also obtained my IP address, Gateway address and I can ping it.

Only problem I encountered was that I am not able to obtain my DNS nameserver AUTOMATICALLY. I did some workaround: I logged in using my Windows installation and got the DNS server address from there. Than I went back to Linux and entered it to the /etc/resolv.conf. Now I am up and running on the internet.

My question is, how can I obtain my DNS server automatically using linux? What about if I am in a hotel and so, where it is hard to find out all the details regarding the router. Why Windows connects automatically, however, in Linux, you have to do it manually? Why, when I connect using my wired LAN card via linux I do obtain all things automatically, but I do not obtain them via the wireless interface?

_rg 02-23-2006 11:10 PM

This is the method I used on Suse 10 to get the WPC54G ver. 1.2 working. It uses Yast instead of the manual configuration edit in the first example.

Install NDISWRAPPER using YAST (Just search for it in YAST CC Software Management)
Copy driver files from CD root (or website); bcmwl5.sys, lsbcmnds.cat, lsbcmnds.inf.
Open root shell
Install Driver
ndiswrapper -i lsbcmnds.inf
ndiswrapper -m
modprobe ndiswrapper
Configure the new hardware with Yast CC
Network Devices
Network Card
Add
Device Type:Wireless
Module: ndiswrapper
On next several pages enter your networks information (Wizard Driven)

Reboot

aoberoi 03-16-2006 04:10 PM

I'm also having the same problem as Andy.

I have the driver installed but the hardware isnt found.

The lights on my WPC54G are also off.

i tried removing ndiswrapper and reinstalling it as well as any packages with "wireless" in them including wireless-tools.

this is my output of ndiswrapper -l:

Quote:

Installed ndis drivers:
lsbcmnds driver present

XavierP 03-16-2006 04:19 PM

Have you thought about posting this in the Tutorials section? It would be easier to find there.


All times are GMT -5. The time now is 01:04 PM.