LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 05-23-2007, 12:08 PM   #1
Plastech
Member
 
Registered: Jul 2006
Posts: 63

Rep: Reputation: 15
Unhappy Sometimes works, sometimes doesn't? WG511U on debian with Ndiswrapper


I have a minimal debian install with a netgear wg511u pcmcia card running with ndiswrapper. About half the time a boot the laptop, it is able to connect immediately to my network, and the other half of the time, it cannot (boot takes forever as it runs through multiple attempts of the dhclient/ifup screen). When it doesn't work at boot, no matter how many times I try dhclient, etc. from the command line, it's no good. Yet after enough reboots, it works fine. Any idea what's causing this? Or, better yet, what might fix it?

Thanks, I love this forum.
 
Old 05-23-2007, 12:36 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
My solution would be to get rid of ndiswrapper and use the native Linux drivers (madwifi). Never could understand why people insist on using Windows software on Linux equipment.
 
Old 05-23-2007, 12:38 PM   #3
Plastech
Member
 
Registered: Jul 2006
Posts: 63

Original Poster
Rep: Reputation: 15
I didn't realize that that would work. Okay, I'll give it a go. Thank you.
 
Old 05-23-2007, 01:50 PM   #4
Plastech
Member
 
Registered: Jul 2006
Posts: 63

Original Poster
Rep: Reputation: 15
Worked like a charm! Thank you so much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear WG511U via ndiswrapper on minimal debian install Plastech Linux - Wireless Networking 1 05-16-2007 08:41 PM
ndiswrapper works, but no radio? Adrian Baker Linux - Wireless Networking 8 01-12-2007 02:45 PM
can't connect to an AP with Netgear WG511U dracolich Linux - Wireless Networking 0 04-11-2006 01:32 PM
ndiswrapper works, but iwconfig does nothing whit2333 Linux - Wireless Networking 4 12-16-2005 04:54 PM
ndiswrapper works but doesnt? AKA-tex Linux - Wireless Networking 7 08-21-2005 05:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration