-   Linux - Wireless Networking (
-   -   Slackware 11 + Belkin USB Wireless Card = No Connection? (

Sir.Del 02-27-2007 08:33 PM

Slackware 11 + Belkin F5D7050 USB Wireless Device = No Connection?
Hi all,

Having some problems connecting to my home wireless network.

Connecting through a windows pc to the network seems to work flawlessly.

I've been able to set the essid and wep key...but not able to get an IP

Running an iwlist wlan0 scan brings up all of the networks available.

iwconfig wlan0 essid <my essid>
iwconfig wlan0 key <mykey>
dhcpcd wlan0

Are the commands that i am running, but nothing at all. DHCP just times out.

I also downloaded getwifi and tried using that...however i keep get the following dump:
device is wlan0
key is off
wep key set to off
signal is 0
not high enough

Any help guys?

2Gnu 02-27-2007 10:03 PM

What's the output of iwconfig wlan0 and ifconfig wlan0?

Sir.Del 02-28-2007 02:15 AM

iwconfig wlan0:


root@bender:~# iwconfig wlan0
wlan0 IEEE 802.11g ESSID:"landed" Nickname:"bender"
Mode:Auto Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:20 dBm Sensitivity=-121 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:6598-7DC0-1AB6-DFC9-E053-6840-F6 Security mode:restricted
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
ifconfig wlan0:

root@bender:~# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:17:3F:71:60:A1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:4 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

2Gnu 02-28-2007 08:21 AM

The adapter is not associated with the wireless network. That's usually the result of a WP key mismatch, MAC address filtering or WEP mode setting.

Double-check the WEP key. Make sure the ESSID is being broadcast. Turn off MAC address filtering, if it's being used. When you set the WEP key, set the mode to open authentication.
ex: iwconfig wlan0 key open 1234-5678-...

Sir.Del 03-01-2007 01:39 AM

Tried what you suggested and nothing seems to have worked

Running 2.4.33 kernel, but that shouldn't make a difference?

All times are GMT -5. The time now is 08:05 AM.