LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 03-04-2006, 06:29 AM   #1
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Rep: Reputation: 17
setting up wireless with fedora core4


I am sure this question was asked previously somewhere, but somehow the search.php wouldn't run my query, so I was wondering if someone could tell me where this questions is answered.

I've looked at the tutorial, and I've looked at the one with subject: " intel pro 2200 +slackware ". But since I am a total noob with linux, I've decided to be safe and ask.

This machine with fc4 is IBM x31 with intel pro 2100, which only supports 802.11b.

I would appreciate all the help I get.

Regards
 
Old 03-04-2006, 08:12 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Follow the instructions here;

http://fedoranews.org/contributors/j...ence/wireless/

The link for ipw2100 and FC4 is;

http://www.atrpms.net/dist/fc4/ipw2100/

You want the ipw2100-1.2.0-41.rhfc4.at.i386.rpm and the ipw2100-kmdl rpm for your current kernel.

The firmware rpm can be found here;

http://stentz.freshrpms.net/rpm.html?id=866
 
Old 03-05-2006, 06:47 AM   #3
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Thanks a lot I'll try soon and and reply again.
 
Old 03-05-2006, 07:18 AM   #4
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
hmm.. i don't have the right version of ipw2100-kmdl .. if I type

rmp -q kernel, i get

kernel-2.6.11-1.1369_FC4

Does this look like it's out of date?

Thanks
 
Old 03-05-2006, 09:04 AM   #5
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Yes your kernel is out of date, have you not been keeping up with the updates?? The latest kernel is;

http://www.redhat.com/archives/fedor.../msg00003.html

As a suggestion, learn how to use and configure yum and update the system;

http://fedora.redhat.com/docs/yum/index.html

http://www.fedorafaq.org/#installsoftware
 
Old 03-05-2006, 09:21 PM   #6
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Thanks a lot.. I am using this window-formatted update and it keeps asking me to click "yes" for things are not signed with GPG blah. And all the files are not signed with GPG

Last edited by rlee923; 03-05-2006 at 09:24 PM.
 
Old 03-07-2006, 04:50 AM   #7
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Finally updated everything with yum and trying to get wireless working.

I am really sorry but could you point out which kdml to download?

kernel-2.6.15-1.1833_FC4

My current kernel is this and I don't really know which one to get because I see 4 files with same kernel name.

Regards
 
Old 03-07-2006, 05:17 AM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
If yum is configured for use with the ATrpms repo, as root;

yum install ipw2100-kmdl

If not then;

rpm -qa --queryformat "%{n}-%{v}-%{r}.%{arch}.rpm\n" kernel

Sample results; kernel-2.6.15-1.1833_FC4.i686.rpm

Based on the sample results, download and install;

ipw2100-kmdl-2.6.15-1.1833_0.99.rhfc4.cubbi_swsusp2_8k-1.2.0-41.rhfc4.at.i686.rpm
 
Old 03-07-2006, 07:40 AM   #9
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Noo.. still haven't got it working

I followed the instructions given from above previous post

and I typed the first line of the instruction which is

sudo rpm -Uvh ipw2200-*.rpm kernel-module-ipw2200-*.rpm ipw2200-firmware-*.rpm

and I did replace 2200 to 2100 and kernel-module to appropriate filename

but it says the file has been already added and it skipps to read from it.

Anyway it's good upto that part.

The next intstruction is to get the device detected on the network setting.

And I do have it.

So I tried to follow the next instruction, but I can't find where the wireless tap is.

I did't think renaming my ssid is necessary so I skipped that part.

How to I get the wireless tap shown?
 
Old 03-07-2006, 07:57 AM   #10
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Actually I get this error for typing first command

error: Failed dependencies:
/boot/vmlinuz-2.6.15-1.1833_0.99.rhfc4.cubbi_swsusp2_8k is needed by ipw2100-kmdl-2.6.15-1.1833_0.99.rhfc4.cubbi_swsusp2_8k-1.2.0-41.rhfc4.at.i686
ieee80211-kmdl-2.6.15-1.1833_0.99.rhfc4.cubbi_swsusp2_8k >= 1.0.2 is needed by ipw2100-kmdl-2.6.15-1.1833_0.99.rhfc4.cubbi_swsusp2_8k-1.2.0-41.rhfc4.at.i686
ipw2100-firmware = 1.3 is needed by ipw2100-kmdl-2.6.15-1.1833_0.99.rhfc4.cubbi_swsusp2_8k-1.2.0-41.rhfc4.at.i686

It's starting to get a little irretating slowly...

I
 
Old 03-18-2006, 07:42 PM   #11
ericwho
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Rep: Reputation: 0
Hopefully this will help out. Here are the rpm's that I downloaded and installed them in this order. Sorry I couldn't post links, still got under 5 posts. All rpm's except for the firmware were downloaded from atrpms.net.

1. ieee80211-kernheaders-1.1.12-9.rhfc4.at.i386.rpm
2. ieee80211-kmdl-2.6.15-1.1833_FC4-1.1.12-9.rhfc4.at.i686.rpm
3. ieee80211-1.1.12-9.rhfc4.at.i386.rpm
4. ipw2100-firmware-1.3-2.noarch.rpm
5. ipw2100-kmdl-2.6.15-1.1833_FC4-1.2.0-41.rhfc4.at.i686.rpm
6. ipw2100-1.2.0-41.rhfc4.at.i386.rpm

I'm also running an IBM x31 with FC4. My kernel is kernel-2.6.11-1.1369_FC4
 
Old 03-22-2006, 12:32 AM   #12
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Thanks for letting me know what to donwload, I think I am very close to get it running.

I've installed all the packages, gone through the settings and the devices turns on and blinks.

even iwlist works, scanning works fine but I don't know how to connect it up.

i thought it is

$ iwconfig eth1 essid YourNetworkName

this, so i typed

iwconfig eth1 essid wireless

where 'wireless' is the ssid.

doesn't seem to work like this coz after this I am supposed to actviate the device by typing

ifup eth1

and it complains as follows:

Error : unrecognised wireless request "kb/s"

Determining IP information for eth1... failed; no link present. Check cable?

Thanks a lot to lenard and ericwho, for getting me this far. I didn't know it's this hard to setup this device working.

Can you help me a bit more plz?

Thanks
 
Old 03-22-2006, 12:33 AM   #13
rlee923
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora Core 6
Posts: 88

Original Poster
Rep: Reputation: 17
Thanks for letting me know what to donwload, I think I am very close to get it running.

I've installed all the packages, gone through the settings and the devices turns on and blinks.

even iwlist works, scanning works fine but I don't know how to connect it up.

i thought it is

$ iwconfig eth1 essid YourNetworkName

this, so i typed

iwconfig eth1 essid wireless

where 'wireless' is the ssid.

doesn't seem to work like this coz after this I am supposed to actviate the device by typing

ifup eth1

and it complains as follows:

Error : unrecognised wireless request "kb/s"

Determining IP information for eth1... failed; no link present. Check cable?

Thanks a lot to lenard and ericwho, for getting me this far. I didn't know it's this hard to setup this device working.

Can you help me a bit more plz?

Thanks
 
Old 03-23-2006, 08:51 AM   #14
ericwho
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Rep: Reputation: 0
still learning my way around linux so i'm not too sure i can help you with terminal commands, but i can tell you the way i did it. i'm using gnome, so i went to desktop>system settings>network. if your device isn't listed, then click new up top, then choose 'wireless connection' and hit forward. your device should be listed there.

as for the wireless connection stuff, my home network uses wep, so here's what i put into the fields:

mode: managed
network name (ssid): (.)specified: networkssid
channel: (left at 1)
transmit rate: (left at 11mb/s)
key: 0xwepkey

remember to add the '0x' in front of the key, cuz that was what gave me trouble. hope this helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core4 and g77 compiler hhegab Programming 8 12-18-2005 04:57 PM
f5d6020 v2 in Fedora Core4 Lib_not_found Linux - Networking 1 10-31-2005 02:16 AM
Fedora Core4 issues... DrunkenDisciple Linux - Software 3 10-12-2005 12:01 PM
Wireless Internet with Interl 2200BG on Fedora Core4 makaveli221 Linux - Wireless Networking 5 09-28-2005 02:45 AM
install fedora core4 hi_all General 3 05-10-2005 07:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 07:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration