LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Setting up wireless network/internet connection in SuSE 10 (https://www.linuxquestions.org/questions/linux-wireless-networking-41/setting-up-wireless-network-internet-connection-in-suse-10-a-401173/)

ImpelGD 01-09-2006 08:47 AM

Setting up wireless network/internet connection in SuSE 10
 
Hello there; any suggestions welcome - I'm a complete Linux noob.

Wireless network card: ASUS WL-130g
Wireless router: D-Link DSL-G624M

Have used YaST in SuSE Linux 10 to configure the installed wireless card with a few different settings. This hardware does work okay in Windows XP and wireless signal strength is being reported in Linux, but I can't get internet access working so I expect I'm not using the correct settings.

Am trying to use as DHCP client. I'm not sure what 'host name' and 'domain' are exactly. Have tried setting these manually to an arbitrary name and having them set using DHCP, but the online update says it can't resolve the required location.

WPA-PSK settings have been inserted (infrastructure or equivalent selected). Have tried changing firewall locations.

If I need to supply any other details please let me know. Thanks.

Caeda 01-10-2006 07:45 PM

Host Name? Domain? Why are you messing with those if you don't know what they are for...
When I open up the Network Card Setup in Yast2 all I have to to is click "Wireless" and type in the driver name for the card. Then, click next twice and it asks me for the Network Name and Encryption key, and it's done...

madwifimoody 01-11-2006 02:29 AM

have you set up the gateway address im not sure how you would do it with your disto mine has an interface where i can just tell it where the gateway is to connect to the internet i hope that might help

ImpelGD 01-11-2006 05:35 PM

Thanks for the replies.

I was messing with the host name and domain because it wasn't working with them set to defaults.

I tried inserting the default gateway address, madwifimoody, as 192.168.1.1 (my ADSL routers IP address). I did get an internet connection of sorts, but it was amazingly slow. Now I can't seem to get anything. When I try loading a web page in the browser it says Error loading http://www.domainname.co.uk/ Unknown host (or something similar).

The card is shown as using the RT2500 chipset in YaST. Do I need to mess with the driver? Hope not as I wouldn't know where to start.

Signal strength isn't brilliant at this machine but I don't think that's the problem because it works consistently in Windows. Have disabled firewall for testing.

I've been doing some research and have tried using iwconfig. The funny thing is, no matter what settings I put into the YaST control panel they don't seem to be reflected in the iwconfig output... I don't understand. The interface my wireless card is listed as being on in iwconfig is ra0.

ImpelGD 01-16-2006 08:24 AM

I'm pretty sure the problem is that Kinternet doesn't support WPA-PSK encryption - think I'll be okay from here on (at least with the internet connection ;)).

Thanks again.

abelloda 01-21-2006 04:25 AM

Quote:

Originally Posted by ImpelGD
I'm pretty sure the problem is that Kinternet doesn't support WPA-PSK encryption - think I'll be okay from here on (at least with the internet connection ;)).

Thanks again.


Im having the same problem - it detects the network and all, but dosent connect at all. I think it's the WPA-PSK encryption problem. How'd you solve the internet connection problem?

monsm 01-23-2006 12:54 PM

Hi,
As ImpelGD indicate, WPA is right at the cutting edge of things.
If you are just setting up the machine for the first time with Linux, try using WEP or even no encryption first in order to make sure drivers etc are correctly configured.
When you know the connection is working you can add WPA. Adding WPA is a whole new level of complexity.
Personally I only use 64 bit WEP. For a standard home network I would think it's enough. You can also later add MAC address access control in most routers and you can hide the SSID as well.

abelloda 01-23-2006 02:26 PM

Thank you, but it did work with the WPA. Don't really know how yet, but im counting my blessings and hoping i'll never have the same problem again. BUt then again, if i do - i'll try your suggestion.


All times are GMT -5. The time now is 11:12 AM.