LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 08-18-2005, 06:05 PM   #1
pafrica
Member
 
Registered: Aug 2004
Location: canada
Distribution: Slackware
Posts: 66

Rep: Reputation: 15
segmentation fault upon loading ipw2200


Hi everyone,

I have an Asus z71v laptop with an intel 2915 mini pci nic card. I've recompiiled my kernel with all necessary options for wifi and have installed the ipw2200 files and firmware. When I try to load the ipw2200 drivers it get the error message:

./load line 79: segmentation fault modprobe $i

The ipw2200 discussion boards on sourceforge weren't much help. Does anyone have an idea what might be causing the fault?
 
Old 08-18-2005, 07:31 PM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
How are you loading it? insmod? modprobe?
If you are doing it either way - open that modules source - find line 79 - figure out what $i is.
I would maybe switch it to $1 - maybe $0 depending on the language.....
 
Old 08-19-2005, 03:29 AM   #3
pafrica
Member
 
Registered: Aug 2004
Location: canada
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 15
Thanks PenguinPwrdBox.

It was actually a conflict with the older version i had previously installed which needed to be cleaned up.

So the drivers load properly now but doing ifconfig puts my wireless on eth0 and the wired on eth1. I connect to the internet through the wire. How do i change the interfaces?
 
Old 08-19-2005, 10:03 AM   #4
PenguinPwrdBox
Member
 
Registered: Oct 2003
Posts: 568

Rep: Reputation: 30
Which distribution are you using?
 
Old 08-19-2005, 04:07 PM   #5
pafrica
Member
 
Registered: Aug 2004
Location: canada
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 15
Oh right. I'm using Slackware 10 with a 2.6.9 kernel. Sorry, i should have been more specific. I keep forgetting that a lot of stuff are distro specific.
 
Old 08-23-2005, 09:47 PM   #6
pafrica
Member
 
Registered: Aug 2004
Location: canada
Distribution: Slackware
Posts: 66

Original Poster
Rep: Reputation: 15
<bump>

anyone?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika SUSE / openSUSE 2 12-02-2005 10:34 AM
segmentation fault libriana Linux - Newbie 2 06-10-2005 06:52 PM
ipw2200 not loading the-sloth Linux - Wireless Networking 7 03-30-2005 08:14 PM
Segmentation fault loading plugin (gstreamer) Saur2004 Linux - Software 0 11-29-2004 03:55 PM
ipw2200 seems to be loading OK but can't slackist Linux - Wireless Networking 12 11-05-2004 07:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 04:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration