-   Linux - Wireless Networking (
-   -   RTL8192 WiFi-loaded driver but unknown next step (

merlin1012 11-07-2011 09:29 PM

RTL8192 WiFi-loaded driver but unknown next step
Hoping someone can help.
Starting with a fresh install of Ubuntu 10.04;
copied the supplied .tar.gz file to the desktop;
extracted to a directory "beneath" the desktop;
ran make (got some ERROR that was corrected by changing line 712 to 0);
re-ran make;
sudo make install;
iwconfig yields:

lo        no wireless extensions.

eth0      no wireless extensions.

pan0      no wireless extensions.

wlan0    unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Access Point: Not-Associated  Sensitivity:0/0 
          Retry:off  RTS thr:off  Fragment thr:off
          Power Management:off
          Link Quality=0/100  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

sudo modprobe r8192se_pci (no change)

The light is blinking on the USB device but Network Connections doesn't "see" it.

any more details that might be helpful please ask.

I've tried following the advice of others & this is as far as I've gotten. (What step on what Thread am I missing?)

Thanks in advance if you can help!

fukawi1 11-09-2011 05:58 AM

I dont use ubuntu so forgive my ignorance, but what do you mean by "Network Connections"?

iwconfig is showing the device, so the modules all appear to be loaded correctly, but you can check them with

# lsmod | grep r8192se_pci
The next step is finding an AP to associate with.


# ifconfig wlan0 up && iwlist scan
# iwconfig essid "some essid name" key $some_passphrase
# dhclient wlan0

Depending on your AP there may be other options that need to be passed to iwconfig.
See "man iwconfig" for how to do that.

merlin1012 11-13-2011 08:17 PM

Hi fukawi1;
Thanks for responding!

Results of the "lsmod" command:

lsmod | grep r8192se_pci
The "ifconfig wlan0 up" command displays my network (plugged or unplugged, cable).

The "iwconfig essid...key..." command went thru but no change (I did repeat all these commands without the cable).

"dhclient wlan0" seemed to be similar to "ping", several lines like:

DHCPDISCOVER on wlan0 to port 67 interval 7
but then ended with:

No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Wish I could help looking outside what were trying. 8^(

The "Network Connections" is just an Ubuntu GUI. Trying to do the same thing we're doing thru the Terminal window?

fukawi1 11-14-2011 01:26 AM

Out of curiosity, the loaded module is "r8192se_pci"
PCI would suggest it is a PCI wireless adapter...

Perhaps you need a driver specific to USB adapters?

merlin1012 11-15-2011 09:29 PM

I agree with the PCI notice & was wondering the same thing myself.

Also wanted to mention when I ran "lsmod" there is:

8192cu                309895  0
Not sure if that changes anything.

I did try contacting the manufacturer, no response yet, guess I'll try again. 8^(

Thanks for trying! If you think of anything else to try please RESPOND.

merlin1012 11-15-2011 11:16 PM

I have WiFi!!!

Here's what I did (with the help of thread #1329254 on Ubuntu Forums &
- edited etc/modules: replaced r8192se_pci with r8192s_usb
- using Network Connections (Ubuntu GUI), entered network name (SSID) & key (same as essid & key in iwconfig)
- re-ran (after changing to the driver directory):
- make clean
- make
- make install
- reboot

The adapter still just blinks, but it connects!!!

Thanks for helping me fukawi1! By raising the question you made me look deeper!

Hopefully this thread will help someone else.

varghesejoyvarghese 11-17-2011 03:26 AM

I am not getting wifi.I am using the laptop latitude d630 and using ubuntu 10.1.I am having wifi card embeded.

All times are GMT -5. The time now is 05:32 AM.