LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 04-11-2004, 05:37 AM   #1
Nanthrax
LQ Newbie
 
Registered: Apr 2004
Location: France
Posts: 2

Rep: Reputation: 0
Rtl8180 and Belkin F5D6020 ver 3


Hello all,

I have a Belkin F5D6020 ver 3 wireless card.

This card use a Realtek 8180 chipset.

If I make a cardctl ident, I have :
Socket 0:
product info: "Realtek", "Rtl8180"
manfid: 0x0000, 0x024c
function: 6 (network)

When I put the card in the pcmcia slot, I have this in the /var/log/syslog :
cs: cb_alloc(bus 2): vendor 0x1799, device 0x6020
PCI: Enabling device 02:00.0 (0000 -> 0003)

So I have downloaded the Rtl8180 module at the realtek website, I try to compile.

Firstly I have try modifying the r8180_pci_init.c (line 59) with 0x1799 and 0x6020.
When I try insmod -f rtl8180_24x.o, I have a segfault apparently du to a conflict with agpgart. So I remove rmmod agpgart and try again, but segfault with jds (if I remeber).

A this point, I have try to recompile the rtl8180 module using other values in rt8180_pci_init.c. I have try with value return by the cardctl ident (0x0000 and 0x024c).
Now the module load but no device found

I use Debian Sid with a 2.4.25 kernel.

Someone has an idea ?

Thanks
 
Old 04-13-2004, 01:12 PM   #2
admiralissimus
LQ Newbie
 
Registered: Apr 2004
Location: Hungary, Europe
Posts: 1

Rep: Reputation: 0
Hi,
I have exactly the same problem with a rtl8180 card.
I have tried Debian with kernel 2.4.18, 2.4.25 and 2.4.20 - as it is suggested on the realtek home page - with gcc 2.95, gcc.2.96, and the suggested 3.2.2
always Seg.Fault while iwpriv wlan0 enable
Finally I tried RedHat 9, but with the same result. If IO_FLAGS was set to RTL_MEM_MAP, the driver could be loaded but the card was not worked...
If you have further info. plz notify me.

Admiral
 
Old 04-19-2004, 10:54 AM   #3
Nanthrax
LQ Newbie
 
Registered: Apr 2004
Location: France
Posts: 2

Original Poster
Rep: Reputation: 0
Success.

I have compiled a 2.4.20 kernel from sources.

I have compiled the realtek module (this one design for the 2.4.20 kernel).

It load with only a warning.

I have made modification on the wlanup script (which made different call of iwpriv) provide by with the realtek module and launch it, all go right.

I use the infra mode with an AP.

If someone want more information about this, send me a mail (jbonofre@phpfr.org) or post here.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Belkin F5D6020 Problems ... again! finchee Linux - Hardware 0 03-16-2005 03:41 PM
Belkin F5D6020 in Linux akjmicro Linux - Wireless Networking 2 01-04-2005 10:31 AM
Belkin F5D6020 Realtek RTL8180 wi-ft card on RH Linux 9.0 pvrbharg Linux - Wireless Networking 5 06-28-2004 10:52 AM
Problems with Belkin F5D6020 ver.2 and Mandrake 9.2 six_fingerz Linux - Wireless Networking 2 03-04-2004 01:57 AM
suse 8.2 wlan Belkin F5d6020 Ver.2 Fozzybear Linux - Newbie 5 10-28-2003 06:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration