-   Linux - Wireless Networking (
-   -   Routing between a wired ethernet (internet connection) and a wireless card (home net) (

ner0 11-25-2004 02:52 PM

Routing between a wired ethernet (internet connection) and a wireless card (home net)

Firstly I would like to thank you all for your help with my previous problem concerning selecting my ethernet (eth0) as the internet connection. This all now works fine, and eth0 is totally configured.

My problem at this stage is enabling the wireless interface also, I found that doing a "netconfig" would remove my eth0 settings, and only configure the wireless network. I also found that in order for the eth0 to work, eth1 had to be disabled, this; I presume is a consequence of misconfigured routing.

from a "route -n" query, I get the correct destinations of the eth0 device, along with gateways etc, and this gateway is also defined as default in /etc/rc.d/rc.inet1.conf, but nothing from eth1 (i know this should happen because It isn't told to use dhcp in the rc.d/rc.inte1.conf)...

I know my eth1 device is detected from both lspci and ifconfig, and the penultimate question I have is:

How can i configure my routing (i am assuming this is the issue) to route network packets through eth1, and internet packets through eth0...

preferably, but not essentially, I would aspire to do this without the need of going offline.

ilikejam 11-25-2004 03:34 PM


What you would do is make eth0 the default route, and do 'route add -net netmask eth1' (assuming your network is using the 192.168.0.x address space). That would route all internal network traffic to eth1, and everything else should go to eth0. Hopefully.

You shouldn't have to go offline to do this.


ner0 11-25-2004 05:51 PM

Thanks for the reply Dave, I had thoughts of it being along those lines, however I get an error from SIOCADDRT saying "No Such Device", I personally have no idea what this means, any ideas as to what I should refine?

ilikejam 11-25-2004 08:13 PM

Hi again.

Try doing 'ifconfig eth1 up' first. I'm guessing that's what the problem is, however I get the same error if I try to configure a device which doesn't exist, so it might be a driver issue.


ner0 11-26-2004 07:33 AM

yeah, I'd also think it would be a driver issue now, however I know the eth1 has been working. no kernel modules have been changed, only the inet1.conf.

still getting the same error by the way, so right now I'm pretty confused

ner0 11-28-2004 01:54 PM

Ok, I realise this thread died, but after acknowledging the idea that my card may infact not be recognised by my system I tried other things...

I've come across "iwconfig" and it certainly does appear that "eth1" is up and connected to the network, here's my results of iwconfig:


eth1 IEEE 802.11-DS ESSID:"belkin54g" Nickname:"dtop"
Mode:Managed Frequency:2.462GHz Access Point: 00:30:F1:AF:B8:08
Bit Rate:2Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:92/92 Signal level:5/153 Noise level:112/153
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
would lead me to believe theres just one simple thing I could do to fix this, but for the life of me I can't find out what.

;note, In /etc/rc.d/rc.inet1.conf, the USE DHCP for eth1 is set to OFF, this is one suspicion I have as to why it does not work, however enabling it scraps my settings for eth0.

your help is appreciated :)


ilikejam 11-28-2004 02:07 PM

What do you get when you run ifconfig on its own (after doing 'ifconfig eth1 up')?


ner0 11-28-2004 05:35 PM

heres the ifconfig results; sorry I'm 3 hours late lol...


eth0 Link encap:Ethernet HWaddr 00:0C:76:A8:1B:C0
inet Bcast: Mask:
EtherTalk Phase 2 addr:65280/9
RX packets:3048646 errors:0 dropped:0 overruns:0 frame:0
TX packets:90263 errors:0 dropped:0 overruns:0 carrier:0
RX bytes:215378546 (205.4 Mb) TX bytes:9026295 (8.6 Mb)

eth1 Link encap:Ethernet HWaddr 00:09:5B:91:A4:A4
RX packets:673 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
RX bytes:235574 (230.0 Kb) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr: Mask:
EtherTalk Phase 2 addr:0/0
RX packets:46914 errors:0 dropped:0 overruns:0 frame:0
TX packets:46914 errors:0 dropped:0 overruns:0 carrier:0
RX bytes:5689656 (5.4 Mb) TX bytes:5689656 (5.4 Mb)
hope this helps.

ilikejam 11-29-2004 02:12 AM

It looks like you need to configure eth1 (i.e. give it an IP address etc). If you're using DHCP for eth1, then try running 'dhclient eth1'. If not then you can use ifconfig to set up the interface.

I'm not sure why you were getting 'No such device', though.


All times are GMT -5. The time now is 07:08 PM.