LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 01-17-2004, 09:26 PM   #1
AndrewBalmos
Member
 
Registered: Dec 2003
Posts: 42

Rep: Reputation: 15
RedHat 9.0, Kernel 2.4.21, Linux-Wlan-Ng-0.2.1, Compiles and Runs. But Cant Connect.


Hello,

I am running:

Red Hat Linux 9.0
Kernel 2.4.21
Linux-Wlan-ng-0.2.1
Microsoft USB MN-510 Wireless Network Adapter

I download and configured and compile the kernel and did the same with wlan with the newly compiled kernel.

I ran Make install to have wlan install its self and than I ran this:

chkconfig --add wlan
chkconfig wlan on

than I made a file at '/etc/sysconfig/network-scripts/' called ifcfg_wlan0

In this file I added:
DEVICE=wlan0
ONBOOT=yes
BOOTPROTO=dhcp

and I add the rc.wlan into the '/etc/init.d/' with the name wlan and created the symlinks in the correct rc folders.

When I reboot Linux I get a

Starting wlan [ OK ]
Bringing Up Interface wlan0 [ FAILED ]

And a error about not getting a IP

I used the HOWTO files located at: http://www.fuw.edu.pl/~pliszka/hints/prism2.html

Any ideas one way Wlan wont bring up its interface?

Thanks,
Andrew
 
Old 01-18-2004, 04:49 PM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
Ok, so wlan is started, when you do a cat /proc/interrupts do you see wlan0 on there anywhere? Do you see any information about wlan when you run dmesg? When you do a lsmod what drivers are loaded?
 
Old 01-18-2004, 05:10 PM   #3
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
Also, I have been suggesting this to a lot of people using prism2 chipsets. If RedHat has packages for a 2.6.1 kernel install that. It helps kernel coders get some feedback and it gets you a kernel better suited for a desktop machine. It also has the added kernel support for Prism2/2.5/GT chipsets for USB, PCMCIA, and PCI adapters. So you wouldn't need wlan-ng anymore.
 
Old 01-18-2004, 05:34 PM   #4
AndrewBalmos
Member
 
Registered: Dec 2003
Posts: 42

Original Poster
Rep: Reputation: 15
O Ok... I all ways get kernel configures wornge will an 2.4.21 saved configer file configer the kernel?

And this is what I get:

1. cat /proc/interrupts
timer
Keyboard
Cusced
rtc
usb-uhci
PS/2 Mouse
ied0
ide1

2. dmesg
Prisim2_init: prism2_usb.o: 0.2.1-pre164 Loaded
Prisim2_init: dev_info is: prism2_usb
usb.c: registered new driver prism2_usb
driverf allocating divert_blk for wlan0
Prism2 car SN: \x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00
prism2sta_mlmereguest: failed to read wlan0 statistics: error=-5

3. lsmod
parport_pc
lp
parport
autofs
sq
sr_mod
ide-scsi
scsi-mod
ide-cd
cdrom
Printer
prism2_usb
p80211
Keyboard
mousedey
hid
input
usb_unci
usbcore
ext3
jbd

I will also look in kernel 2.6.1

Thanks for the reply....

Andrew
 
Old 01-18-2004, 06:21 PM   #5
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 67
This is your problem:

Prism2 car SN: \x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00
prism2sta_mlmereguest: failed to read wlan0 statistics: error=-5

You might try to download the newest wlan-ng package from www.linux-wlan.org to see if they have a fix for the problem. (if you used a redhat package)
 
Old 01-18-2004, 07:18 PM   #6
AndrewBalmos
Member
 
Registered: Dec 2003
Posts: 42

Original Poster
Rep: Reputation: 15
Nope I installed Linux-wlan myself and I used the lasted version. My card Microsoft MN-510 Is also supported...

I saw that too and was looking around to see if I could find what error code -5 means....

Know where I can? Also I am going to install kernel 2.6.1...

Andrew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
server runs redhat , workstations win 2k ,workstations cannot connect to internet snkambule Linux - Networking 7 04-27-2005 11:08 AM
Kernel Compiles and loads but still some questions garretjax Slackware 2 07-29-2004 10:36 AM
Realtek 8139 (Speedstream 1020) compiles for different kernel?!?! hobbes567 Linux - Hardware 1 06-26-2004 09:01 AM
Java, code compiles and supposedly runs fine in windows, but not linux exodist Programming 4 03-16-2004 01:47 PM
Redhat linux runs slow ksathya Linux - Software 3 09-16-2003 02:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 09:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration