LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   realtek rtl8187b wireless problems (https://www.linuxquestions.org/questions/linux-wireless-networking-41/realtek-rtl8187b-wireless-problems-624201/)

deft 02-27-2008 06:43 AM

realtek rtl8187b wireless problems
 
Hi All,

I recently bought a laptop, a toshiba equium which comes with a realtek rtl8187b usb 2.0 wireless nic. So far I have been unable to get it working at all. I use ubuntu 7.10 and it does not detect the card at all..

I have googled the problem and it mostly came up with two options, 1. download the windows driver and edit the .inf file and use ndiswrapper

or

2. Download the modified realtek driver from, http://datanorth.net/~cuervo/rtl8187b/

I have tried both options, unsuccessfully :cry:

I thought the second option looked good, but after installing it I edited the /etc/network/interfaces as it instructed, but I must be doing something wrong as it wont load automatically at start up?

I manually run ./wlan0 script when I boot up, it appears to work and I can see numerous wireless networks including my own, yet I still can't connect?

After running that script the card becomes visible in my device manager, but it wont load automatically at start up. Here is a copy of my /etc/network/interfaces


auto lo
iface lo inet loopback


iface wlan0 inet dhcp
wireless-mode managed
wireless-essid *******
wireless-key1 *******

pre-up /path/to/driver/rtl8187b-modified/wlan0up
post-down /path/to/driver/rtl8187b-modified/wlan0down


auto eth0
iface eth0 inet dhcp



Does anyone have any ideas to what I might be doing wrong?

Many thanks in advance for "any" help..

deft.

aus9 02-27-2008 07:04 AM

I don't have your device but I think you may have taken this instruction literally when you need to make some changes

http://datanorth.net/~cuervo/rtl8187b/README

/etc/network/interfaces:

iface wlan0 inet dhcp
wireless-essid your-ssid
wireless-mode managed
wireless-key1 s:yourpw

pre-up /path/to/wlan0up
post-down /path/to/wlan0down

for example pre-up needs to change to true path to your wlan0up command

deft 02-27-2008 08:35 AM

thanks for the quick reply :)

Do you mean i remove the actual "pre-up and post-down" text, and just leave the path to the script wlan0up and wlan0down

also in my first post, the text "path-to-driver" in the interface file, I replaced that with the actual path which i removed when i posted it in here :)

Also when i reboot the interface file now looks like:

auto lo
iface lo inet loopback


iface eth0 inet dhcp


all the text i entered into it has gone?

thanks, deft.

aus9 02-27-2008 05:48 PM

no if you knew to put the real path thats ok, but you used ****** above so I thought you did not understand the path bit.

I can not help any further but here is a link that may shed some light
http://www.linuxhomenetworking.com/w...ess_Networking

aus9 02-27-2008 06:23 PM

hmmm, in a vanilla kernel there are some 8187 drivers...no mention of 8187b but you may have nothing to lose to ask if

MODULE_AUTHOR("Michael Wu <flamingice@sourmilk.net>");
MODULE_AUTHOR("Andrea Merello <andreamrl@tiscali.it>");

these gentlemen if their driver for rtl8187_dev.c could be used for 8187b?

deft 02-28-2008 04:54 PM

Thanks for the help mate, I will give the link a go :)

geden 02-29-2008 11:18 AM

I got this working with ndiswrapper and a win98 driver from MS.

deft 03-06-2008 03:46 AM

I tried to install the win98 inf file using ndiswrapper using this link

http://www.linuxhomenetworking.com/w...less_NICsusing



now i get the message: ndiswrapper -l net8187b : invalid driver!

Ok I removed it and started from scratch. My first real problem came when I done: ndiswrapper -m
module configuration already contains alias directive

I am kind of stuck by this? and have no idea what to do next?

Thanks :)

aus9 03-06-2008 05:28 PM

see if any of this helps

http://www.linuxquestions.org/questi...19#post3077519

deft 03-13-2008 06:02 AM

Solved
 
Hi, sorry for taking a while to get back, been on holiday..

I totally removed ndiswrapper and started again, I am not a 100% sure what was different 2nd time around, but, it works! :)

I just followed the instructions (again) for using the windows driver. I think it may have been the changes I made to the driver itself before I used it.

Anyway I thank everyone for their help on this, much appreciated..


deft.

vspunn 05-26-2008 06:47 AM

RTL 8187B on laptop
 
I am totally new to LINUX.
I bought the laptop just to use LINUX. I installed SUSE 10.3. Everything worked except RTL8187B and HP1000 laser printer.

Franky, I cannot change the code or anything.
I need to start the RTL 8187B Wireless LAN on my system, and need help like a layman. The hardware shows it under USB device, but to make it work like a Network card is problem for me.

Can anybody help me.

Jessica_Lily 07-02-2008 08:05 AM

for suse 10.3 you need to following packages:
- gcc
- kernel-soruces
- make

once you have them (might need to add some repositories) go to this site:
http://datanorth.net/~cuervo/rtl8187b

download the driver

./makedrv
./wlan0up

check its there by doing

ifconfig

and then your fine =]


All times are GMT -5. The time now is 09:18 PM.