LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 10-31-2010, 12:15 AM   #1
anon55672
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Rep: Reputation: 0
Exclamation REALLY strange problem with TL-WN422G (atheros)


Hello everyone!
I've recently bought TP-Link WN422G wireless adapter with atheros chipset.
I've followed this guide successfuly and now I can see the adaptor with iw/ifconfig.

However, when i try connecting to ANY wireless network (no encryption and pretty good signal) I get error "unable to get IP".

I've ran wireshark to see what is happening when I try to connect and - voila! It immediatally got connected!

I've tested at least 30 times connecting to the AP with and without wireshark running, and I can connect with no problems while it is running and not at all while it isn't.

So, I'm just asking what does wireshark have to do with connecting to router at all?
 
Old 11-02-2010, 06:06 PM   #2
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Maybe something in the syslog or kernel ring buffer can shed some light on what's going on...
 
Old 11-07-2010, 10:53 AM   #3
anon55672
LQ Newbie
 
Registered: Oct 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Problem solved.
I spoofed the MAC of the card and Wireshark put the card into the promiscuous mode so that was the cause.
But that's still strange because all other cards I've tried work fine when I spoof their MAC without being in promisc. mode...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Usb wifi TL-WN422G saturates my dmesg! Mikro Linux - Hardware 3 07-08-2010 09:40 AM
[SOLVED] USB stick TP-Link TL-WN422g V.2 ar9271 ukiuki Linux - Wireless Networking 0 05-29-2010 01:35 PM
Another Atheros Problem maravi Slackware 3 08-10-2008 03:56 PM
Madwifi Atheros - Strange problem NDR008 Linux - Wireless Networking 1 08-09-2008 01:56 PM
strange, strange alsa problem: sound is grainy/pixellated? fenderman11111 Linux - Software 1 11-01-2004 05:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 12:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration