LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 10-16-2008, 06:00 PM   #1
leifmusik
LQ Newbie
 
Registered: Oct 2008
Posts: 10

Rep: Reputation: 0
Ralink RT2860 device doesn't work


Hi.

Since a few days I've been trying to get the Ralink Rt2860 device - installed in my laptop - working. I am using a "linux from the scratch"-like 64bit-multilib system, running kernel 2.6.23.13.

I chose the driver (version 1.8.0.0) available from the Ralink-Website (w ww.ralinktech.com/ralink/Home/Support/Linux.html)

Follwing the instructions coming along with the driver I first had a look a the Makefile in the root directory which - in my opinion - doesn't need to be modified. Then I edited the file os/linux/config.mk regarding WPA_SUPPLICANT, so that these lines look like this now:
Quote:
HAS_WPA_SUPPLICANT=y
Quote:
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
To compile the driver I did a simple
Quote:
make
Just as suggested by Ralink I generated a RT2860STA.dat file, located in /etc/Wireless/RT2860STA.

The next step I did was to load the driver:
Quote:
insmod ./rt2860sta.ko
A quick look at the output of 'lsmod' shows me that the driver seems to be loaded correctly.

Just until this point everything seems to work fine, but performing the next step in Ralinks instructions fails.
You should bring up the card using the command:
Quote:
ifconfig ra0 inet 192.168.200.200 up
'ifconfig' doesn't do anything and all I get is this error message:
Quote:
ifconfig: only one address allowed for interface 'ra0'
Why does 'ifconfig' say there's already an address defined for ra0? I definitely didn't do so.

This is what 'ifconfig ra0' says:
Quote:
ra0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
BROADCAST MULTICAST MTU:1500
txqueuelen:1000
And this doesn't look as if there is already an address specified for 'ra0'. Another strange thing I recognize here is the MAC-address, 00:00:00:00:00:00 looks a bit unusual, doesn't it?

So what am I doing wrong?

Perhaps the output of 'iwconfig ra0' might give you some additional information:
Quote:
ra0 RT2860 Wireless ESSID:"" Nickname:""
Mode:Auto Frequency=2.412 GHz
Link Quality=10/100 Signal level:0 dBm Noise level:-143 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
As you can see none of the things specified by my RT2860STA.dat file were set, so the driver seems to ignore it. Or will these information be added after the device is brought up using 'ifconfig'?

And settings can't even be done manually using 'iwconfig'. All the program says is:
Quote:
SET failed on device ra0 ; Network is down.
If you need any additional information to help me, just let me know.

Thanks in advance
leifmusik

Last edited by leifmusik; 10-16-2008 at 06:03 PM.
 
Old 10-17-2008, 01:38 PM   #2
leifmusik
LQ Newbie
 
Registered: Oct 2008
Posts: 10

Original Poster
Rep: Reputation: 0
The following Configuration did the job:

1. No configuration using /etc/Wireless/RT2860STA/RT2860STA.dat, wpa_supplicant will do that
2. Ralink-driver, version 1.8.0.0, the only file to be modified is "config.mk"
Quote:
HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
3. /etc/wpa_supplicant.conf (works - like this - of course only for me)
Quote:
network={
ssid="3210 Phone WLAN SL"
scan_ssid=1
proto=RSN
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="xxxxxxxx"
}
If you have that, the following actions have to be performed to get a connection to the Internet:

1. modprobe rt2860sta
2. wpa_supplicant -Dwext -ira0 -c/etc/wpa_supplicant.conf
3. ifconfig ra0 IP_ADDRESS
4. route add default gw ROUTER_IP_ADDRESS

Maybe this can help someone.
leifmusik
 
Old 11-14-2008, 10:20 AM   #3
ralfs
LQ Newbie
 
Registered: Mar 2006
Location: Jurmala, Latvia
Posts: 3

Rep: Reputation: 0
You can connect by hand:

iwconfig ra0 essid MySSID
iwpriv ra0 set AuthMode=WPA2PSK
iwpriv ra0 set EncrypType=AES
iwpriv ra0 set WPAPSK=MyWPAkey

Or put in /etc/sysconfig/network-scripts/ifup-wireless

r.
 
Old 03-11-2009, 11:19 PM   #4
k_v
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
Could you please post the wpa_supplicant .config file to build the supplicant?

Thanks
 
Old 03-15-2009, 08:59 AM   #5
leifmusik
LQ Newbie
 
Registered: Oct 2008
Posts: 10

Original Poster
Rep: Reputation: 0
Which file are you concretely thinking about? (I posted my /etc/wpa_supplicant.conf as you can see above)
 
Old 03-15-2009, 01:03 PM   #6
k_v
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
I'm looking for the .config file that you'd have to have in order to compile the wpa_supplicant software

i am mainly interested in driver_wext.c which would have the required modifications needed
to make the supplicant work with this rt2860 driver. As every driver is unique, i appreciate
the .config file and the driver_wext.c

Thanks for the wpa_supplicant.conf that the supplicant uses to connect with the radius server.

Ven
 
Old 03-16-2009, 02:22 AM   #7
leifmusik
LQ Newbie
 
Registered: Oct 2008
Posts: 10

Original Poster
Rep: Reputation: 0
Hi Ven

I'm just not at home where I could double-check my false pretences , but the notes on my laptop say I'm using the following .config-file with wpa_supplicant 0.5.10:

Code:
CONFIG_DRIVER_WEXT=y
CONFIG_WIRELESS_EXTENSION=y
CONFIG_IEEE8021X_EAPOL=y
CONFIG_EAP_MD5=y
CONFIG_EAP_MSCHAPV2=y
CONFIG_EAP_TLS=y
CONFIG_EAP_PEAP=y
CONFIG_EAP_TTLS=y
CONFIG_EAP_GTC=y
CONFIG_EAP_OTP=y
CONFIG_EAP_SIM=y
CONFIG_EAP_AKA=y
CONFIG_EAP_PSK=y
CONFIG_EAP_SAKE=y
CONFIG_EAP_GPSK=y
CONFIG_EAP_PAX=y
CONFIG_EAP_LEAP=y
Hope this works for you, too.

Leif
 
Old 03-17-2009, 06:19 PM   #8
k_v
LQ Newbie
 
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
Thanks. That's exaclty what i was looking for..
 
Old 07-12-2009, 03:36 PM   #9
royor
LQ Newbie
 
Registered: Jul 2009
Posts: 12

Rep: Reputation: 0
rt2860 does not work in fc11

I have upgraded from fc7 to f11.

In fc7, I had compiled the rt2860 driver from the open source tarball I downloaded from ralinktech.com.

I compiled it for use with -Dwext :

HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

which worked very well. I was able to associate with
my AP without problems.

Now that I have migrated to FC11, which comes with
rt2860 driver support, I am not able to associate
with the AP.

I tried to config the ra0 interface to be
managed by NetworkManager (which is in itself problematic),
and I tried to config ra0 without NetworkManager.

In both cases, restarting wpa_supplicant.

I am not able to associate with the AP.

PS: I am using the same wpa_supplicant.conf
and sysconfig/wpa_supplicant files
which were used in FC7 where they worked so well.

Does ANYONE in this forum have rt2860 working in FC11??

If so, please PLEASE reply with a list
of all the relevant rpms you had to install to make it work, and with the contents of your

wpa_supplicant.conf
(be sure to erase your key when you post it here), and the contents of
/etc/sysconfig/wpa-supplicant and
/etc/sysconfig/network-scripts/ifcfg-ra0

Thanks for your help.

Cheers,

Royor
 
Old 07-12-2009, 03:48 PM   #10
royor
LQ Newbie
 
Registered: Jul 2009
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by leifmusik View Post
Hi.

Since a few days I've been trying to get the Ralink Rt2860 device - installed in my laptop - working. I am using a "linux from the scratch"-like 64bit-multilib system, running kernel 2.6.23.13.

I chose the driver (version 1.8.0.0) available from the Ralink-Website (w ww.ralinktech.com/ralink/Home/Support/Linux.html)

Follwing the instructions coming along with the driver I first had a look a the Makefile in the root directory which - in my opinion - doesn't need to be modified. Then I edited the file os/linux/config.mk regarding WPA_SUPPLICANT, so that these lines look like this now:



To compile the driver I did a simple


Just as suggested by Ralink I generated a RT2860STA.dat file, located in /etc/Wireless/RT2860STA.

The next step I did was to load the driver:


A quick look at the output of 'lsmod' shows me that the driver seems to be loaded correctly.

Just until this point everything seems to work fine, but performing the next step in Ralinks instructions fails.
You should bring up the card using the command:


'ifconfig' doesn't do anything and all I get is this error message:


Why does 'ifconfig' say there's already an address defined for ra0? I definitely didn't do so.

This is what 'ifconfig ra0' says:


And this doesn't look as if there is already an address specified for 'ra0'. Another strange thing I recognize here is the MAC-address, 00:00:00:00:00:00 looks a bit unusual, doesn't it?

So what am I doing wrong?

Perhaps the output of 'iwconfig ra0' might give you some additional information:


As you can see none of the things specified by my RT2860STA.dat file were set, so the driver seems to ignore it. Or will these information be added after the device is brought up using 'ifconfig'?

And settings can't even be done manually using 'iwconfig'. All the program says is:


If you need any additional information to help me, just let me know.

Thanks in advance
leifmusik

From all the replies you have received, have you been able to make it work???
I have not been able to make it work in FC11.

Royor
 
Old 08-06-2009, 11:51 AM   #11
technowar
LQ Newbie
 
Registered: Aug 2009
Posts: 17

Rep: Reputation: 0
Quote:
Originally Posted by leifmusik View Post
3. /etc/wpa_supplicant.conf (works - like this - of course only for me)
Sir, how do you run it? I have extracted the file in my desktop. Uhm am I doing the wrong thing?
 
Old 11-27-2009, 10:54 AM   #12
ralfs
LQ Newbie
 
Registered: Mar 2006
Location: Jurmala, Latvia
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by royor View Post
From all the replies you have received, have you been able to make it work???
I have not been able to make it work in FC11.

Royor
In Fedora 11 I just:
make
make install
and change values in /etc/Wireless/RT2860STA/RT2860STA.dat

but now in Fedora 12 I cannot make that module

I hope that in kernel v2.6.32 should be included rt2860sta module...
 
Old 12-28-2009, 04:21 PM   #13
ralfs
LQ Newbie
 
Registered: Mar 2006
Location: Jurmala, Latvia
Posts: 3

Rep: Reputation: 0
Fedora 12

From RPMFusion repo install rt2860:
yum -y install rt2860

Edit /etc/wpa_supplicant/wpa_supplicant.conf

Edit /etc/sysconfig/wpa_supplicant
INTERFACES="-ira0"

Run:
chkconfig wpa_supplicant on

Reboot...

All works fine
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to work RaLink RT2561/RT61 and Ubuntu 7.1 Felipe Linux - Wireless Networking 5 03-24-2008 02:19 PM
wlan, Ralink PCI, dosent work Salocin27 Linux - Hardware 2 03-19-2008 07:22 AM
D-Link DWL G510 (Ralink Chipset) doesn't work marco18 Linux - Hardware 4 01-17-2008 06:03 AM
Wireless LAN (RaLink RT2500) does not work with edited boot options wersdaluv Linux - Wireless Networking 7 03-15-2007 08:40 PM
Ralink USB device on suse krypton.kr Linux - Networking 1 11-03-2005 06:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 04:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration