LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 01-13-2005, 08:22 AM   #1
slack---line
Member
 
Registered: Jul 2003
Location: Sheffield, UK
Distribution: Gentoo/Slackware10.0@AthlonXP2600, 1Gb RAM; Slackware9.1@Dell Latitude X300; Gentoo@Ultra10
Posts: 48

Rep: Reputation: 15
problems installing ndiswrapper


Hi all,

I'm trying to install the ndiswrapper-1.0rc2 and attempting to get it to work with a broadcom wireless network card.

I'm following the instructions posted here

http://www.linuxquestions.org/hcl/sh...hp?product=856

and am using slackware 9.1 (kernel 2.6.9 custom compiled with sources installed and available).

However, when I get to step 9 in the above instructions I get the following...

# modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.9/misc/ndiswrapper.ko): Operation not permitted

I have definately got module support in the kernel as I had been (unsuccesfully trying to install the ipw2200 driver (see thread in slackware forum http://www.linuxquestions.org/questi...ighlight=ipw00)
and had could succesfully load the modules required here.

I checked the ndiswrapper installation wiki, but nothing there helped me resolve this problem.

I've also tried this with the ndiswrapper-0.12 but that won't even make install, it results in a load of error and warning messages.

I guess trying the latest CVS may be an option, but I'd like to resolve why this isn't working.

Any help as to why the module can not be installed would be most appreciated,

thanks in advance,

slack---line
 
Old 01-13-2005, 01:41 PM   #2
slackman
Member
 
Registered: Mar 2003
Distribution: Slack 9.0
Posts: 123

Rep: Reputation: 15
are you getting any warnings/errors during compilation of ndiswrapper?
i would try lower versions too. i was getting the same error (but was gettin also compilations warnings about usb stuff). i recompiled the kernel with usb support (i dont need it thou) and ndiswrapper worked fine.
 
Old 01-17-2005, 04:40 AM   #3
slack---line
Member
 
Registered: Jul 2003
Location: Sheffield, UK
Distribution: Gentoo/Slackware10.0@AthlonXP2600, 1Gb RAM; Slackware9.1@Dell Latitude X300; Gentoo@Ultra10
Posts: 48

Original Poster
Rep: Reputation: 15
Just to close this thread and let people know that I've managed to get ndiswrapper-0.11 installed and running with this hardware conf, so if your having trouble do as slackman suggested and try another older version :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing ndiswrapper harisund Ubuntu 5 02-28-2006 09:26 AM
Problems installing ndiswrapper-1.2 on Mandrake 10.1 ChillyWillie Linux - Hardware 6 07-20-2005 07:42 PM
Problems installing ndiswrapper-1.2 on Mandrake 10.1 ChillyWillie Mandriva 2 07-20-2005 03:53 PM
problems installing Ndiswrapper joshknape Linux - Wireless Networking 9 07-19-2005 02:25 AM
Booting problems after installing Ndiswrapper (Fedora 2) mawaldne Linux - Wireless Networking 4 12-30-2004 11:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 07:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration