-   Linux - Wireless Networking (
-   -   Problems installing madwifi on FC5 updated kernel (

dehavik 04-27-2006 10:11 PM

Problems installing madwifi on FC5 updated kernel
hi all. i'm new to linux and enduring what seems to be the right of passage......installing a wireless card on my laptop. i am running FC5 with the updated kernel 2.6.16-1.2096_FC5
i have an NEC Aterm WL54AG pcmcia (cardbus) adapter. it is listed as having the Atheros AR5212 chipset which is listed as compatible with madwifi drivers. i have been here: atrpms net/dist/fc5/madwifi/
(sorry, i am not permitted to post urls until i've posted at least three times)
to find the madwifi packages i need for installation but there is nothing listed for the kernel i am using. again, that is 2.6.16-1.2096_FC5
where do i get the files i need and what is the best way to install them? i am assuming yum.

i have also been here: forum fedora forum org/forum/showthread php?t=43718

to check out that explanation. i run into problems with yum install wifi after adding the info into: gedit /etc/yum.repos.d/atrpms.repo
here is what i get:
[root@localhost dehavik]# yum install madwifi
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/4]
core 100% |=========================| 1.1 kB 00:00
updates [2/4]
updates 100% |=========================| 951 B 00:00
atrpms-stable [3/4]
[[/url] [Errno 14] HTTP Error 404: Date: Fri, 28 Apr 2006 02:46:03 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms-stable
failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.

there was a url in that execution, i took out part of it because i am not permitted to post them yet.

if anyone can elaborate or help in any way it would be greatly appreciated. please keep in mind that i am a complete newbie, so if posting command lines please elaborate so that i can execute them properly. thanks again in advance.

basileus 04-28-2006 02:13 AM

If you can't find a module package for your kernel you will have to compile the modules from source. You can get it with


Then issue a

tar -zxf madwifi-ng-current.tar.gz

Then go to the created dir (mine was as follows, your may differ)

cd madwifi-ng-r1531-20060427/

Do a "ls" to see what you can find:

ath contrib include regression THANKS
ath_hal COPYRIGHT INSTALL net80211 release.h tools
ath_rate docs kernelversion.c patches scripts hal Makefile README SNAPSHOT

Then read the INSTALL file, for example with "less":


You can leave "less" by pressing "q".

Just follow the instructions... you can probably install all the dependencies with "yum".

Titanas25 04-28-2006 03:05 AM

give us an: uname -a

the FC5 madwifi drivers are at: in rpm format

dehavik 04-28-2006 03:08 AM

thanks basileus. i am struggling through the install doc right now. do you have any insight as to where i might find the kernel sources in order to execute
make KERNELPATH=[kernel source dir]
somewhere along this epic journey i lost use of my yum update feature as well. i think this may have happened when following the directions on the post i refer to above where i edited or created some file.
thanks again for your wisdom.

dehavik 04-28-2006 03:12 AM

Titanas25....... here's the result of uname -a......
[root@localhost dehavik]# uname -a
Linux localhost.localdomain 2.6.16-1.2096_FC5 #1 Wed Apr 19 05:14:36 EDT 2006 i686 i686 i386 GNU/Linux

thanks for jumping in...i can use all the help i can get

dehavik 04-28-2006 03:26 AM

i fixed the yum issue i was having.
Titanas25....i tried installing the rpm you pointed me to but it says:
Error: Missing Dependency:
where can i find this dependency?
and this will work with the kernel i am using? 2.6.16-1.2096_FC5
thanks so much.

Yoshiboy 05-09-2006 04:14 AM

i am having similar problems in compiling madwifi for FC5. I tried compiling from the source files but KERNEL PATH is missing.

Any help please?

short101 05-09-2006 06:48 AM

Guys, you need either configured kernel sources or kernel headers for your kernel. You are probably best off asking in the forum for your distro about that sort of thing. You may find someone can point you to a repo with everything you need. If you are going to compile from source, i suggest you read the newbie doc on

All times are GMT -5. The time now is 01:08 AM.