-   Linux - Wireless Networking (
-   -   Please help the n00b. (

NssOne 02-07-2004 12:45 PM

Please help the n00b.
Somebody please help me. I'm totally new to Linux and I just installed RedHat yesterday. I have this Wireless LAN Adapter that I want to install, but I don't know wtf I'm doing. I have all the files but I can't figure out how to do anything. I desperately cry out: PLEASE HELP ME!!!

Seriously, take baby steps with me here if you have to. I have AIM, ICQ, Yahoo IM and MSN Messenger of which all to reach me instantly. If somebody is willing to help me here, Let me know.

NssOne 02-07-2004 01:46 PM

Update: OK, so I figured out how to get to the terminal and navigate through that. Now I need to figure out where the kernel is so I can finish the 'make config' command.

aclaunch 02-07-2004 05:34 PM

What are you trying to compile?? Usually the commands are "configure", "make" and "make install". Ususally you don't need the kernel but you do need either kernel headers or the complete kernel source to compile.

More info would be helpful.

Good Luck

NssOne 02-08-2004 02:52 AM

Actually, I believe I have figured out what paths I needed to type in in order to start the 'make config', but I think my install is missing the development components and, therefore, won't compile.

I kept getting errors, something like 'file missing' or 'file not found'. I'll try to be more indepth when I get a chance to work on it again. That unfortunately won't be until tomorrow night.

EDIT: Also, if anybody knows of a few different places to d/l RH9, that'd be great. I'm trying to d/l it through bit torrent and it says it would take me another 2-3 days to finish it. I have broadband, it shouldn't be that slow for all 3 discs. If anybody knows of some places that have higher bandwidth that I can d/l the isos from, please let me know.

2Gnu 02-08-2004 09:41 AM

The fastest RH mirror around:

NssOne 02-08-2004 11:43 AM

Wow, I'm grateful. Thank you very much. With this, I'll have the ISOs downloaded tonight and hopefully I'll be able to add on those development components.

NssOne 02-09-2004 12:13 AM

I have a new problem. The last step of my installation requires me to insert the default gateway. I'm using both a Linksys router and WAP. I'm having trouble figuring out how to set the default gateway addy and getting it to connect to the WAP and log onto the network. Please help me some more.

aclaunch 02-09-2004 12:24 AM

Default gateway should be the IP of your router. The command is "route add default gw IP.of.the.router" from the command line as root.

Good Luck

NssOne 02-09-2004 12:35 AM

Could I be doing the ifconfig wrong? I'm not sure what IP I should be putting in there.

aclaunch 02-09-2004 12:44 AM

In my system, I set a static address for my card with

"ifconfig wlan0"

then add the card parameters with iwconfig

"iwconfig wlan0 mode Managed channel 6 essid XXXXX " (XXXX=my essid)

then set default gateway

"route add default gw"

Good Luck

NssOne 02-09-2004 12:51 AM

Well here's the bit of instructions I'm at and what it's trying to tell me to do.

    run '/sbin/ifconfig ra0 inet YOUR_IP up'
    run '/sbin/route add default gw YOUR_DEFAULT_GW dev ra0'
    (where [YOUR_IP] like [], [YOUR_DEFAULT_GW] like [])
  - run '/usr/local/bin/RaConfig'  to start the Configuring Utility.

EDIT: I'm not getting the same error messages, but I'm getting no response out of mozilla when I try to connect to a website. I think I'm setting up the wrong GW. Please more help :/

aclaunch 02-09-2004 09:10 AM

I would just use an arbitrary IP for "Your_IP" like and your gateway should be if you're using a Linksys router. Your router documentation should tell you what it's IP is.

Once this is entered, try to ping your router from your wireless machine. Do "ping -c 4 IP.of.the.router"- this should give you some times in the output, not a message of "network unreachable".

Good Luck

NssOne 02-09-2004 12:42 PM

I tried the ping and this is what I got:

4 packets transmitted, 0 received , +4 errors, 100% packet loss, time 3142ms, pipe 3
Yes, is the device IP of my router. But I'm not just using a router, I'm using a WAP. My router is wired. I think part of my poblem is the IP address of the WAP, but I'm not sure.
EDI: I also tried the 'iwconfig', but I get an 'Error for wireless request "Set Mode" (8B06) : .....'

NssOne 02-09-2004 01:10 PM


:sigh: Well, unfortunately, I don't know exactly what I did to make it work, but it connects to the internet.

But unfortunately it's not so much that it's working as it's what I needed to do to make it work. I'm basically writing a report on how I'm turning this into a wireless media server. Well, thanks again for your helps.

EDIT: Ummm... no it did work, but now i doesn't again. where's the smilie of the guy putting a gun to his head in frustration?

EDIT II: Why do I have to add in all the IP stuff again? Why won't it save it? Any explanations? I'm sorry if I'm being such a bother with this, but it's getting to me.

aclaunch 02-09-2004 02:17 PM

OK now I'm confused. What does your wireless access point connect to. My setup is wireless router/wireless USB card for remote computer; card connects to router.

As root what does "iwconfig wlan0 (or eth0 whichever is correct)" show?


All times are GMT -5. The time now is 01:25 AM.