-   Linux - Wireless Networking (
-   -   Partially solved-broadcom b43 no mac phy0 error-broadcom (

tnrooster 03-06-2008 10:14 AM

Partially solved-broadcom b43 no mac phy0 error-broadcom
I think I finally see why my 4306 rev3 card doesn't work with the b43 driver setup. Mine works perfect with bcm43 but I cant load it as the machine whines about it needing the b43 driver. Why?

B43 uses the mac I'm guessing to figure out which driver to use, b43 or b43legacy, and b43 fails to see the mac on my card. A quick search shows others having the exact saem problem, no mac address assigned to phy0 or well a false one.

Mine shows a no-op'ed ff;ff;ff.... which is nothing right? Well if it has version 4 and up b43 uses the standard driver trying to make the on chip encryption negotiations but if its earlier it uses something like the bcm43 where the CPU does all the math.

My card needs b43legacy but it refuses to load it and I believe its because the no-op'ed mac makes it see it as a later version than the threshold "04".

Mine sees all the routers just can never get associated with one. Dump b43 kernel and go back to F6 out of the box using bcm43 and it works perfect.

So anyone point me in the right direction of how to force b43legacy? Or to get the right mac posted in phy0? Maybe someone could point this out to the people who write all this stuff.

Lenard 03-06-2008 10:50 AM

So blacklist the b43 kernel module by adding it to the /etc/modprobe.d/blacklist file. Also edit the /etc/modules.conf file to use the b43leagacy as the driver instead of the b43.

Also try the following (as root) when done with the editing;

service network stop
modprobe -r b43
modprobe b43legacy
service network start

tnrooster 03-06-2008 11:23 AM

Thats not how it works. During the months of flustration dealing with this I never could get b43 removed as it comes up from ssb which runs other things, usb maybe? Anyway blacklisting b43 doesn't work.

By "force b43legacy" I mean go in where the if/then on the mac which decides the proper firmware set to use out of the b43 driver. Its not a option driver but an option firmware used within the driver depending on the mac version reported to phy?, somewhere?.

tnrooster 03-06-2008 12:44 PM

After a little looking I found another broadcom 4306 rev 03 here at the office. Throw it in the laptop, load the same firmware and it works. Why? without even looking I'm guessing its a rev4 or up mac. I dont have the ssb debug figured out so I cant confirm if it is but its the only thing that makes sense.

Dmesg shows the same no-op'ed mac of ff;ff;ff... but this one works as b43 always loads the encryption based firmware because the report failure of the mac I'm guessing.

There needs to be some additional rules to the part where it determines which firmware to use, like a default to the b43legacy then try b43 if that passes/works?

All times are GMT -5. The time now is 07:15 AM.