LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Non-DHCP connect on a Linksys WRT54G router (https://www.linuxquestions.org/questions/linux-wireless-networking-41/non-dhcp-connect-on-a-linksys-wrt54g-router-342231/)

Zyk 07-11-2005 04:50 PM

Non-DHCP connect on a Linksys WRT54G router
 
I'm having a problem connecting through a Linksys WRT54G router. My system can successfully ping the router at 192.168.1.1, and I can access the setup, but I can't access anything outside of it.

I'm running Slackware and use a shell script called rc.DWL in /etc/rc.d to specify wireless connection settings. The main part of the file looks like this:

Quote:

DEVICE="ath0"
IPADDR="192.168.1.20"
NETMASK="255.255.255.0"
BROADCAST="192.168.1.255"
GATEWAY="192.168.1.1"
ESSID="wertznet"
CHANNEL="10"

startDevice() {
echo -n "Bringing up $DEVICE..."
echo "Done."
/sbin/iwconfig $DEVICE channel $CHANNEL
/sbin/iwconfig $DEVICE essid $ESSID
/sbin/ifconfig $DEVICE $IPADDR broadcast $BROADCAST netmask $NETMASK
sleep 1
/sbin/route add default gw $GATEWAY
}
I've been using this script for a long time, and simply manually change the settings when I must connect to a new network.

The settings currently entered seem to put me on the network. My card blinks as if it is connected, and any other settings bring up a "Network unavailable" message. I can ping the router and other computers on the network. ifconfig displays the router's correct mac address, and everything looks to be right.

On the router, all security is currently disabled. When I view the Wireless Client MAC list, my computer's MAC address is displayed along with the others that are connected, but the "Client Name" and "IP Address" fields are blank for my computer. What I think is the problem (though I'm not positive) is that the router isn't letting my computer establish it's own IP address. However, I've continually gone through every section of the router's settings, and can't find any option that relates to this.

Any suggestions or ideas?

Bruce Hill 07-11-2005 06:13 PM

Is this router new? If so, have you setup the client IP addresses under Access Restrictions?
Status > Enable > PCs: Allow > and Enter the IP Address of the PCs.

I have the same router and could ask a lot of questions, but it's obviously the WAN side and not the LAN side. Also check under Status the output for Router, Local Network, and Wireless.


All times are GMT -5. The time now is 01:23 AM.