LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   No Wireless networks found under Wicd (https://www.linuxquestions.org/questions/linux-wireless-networking-41/no-wireless-networks-found-under-wicd-809557/)

nickboarder27 05-22-2010 09:50 PM

No Wireless networks found under Wicd
 
Hello,

I am unable to detect my wireless network.

Code:

root@DellNB:/home/nick# lspci -v  --snip--
02:03.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
        Subsystem: Dell Wireless 1370 WLAN Mini-PCI Card
        Flags: bus master, fast devsel, latency 64, IRQ 19
        Memory at dfdfe000 (32-bit, non-prefetchable) [size=8K]
        Kernel driver in use: b43-pci-bridge
        Kernel modules: ssb

02:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 03)
        Subsystem: Dell Device 01a4
        Flags: bus master, medium devsel, latency 64, IRQ 20
        Memory at dfdfd000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at df40 [size=64]
        Capabilities: [dc] Power Management version 2
        Kernel driver in use: e100
        Kernel modules: e100

and

Code:

root@DellNB:/home/nick# iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0    Interface doesn't support scanning : Network is down

and

Code:

root@DellNB:/home/nick# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0    IEEE 802.11bg  Mode:Managed  Access Point: Not-Associated 
          Tx-Power=0 dBm 
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off

I'm fairly confident wicd is working because it correctly reports the current wired connection. And, the AP is confirmed up and running.

nimnull22 05-22-2010 09:56 PM

Wicd has its own log, please enable it, and look. May be it tells you what is going wrong.

repo 05-23-2010 02:58 AM

Which version are you using?
Version 1.6.2.1 has a bug
Try to use version 1.7

nickboarder27 05-25-2010 07:19 PM

How would I query the version?

I'm using slackware-current "13.1 RC"

I have read some threads about this particular card but they are all fairly old.

I put my settings in rc.wireless.conf -> no help.

If I run
Code:

./rc.inet1
dhcpcd polls on eth0 but not wlan0

Code:

./rc.inet1 wlan0_start
I get error on SET (Nickname and Encode).
I did not set these in rc.wirless.conf.

Edit: Oh yea, I checked the log and I'm not sure what its telling me. The log is very long, wicd is running ifconfig then iwconfig every 4 seconds. I will attach if requested.

Hangdog42 05-26-2010 07:06 AM

For starters if you look at your iwconfig output, none of your network interfaces have wireless capability. That means either a driver isn't loading or you've got too many drivers for that card loading. Having upgraded to 13.1 yesterday I mindlessly installed the Broadcom sta driver and was surprised when my wireless didn't work. Upon further inspection it turns out that b43 was loading as well, and the two of them were fighting for the card.

So what drivers have you been using? And if you look in lsmod, do you see them? You might also check your log files and see if there is any complaining that is relevant.

nickboarder27 05-26-2010 09:18 PM

Problem Solved!

I checked the log (thanks Hangdog :hattip:), and sure enough b43 can't find stuff. There was even a nifty kernel message telling me exactly what website to get the files from. So I downloaded and extracted the driver and b43-fwcutter. I then built and ran the cutter followed by a three finger salute.

Once in KDE I checked wicd and BINGO!

Put in my key and I'm now unplugged.:)

Leson Learned:
ALWAYS check the log, its there for a reason


All times are GMT -5. The time now is 05:42 AM.