-   Linux - Wireless Networking (
-   -   No wireless connection on Acer Aspire 5315 (

saradraj 01-08-2008 05:15 AM

No wireless connection on Acer Aspire 5315
I have dual booting operating systems on my laptop. Oracle Unbreakable Linux is installed on one and I am trying to get an Internet connection, but the OS is not detecting the Wireless card. My laptop is Acer Aspire 5315-2153 with Atheros 802.11 b/g WLAN card. I tried using device drivers from madwifi but it's not working or I am doing it wrong. Can any one of you members help me? thanks

Peter_APIIT 01-09-2008 02:54 AM

What distributions are u using ? Post your dmesg | less output to here. What is u wireless card model ?
I hope this help.

saradraj 01-09-2008 03:50 AM

No internet connection on Acer Aspire 5315-2153
I am using Enterprise Linux 4.5 from Oracle and my network card is Atheros AR5007EG Wireless Network Adapter.

b0uncer 01-09-2008 04:46 AM

If the native driver (if any) doesn't work, you can try to load Windows drivers (.inf and .sys file required) with NDISwrapper, and see if that helps.

For NDISwrapper instructions, use the search functionality at the top of the page. There are loads of threads here about it and more outside this site, and apart from installing NDISwrapper (except for the case where you compile it from source) the instructions are distribution-independent.

kung foo priest 01-26-2008 03:01 PM


if you didn't get it to work yet:

The Aspire 5315 uses an Atheros chipset meaning you will need the ath-pci kernel module that comes with madwifi..

I tried the ndiswrapper one too and it worked almost without a problem..
Yet ff you want to put the card into promiscious mode you will need to want to get to have madwifi.

good luck

crayzeewulf 06-03-2008 01:01 AM

Try using madwifi with a patch...
Try using the instructions at the following page:

These work on an Acer Aspire 5315-2122.


All times are GMT -5. The time now is 10:34 AM.