-   Linux - Wireless Networking (
-   -   No scan results anymore with Broadcom BCM4312 (

LordFrancis 08-31-2008 02:13 PM

No scan results anymore with Broadcom BCM4312
Hello all

I have been having some problems with my wireless network card.
So far I haven't been able to figure out what causes the problem, but the device has been unable to find any network. This suddenly happened some time ago while I was using the wifi. Before then I had always used my wireless card successfully.

My network card is a:

30:00.0 Network controller: Broadcom Corporation BCM4312 802.11a/b/g (rev 01)
I am using the b43 kernel driver with the latest firmware from

I've just changed the encryption to wpa from wep, hoping that something would change.

A windows computer beside mine finds two networks: my home one (the one I am trying to connect to), and my neighbour's.

Here is some information (commands, output):

This is after the boot.

# dmesg | grep b43
b43-phy0: Broadcom 4311 WLAN found
b43-phy0 debug: Found PHY: Analog 4, Type 2, Revision 8
b43-phy0 debug: Found Radio: Manuf 0x17F, Version 0x2050, Revision 2


# ifconfig wlan0 up
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0 debug: Chip initialized
b43-phy0 debug: 32-bit DMA initialized
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
b43-phy0 debug: Wireless interface started
b43-phy0 debug: Adding Interface type 2
ADDRCONF(NETDEV_UP): wlan0: link is not ready


# iwlist wlan0 scan
wlan0        No scan results


# ifup -v wlan0
Configuring interface wlan0=wlan0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -B -P /var/run/ -i wlan0 -D wext -q -f /var/log/wpa_supplicant.wlan0.log -C /var/run/wpa_supplicant
Starting /sbin/wpa_supplicant...
wpa_supplicant: creating sendsigs omission pidfile: /lib/init/rw/sendsigs.omit.d/
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/wlan0
wpa_supplicant: wpa-ap-scan 1 -- OK
wpa_supplicant: configuring network block -- 0
wpa_supplicant: wpa-ssid "XXX" -- OK
wpa_supplicant: wpa-psk ***** -- OK
wpa_supplicant: wpa-pairwise TKIP -- OK
wpa_supplicant: wpa-group TKIP -- OK
wpa_supplicant: wpa-key-mgmt WPA-PSK -- OK
wpa_supplicant: wpa-proto WPA -- OK
wpa_supplicant: enabling network block 0 -- OK

dhclient3 -pf /var/run/ -lf /var/lib/dhcp3/dhclient.wlan0.leases wlan0
Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/YYY
Sending on  LPF/wlan0/YYY
Sending on  Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 8
DHCPDISCOVER on wlan0 to port 67 interval 19
DHCPDISCOVER on wlan0 to port 67 interval 11
DHCPDISCOVER on wlan0 to port 67 interval 14
DHCPDISCOVER on wlan0 to port 67 interval 9
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/000resolvconf
run-parts: executing /etc/network/if-up.d/avahi-daemon
run-parts: executing /etc/network/if-up.d/mountnfs
if-up.d/mountnfs[wlan0]: waiting for interface lo before doing NFS mounts (warning).
run-parts: executing /etc/network/if-up.d/openvpn
run-parts: executing /etc/network/if-up.d/wpasupplicant

My wlan0 interface configuration in /etc/network/interfaces

iface wlan0 inet dhcp
  wpa-driver wext
  wpa-ssid XXX
  wpa-ap-scan 1
  wpa-proto WPA
  wpa-pairwise TKIP
  wpa-group TKIP
  wpa-key-mgmt WPA-PSK
  wpa-psk ZZZ
  wireless-channel 6

I am using a customized 2.6.25-4 kernel, on an x86_64 Debian testing machine.

I've asked for help elsewhere but all I learned is that the driver seems to work fine.

Thank you

Tons of Fun 09-01-2008 09:20 AM

From looking at your listings, it appears that you are not getting an ip address, therefore you aren't on the network. I would look at this before anything else. Your configuration looks good, and the card initializes which means the driver and firmware are both good. But notice after issuing the ifup command, you didn't receive an ip address from your dhcp server and the card went to sleep. That's where I believe your problem is.


LordFrancis 09-01-2008 01:50 PM

Thanks for the reply.

I see what you mean. However, how can I get an IP address from DHCP, when my driver sees _no_ networks, and is not associated with any access point?

If I remember well, what normally happens is:
1. device is up, driver is loaded
2. finds n networks after scan
3. connects to one of the n networks

I am missing point 2, which I believe is necessary to connect.
Is that right?

darkangel29 09-27-2008 01:52 AM

How did you got the b43 driver to work with Broadcom BCM4312?

Tons of Fun 09-27-2008 10:56 AM

I had a real hard time getting my broadcom card to work. In my case, the problem was the broadcom firmware. Using fwcutter didn't work because the firmware server that hosts the fwcutter firmware downloads has been down. I found this site and followed his instructions, and my wireless installed perfectly. Here is the link:

Make sure you read the whole thing through before you start as he has addendums throughout.


LordFrancis 10-01-2008 10:12 PM

I actually haven't had any problems getting it to work in the first place. It happened that it stopped working, and since then there has been nothing that fixed it.

I use the fwcutter from the debian repositories, it seems to get the firmware itself and install it. The link you posted explains pretty much what I do.

I am beginning to think that the device has a hardware problem, since it cannot see _any_ network around (and I know for sure there are).

Thanks for your help anyway!

Tons of Fun 10-02-2008 07:27 AM

I apologize that I missed the point about it working in the first place. It is possible that the card could be bad. In my experience, when a NIC stops working, it's usually not hardware. That's not to say that it isn't bad, just my past experience.

Have you tried a program such as wifi-radar? On my Debian Etch laptop, the network manager wouldn't see the networks, but wifi-radar saw them and allowed me to connect to them. Also, the built-in network manager wouldn't allow me to set up anything other than WEP for security. I am using WPA, so I had to modify my interfaces conf file for my home network, and then used wifi-radar when I was away from the house. Just a thought.

LordFrancis 10-02-2008 11:36 PM

I tried wifi-radar now. I am not sure whether it should scan for networks and show them in a list or not, but the list was empty. I added a new configuration with "New" and then tried to connect, but it didn't work.

I am using WEP and I have a MAC address filter.

Not sure what to do next.. :confused:

Tons of Fun 10-04-2008 10:15 AM

I would remove WEP and MAC filtering and try to get the wireless working first, then enable those features. That way, you eliminate other issue that could be causing it.

Wifi-Radar should show you a list of available networks shortly after starting. If you don't see any, then clearly the card isn't seeing them. I am out of ideas as everything shows it should be working. Hopefully someone else can chime in and let us know what we're missing.

All times are GMT -5. The time now is 02:51 AM.