-   Linux - Wireless Networking (
-   -   Newbie can't set up netgear usb adapter (

Lynswin 10-04-2006 03:10 PM

Newbie can't set up netgear usb adapter
Please help! I have been trying to sort this out for days but with no luck! I have recently installed Freespire and I am trying to get my network setup. I have a Netgear WG111 USB adapter. I am a complete n00b and have been following a step-by-step guide and have managed to install the drivers using ndiswrapper. Now when I type 'sudo ndiswrapper -l' in the list my drivers are installed and hardware present. The problem is, when i go on to the next bit, where I type 'sudo iwconfig' I get 'no wireless connections' and certainly no wlan0. So I can't really go any further. Can someone please tell me what to do next?

Any help would be greatly appreciated.



Lynswin 10-05-2006 03:14 AM

Anyone? Why is this the only thread with no reply? Surely someone can help me out? I would have thought this would be fairly straightforward for someone familiar with Linux?
Many thanks

Lynswin 10-05-2006 07:11 AM

looks like Microsoft wins again. :mad:

mickyg 10-05-2006 07:16 AM

Have you run

ndiswrapper -m
to create the module alias and then

sudo modprobe ndiswrapper
to load the ndiswrapper module into the kernel.

This should create your wlan0 interface.

Lynswin 10-05-2006 07:34 AM

Hi. Many thanks for the reply. Yes, I have used both of these commands but still no wlan0.

I have just tried typing them again and after typing the 'ndiswrapper -m' I get 'modprobe config already contains alias directive'. If I then type 'sudo modprobe ndiswrapper' nothing appeasr to happen it just goes straight back to my 'command line'(not sure if this is what it is called in Linux).

Is any of this relevant?



mickyg 10-06-2006 03:18 AM

Yes, if it goes back to the command line that normally means its loaded the driver successfully. You can check its loaded by running

sudo lsmod
Also, might be worth seeing what output you get from

sudo ifconfig -a
This should list all your interfaces. Also check any log files, i.e.

tail -n20 /var/log/messages

See if these give any clues as to what's happening when you run modprobe.

Post the output of these if there's stuff you don't understand.

Lynswin 10-07-2006 03:24 AM


Many thanks for your help but I have decided Linux is not for me (I just don't have the time to mess about with it). This morning when I type 'sudo ndiswrapper -l' the driver comes up as 'invalid driver' so I am back to square one with it.

I am really disappointed as I really wanted to get away from Microsoft but until they make Linux a bit more 'plug and play' I think it will be missing out on a lot of potential converts.

Thanks again


kingofthevegetables 12-27-2006 05:53 PM

I am in total agreement. It's really not worth the hassle for me. I have same USB adapter (WG111) and am having similar issues with Ubuntu.


mickyg 12-28-2006 11:30 AM

Well each to their own I guess, I do agree that Linux can be a pain sometimes but it is important to remember it's not necessarily 'Linux' that's the problem, it's the hardware manufacturers that don't always play nice, or use open standards. After all if they did, you wouldn't even need ndiswrapper!

In any case I urge you not to strike off Linux completely, after all part of the beauty of Linux is choice, Freespire and Ubuntu are both Debian based distros so it might be worth trying a different distro, such as Suse, Mandriva or Fedora as examples. I'm not saying this will solve all your problems with Linux but every distro works slightly different. For example, I'm using OpenSuse 10.0 whereby ndiswrapper works fine after a little tweaking with the startup scripts to get it to load the module on boot, however, in OpenSuse 10.1 I couldn't even load ndiswrapper. Mandriva worked a charm with ndiswrapper and I didn't even need to tweak any scripts, whereas much to my total surprise SimplyMepis worked completely 'out of the box' and I didn't even need to use ndiswrapper for my wireless.

Have a look at if you're still interested in getting away from MS.

Debord 02-17-2007 11:59 AM

I have the same problem with my Netgear wg111-v2 and I think the problem is that I connected it to a windows machine and installed it there, and get the usb locked to only that machine. It whas one of the steps in the installation process to take the usb out and put it in ather machined it should bee used in, but I didnt do that, just continued with the installation, and proberly the hardwere know is locked. Can that bee true?

Excuse my bad english!

mickyg 02-20-2007 02:07 PM

Um, no, I don't think that'd be it. At least I've never heard of anything like that, it would mean you wouldn't be able to sell the device on which would, AFAIK, violate fair use laws (please don't quote me on that! lol) Besides, you're running it on the same machine, just with a different OS.

I can *almost* guarantee you that it's a driver issue.

Have a read of this thread, it might help.

Also, the ndiswrapper wiki might help.

All times are GMT -5. The time now is 09:11 PM.