-   Linux - Wireless Networking (
-   -   Networking woes with Netgear WNA3100 in Kubuntu 11.10 (

Robthemansays1 11-28-2011 10:04 PM

Networking woes with Netgear WNA3100 in Kubuntu 11.10
I just did a fresh install of Kubuntu 11.10 (big fan of KDE, especially after using GNOME2 for so long) and I'm having trouble getting Kubuntu to recognize my wireless adapter.

I went through all the steps to install the Windows driver using ndiswrapper, and I'm pretty sure it installed correctly:

->: ndiswrapper -l
bcmwlhigh6 : driver installed
device (0846:9020) present

So I'm guessing that not only is the driver installed, it recognizes the adapter is there as well. So good so far.

My problem lies in the fact that I can't seem to get any of Kubuntu's tools to recognize the adapter anywhere. In the Network Connections dialog, the Wireless tab is greyed out. Is there something I need to do to enable wireless? Thanks for your help!

Robthemansays1 11-29-2011 10:40 AM

More information
So I've been working on this more and I don't think the 'wlan0' device is getting added correctly...

I'm following the steps on to get the driver working and I run the following commands:

Go:sudo depmod -a
Go:sudo modprobe ndiswrapper

It seems to complete correctly (when I run 'tail /var/log/messages', it says the file doesn't exist). However, when I run iwconfig, it doesn't even list a 'wlan0' device (I'm tethering through my phone as of right now, that's what easytether0 is):

lo no wireless extensions.

eth0 no wireless extensions.

easytether0 no wireless extensions.

Any possible reason why 'wlan0' isn't getting added?

Robthemansays1 11-29-2011 11:12 AM

Okay, so after a little more digging, I found out that it wasn't loading the driver correctly. I ran "dmesg" and this last line gave me some help:

[ 3244.688889] ndiswrapper (load_wrap_driver:108): couldn't load driver bcmwlhigh6; check system log for messages from 'loadndisdriver'

It turns out the Windows driver I was trying to use wouldn't load correctly. So I just reverted bcmwlhigh5 - it was listed on all the help pages (you can download it here). It works like a charm and no more tethering necessary!

All times are GMT -5. The time now is 11:56 PM.