-   Linux - Wireless Networking (
-   -   Netgear WG311 on SUSE 10 (

Bluestreak 10-29-2005 04:09 PM

Netgear WG311 on SUSE 10
It appears that ndiswrapper is not working on my system. I followed the instructions for the WG511 card, and at the point where I install wireless card drivers and type the command ndiswrapper -i WG311v3.inf , it says: Already installed, invalid driver! . I then went and checked what other driver is installed using the ndiswrapper -l command. And it responds with WG311v3 installed, invalid driver! .

At this point, I can't do anything else, because without ndiswrapper, my computer can't connect to the router... It's ironic because Novell is a networking company, and the first thing that doesn't work with this distro is the networking function! What makes it worse is that in Mandriva, it does all the automatically when you first install it. I still can't get online with that, but at the very least I have the light blinking at the back of the card.

Any procedures would be greatly appreciated, as I've been offline for about two months now.... (posting this at work)

(By the way, the instructions for the WG511 included the procedure to install ndiswrapper. That's what I'm refering to in the beginning of the post. However, SUSE 10 already has it, so I just continued to make the hotplug link, and the ndiswrapper -m)

fouldsy 10-29-2005 05:52 PM

I couldn't get my WG311 working using ndiswrapper, I had to use tha ACX100 drivers and updated firmware as documented here. It's not easy-peasy, but not overly complicated if you follow it through step-by-step. Hope it helps.

Bluestreak 10-31-2005 07:03 PM

No more console!
Thanks for the link, but I rather not try building things from source for two main reasons:

1) I don't have the time for this
2) Every time I try things in console - the ndiswrapper installation - nothing comes out the way it should.

After years using console, I can conclude that I am not savvy enough to compile things from source, use the make and make install commands properly. I am either going to have to get one of those quick reference guides for console commands, or not bother anymore.

This is the bottom line: As far as I've seen (SuSE versions 9 and higher, Mandrake9-10) the newer linux distros are losing consistency in terms of hardware support. Every time I updated SuSE, there was something that was fixed, and something that went missing (SuSE 9 detected my Soundblaster 16-but couldn't use it, while nVidia drivers were available through YaST Online Update... Version 10: Didn't even detect my sound card anymore, and the cd drives are not accessible by any other user except root, )even after adding them in at YaST) (Mandrake 10: installed my wireless card with ndiswrapper - this got the light blinking, as opposed to SuSE, which still didn't come on after trying six or seven other methods - but it doesn't stay steady, showing me it's working. I can't get online with this...)

The only things improving is KDE... That's about it. I've tried to make Karamba more useable by customizing the widgets... but the instructions are complicated, and when you go through them, it still doesn't work... (SuSE). It's annoying to go to and see all types of stuff on the desktop, and can't do the same on my own machine.

jimbo7 08-11-2006 01:13 AM

Hi guys. Check out my mini wiki on how to install the WG311v3 Driver on Debian, i hope it can be helpful. And feel free to contribute to make it better!


tskears 08-11-2006 03:38 PM

It's been a while since I used Suse, but I seem to remember having my WG311v3 card working with pre-built Madwifi drivers. Everything worked, but nothing connected until I discovered "iwpriv ath0 authmode 2". Adding that to rc.local had everything working at boot. I had the same issues with the same card under PCLinuxOS, but I already knew the fix... :)

Try the madwifi drivers...I believe madwifi is available using <Sofware Install> through YAST.

All times are GMT -5. The time now is 08:14 AM.