-   Linux - Wireless Networking (
-   -   Netgear MA101 with Linksys WRT54GS help (

sqwiggly 11-17-2006 08:15 AM

Netgear MA101 with Linksys WRT54GS help
I have installed the netgear usb adapter upstairs on my linux pc. Everything seems to be coming up ok with iwconfig and ifconfig. The ip address etc. is assigned through dhcpcd wlan0. I can ping and access the linksys router's config page, but still cannot access any webpages.

I have also tried using a linksys WUSB11v4 adapter upstairs but couldn't get it to work, so as I know that the netgear one has worked before with linux, I thought it'd be easier to just try and configure that one.

Does anyone have any ideas?

Should also mention that I can't get this setup to work on windows either... it finds the network, says it's joining, but then doesn't connect, which is similar to what I think is happening with linux.


rjwilmsi 11-18-2006 05:55 AM

Hmm, how reliably can you connect and navigate around the router's configuration pages. If you can do that reliably at any time then you probably have DNS issues so can't see internet pages. Try pinging Google and report what happens.

However, I think you just have a bad connection. My experience with USB WLAN cards was not good. I don't think they're as good as Cardbus or PCI ones.

jschiwal 11-18-2006 06:29 AM

Are you using wpa encryption? If so, use wpa_cli to montitor whether the device is losing it's association frequently. Also check whether you have the default gateway set to and if you have the nameserver (DNS) addresses. Also see if you can browse to the routers setup. You will first need to allow that with a wired connection however I wouldn't recommend it if you don't use encryption or just use WEP. If you have a second device such as a NIC device, make sure it either isn't on the same subnet or is shut down.

You can check the route with the /sbin/route command.
Here is how mine looks like:

/sbin/route -n
Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface U    0      0        0 wlan0 U    0      0        0 eth0    U    0      0        0 eth0      U    0      0        0 lo        UG    0      0        0 wlan0

My eth0 device is connected to a switch with a networked printer. Notice that it is on a different subnet.
The last line is the default gateway. If it isn't present, then you can set it with:
"sudo /sbin/route add default netmask gw wlan0"
I'm assuming that you don't have your network subnetted.

Cat out the /etc/resolv.conf file. The nameservers listed should match what the route says on its status page. They are needed to resolve domain names to IP address on the internet.

All times are GMT -5. The time now is 06:28 AM.