LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 03-17-2006, 07:12 PM   #1
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Rep: Reputation: 30
Need some help configuring wpa_supplicant


I've searched all over, but I can't seem to find what I need. I need to get WPA encryption working in SUSE 10, but I think I did something wrong configuring wpa_supplicant. Here is the code I get trying to run program:
Code:
linux:/ # /usr/sbin/wpa_supplicant -B -c/etc/wpa_supplicant.conf -ira0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
Here is my /etc/wpa_suplicant.conf
Code:
network={
      ssid="home"
      scan_ssid=1
      key_mgmt=WPA-PSK
      psk="blahblahblah"
}
Also, if it matters, I'm using a ralink rt2500 card.
 
Old 03-17-2006, 08:29 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Use the YaST Network Interface configuration to set up wireless.

Here is what my /etc/wpa_supplicant looks like:

> cat /etc/wpa_supplicant
# allow frontend (e.g., wpa_cli) to be used by all users in 'wheel' group
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
#
# home network; allow all valid ciphers
network={
ssid="jesnet"
scan_ssid=1
# key_mgmt=WPA-PSK
psk="secretpassphrase" # bogus value in this example.
}

The psk isn't what my network uses, instead the value saved in
/etc/sysconfig/network/ifcfg-wlan0 is used. It matches what my router uses. I used the /dev/random device to generate this 64-digit random hexidecimal key.
Code:
cat /etc/sysconfig/network/ifcfg-wlan0
BOOTPROTO='dhcp'
BROADCAST=''
IPADDR=''
MTU=''
NAME='Wireless Network Card'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='yes'
WIRELESS_AP='ma:ca:dd:re:ss:xx'
WIRELESS_AUTH_MODE='psk'
WIRELESS_BITRATE=''
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='myessidname'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0='h:webkeyidontuse'
WIRELESS_KEY_1='h:webkeyidontuseinhexidecim2'
WIRELESS_KEY_2='h:webkeyidontuseinhexidecim3'
WIRELESS_KEY_3='h:webkeyidontuseinhexidecim4'
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK='hpamd64'
WIRELESS_NWID=''
WIRELESS_POWER='no'
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK='xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
_nm_name='static-0'
PREFIXLEN=''

Last edited by jschiwal; 03-17-2006 at 08:32 PM.
 
Old 03-18-2006, 08:04 AM   #3
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Still not working, I configured it with YaST and set my configuration files as follows (censored):
/etc/wpa_supplicant.conf
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
      ssid="home"
      scan_ssid=1
      key_mgmt=WPA-PSK
      psk="blahblahblah"
}
/etc/sysconfig/network/ifcfg-wlan0
Code:
BROADCAST=''
IPADDR=''
MTU=''
NAME='Edimax Ralink RT2500 802.11 Cardbus Reference Card'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
UNIQUE='VQ+S.iEGUOSdqaYE'
USERCONTROL='yes'
WIRELESS_AUTH_MODE='psk'
WIRELESS_CA_CERT=''
WIRELESS_CLIENT_CERT=''
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_NICK=''
WIRELESS_POWER='yes'
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK='blahblahblah'
_nm_name='bus-pci-0000:07:00.0'
WIRELESS_ESSID='home'
WIRELESS_KEY_0=''
BOOTPROTO='dhcp'
WIRELESS_NWID=''
WIRELESS_KEY=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_KEY_LENGTH='128'
WIRELESS_AP='00:11:95:56:f9:1d'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_MODE='Managed'
WIRELESS_FREQUENCY=''
But I still get the following errors when trying to run wpa_supplicant:
Code:
# /usr/sbin/wpa_supplicant -d -c/etc/wpa_supplicant.conf -ira0
Initializing interface 'ra0' conf '/etc/wpa_supplicant.conf' driver 'default'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=10 (from group name 'wheel')
Priority group 0
   id=0 ssid='home'
Initializing interface (2) 'ra0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
ioctl[SIOCSIWPMKSA]: Operation not supported
SIOCGIWRANGE: WE(compiled)=18 WE(source)=14 enc_capa=0x0
  capabilities: key_mgmt 0x0 enc 0x3
Own MAC address: 00:0e:3b:04:06:01
wpa_driver_hostap_set_wpa: enabled=1
wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
Failed to set encryption.
wpa_driver_hostap_set_countermeasures: enabled=0
wpa_driver_hostap_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Using existing control interface directory.
bind(PF_UNIX): Address already in use
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/ra0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.
wpa_driver_hostap_set_wpa: enabled=0
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported
wpa_driver_hostap_set_drop_unencrypted: enabled=0
wpa_driver_hostap_set_countermeasures: enabled=0
No keys have been configured - skip key clearing

Last edited by pdeman2; 03-18-2006 at 08:05 AM.
 
Old 03-18-2006, 08:29 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
I would suggest backing up and looking at the other parts of the setup also.

For example, do you also have a nic interface. Try shutting it down if it isn't already and restarting the wireless.
sudo /sbin/rcnetwork stop eth0
sudo /sbin/rcnetwork restart wlan0

Look at the output of /sbin/ifconfig and /usr/sbin/iwconfig. A good command to find out if the wireless interface is working is to run /usr/sbin/iwlist scan.
 
Old 03-18-2006, 09:48 AM   #5
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Okay, I stoped and restarted ra0 (my wireless interface) and here is the output:
Code:
# /sbin/rcnetwork restart ra0
Shutting down network interfaces:
    ra0       device: RaLink Ralink RT2500 802.11 Cardbus Reference Card (rev 01)
    ra0       configuration: wlan-id-00:0e:3b:04:06:01               done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
    ra0       device: RaLink Ralink RT2500 802.11 Cardbus Reference Card (rev 01)
    ra0       configuration: wlan-id-00:0e:3b:04:06:01
    ra0       warning: WPA configured but may be unsupported
    ra0       warning: by this device
    ra0       starting wpa_supplicant
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWAUTH]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - ioctl[SIOCSIWAUTH]: Operation not supported
    ra0       (DHCP) . . . . . no IP address yet... backgrounding.   waiting
SuSEfirewall2: Warning: ip6tables does not support state matching. Extended IPv6 support disabled.
SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
SuSEfirewall2: batch committing...
SuSEfirewall2: Firewall rules successfully set
I also did iwlist scan, and it seems to be working, I just still can't connect to the AP.
 
Old 03-18-2006, 09:29 PM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Take a look at what is supported according to the kernel.
sudo cat /proc/net/prism2/ra0/hw

Look for a line like: encryption_modes=WEP; TKIP with WPA; AES/CCMP with WPA
I am assuming that your kernel wrapper is named prism2.
Maybe TKIP with WPA isn't supported by your kernel module. That may mean that your driver is too old.
 
Old 03-19-2006, 07:58 AM   #7
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
I don't have a prism2 directory or anything like it in my /proc/net/. Is there anywhere else I could look?
 
Old 03-19-2006, 09:04 PM   #8
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Original Poster
Rep: Reputation: 30
Okay, I got my answer from a couple other forums. It appears that the current stable rt2500 driver for linux does not support WPA. Thanks for the help, jschiwal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wpa_supplicant addisonzinser Slackware 0 02-04-2006 12:12 AM
wpa_supplicant hosler Slackware 7 01-25-2006 04:48 PM
need help with wpa_supplicant slinky2004 Linux - Software 7 12-30-2005 07:07 PM
wpa_supplicant (AGAIN) gbergeson Linux - Laptop and Netbook 10 08-03-2005 08:28 AM
WPA_Supplicant Fraudulent Linux - Wireless Networking 0 10-04-2004 07:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 01:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration