-   Linux - Wireless Networking (
-   -   ndiswrapper works but doesnt? (

AKA-tex 08-17-2005 10:56 PM

ndiswrapper works but doesnt?
Well, i followed all the install stuff for ndiswrapper and the xp driver for my card etc, everything seems to check out according to the ndiswrapper install instructions, but all i get is a "host not found" from anything trying to access the net (ping, links, mozilla, etc)

some morespecific info:

ndiswrapper version : 1.1
kernel: 2.4.26
distro: slackware 10.0
architecture: i586
wireless card: TrendNet TEW-226PC

so after everything wasdone and setup....
modprobe ndiswrapper reports no errors
ndiswrapper -l
Installed ndis drivers:
net8180 driver present, hardware present
iwconfig output:

lo no wireless extensions.

wlan0 IEEE 802.11b ESSID:"slyone"
Mode:Managed Frequency:2.462GHz Access Point: 00:90:96:CF:CB:6A
Bit Rate:11Mb/s Tx-Power:20 dBm Sensitivity=0/3
RTS thr:2432 B Fragment thr:2432 B
Encryption key:xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx-xxxx Security mode:open
Power Management:off
Link Quality:100/100 Signal level:-54 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
ifconfig output:
lo Link encap:Local Loopback
inet addr: Mask:
RX packets:156 errors:0 dropped:0 overruns:0 frame:0
TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12146 (11.8 Kb) TX bytes:12146 (11.8 Kb)

wlan0 Link encap:Ethernet HWaddr 00:40:F4:9F:EE:E5
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:4720 (4.6 Kb)
dmesg output:

ndiswrapper version 1.1 loaded (preempt=no,smp=no)
ndiswrapper: driver net8180 (Realtek,10/07/2004,5.173.1007.2004) loaded
PCI: Setting latency timer of device 02:00.0 to 64
ndiswrapper: using irq 10
wlan0: ndiswrapper ethernet device 00:40:f4:9f:ee:e5 using driver net8180, configuration file 10EC:8180.5.conf
wlan0: encryption modes supported: WEP, WPA with TKIP, WPA with AES/CCMP


so, obviously the encryption key isnt a bunch of x's...anywho... to me everything seems ready to go, but everything is apparently a no guessing it is something really dumb. I also tried

ifconfig wlan0
route add default gw

that didnt help either tho (I didnt forget ifconfig wlan0 up either) still getting the "Host Not Found"...In desperation i tried multiple random (but possible) configs with netconfig

anyone got any ideas?...if it turns out i missed something stupid, then let the flaming begin, lol.

bathory 08-18-2005 03:16 AM

Check your /etc/resolv.conf to see if you have a valid nameserver listed there. If not add one and try again.


AKA-tex 08-19-2005 01:16 AM

hm, i tried your suggestion bathory, and i also tried just using dhcp...again...still getting the "host not found" tho. thank you for the suggestion, anymore? lol, theyd be very welcome :)

bathory 08-19-2005 02:02 AM


ifconfig wlan0
You should use:

ifconfig wlan0 netmask x.x.x.x up

AKA-tex 08-19-2005 12:35 PM

no change :(

tuxdev 08-19-2005 12:46 PM

You should not need to run ifconfig at all. Issueing the correct iwconfig comands and then doing "dhcpcd wlan0" usually works.

AKA-tex 08-21-2005 12:43 AM

Still doesnt work...:confused:

eno_on 08-21-2005 05:44 PM

You may want to try to:
-Turn off encryption on your network and try to connect without the key. What kind of key do you have? WPA or WEP?
-If that doesn't work compile or use a precompiled version of kernel 2.6 and reinstall ndiswrapper.

All times are GMT -5. The time now is 12:56 AM.