LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 07-06-2004, 12:54 PM   #1
patrickclay
Member
 
Registered: May 2004
Location: San Antonio
Distribution: Slackware, Gentoo
Posts: 35

Rep: Reputation: 15
ndiswrapper with intel pro/wireless 2200BG Fedora 1


I'm having problems configuring ndiswrapper to work with my Intel PRO/wireless 2200BG card. I'm not sure what the problem is, so I'll explain the process which i followed.

Downloaded ndiswrapper. Compiled.

Downloaded Intel windows driver from linuxant.com

./ndiswrapper -i w22n51.INF

./ndiswrapper -l

Installed ndis drivers:
w22n51 present

./modprobe ndiswrapper

/dmesg

ndiswrapper version 0.7 loaded
ndiswrapper adding w22n51.sys
divert: allocating divert_blk for wlan0
wlan0: ndiswrapper ethernet device 00:0e:35:14:72:9d using driver w22n51.sys

This is where I get lost.

./iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:"" Nickname:"localhost.localdomain"
Mode:Managed Access Point: FF:FF:FF:FF:FF:FF Bit Rate=54Mb/s
RTS thr=1600 B Fragment thr=2304 B
Encryption keyff
Power Managementff
Link Quality:0/100 Signal level:24/154 Noise level:0/154
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

when I try ./ifup wlan0 I get the message:

Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0... failed.

Any suggestions? Thank you!
 
Old 07-09-2004, 08:48 PM   #2
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 220

Rep: Reputation: 32
I'm basically where you are, although I'm running slackware.

My access point is ff:ff:ff... and I can't change it using
Code:
iwconfig wlan0 ap <mac address>
I get:
Code:
Error for wireless request "set AP Address" (8B14)  :
    SET failed on device wlan0 ; Invalid argument.
When I boot I turn off my lan card using ifconfig eth0 down, and I turn on my wireless using ifconfig wlan0 up. I can manually assign wlan0 its ip or netmask using ifconfig, but I can't get online.

I also can't change the essid using iwconfig, same deal.

Anyone able to get ipw2200 (or even 2100 I suppose) intel centrino wireless working using ndiswrapper windows drivers?
 
Old 07-10-2004, 07:40 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Patrick,
It looks like your driver is installed properly, you just need to configure your card and request an IP address. Something like this might do the trick:

iwconfig wlan0 key XXXXXX (If you use WEP. I've found it usefu to set the WEP key first)
iwconfig wlan0 essid YYYYYYY
iwconfig mode Managed
dhclient wlna0 (this requests an IP from your DHCP server)
ifup wlan0

Atmchicago,
I don't think you need to set your AP MAC address. If you're using WEP, try setting the key first. Also be sure you are su (root) when using iwconfig.
 
Old 07-10-2004, 12:38 PM   #4
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 220

Rep: Reputation: 32
Ok, I've been running as root when using iwconfig the whole time. But isn't it strange that I can't change the essid/ap mac adress ? Also, not using WEP yet - want to keep things simple.

Edit: I forgot to use my 8k stacks kernel when testing, so I'll recompile and see how it goes.

Edit2: Nope, 8k stacks give the same result.

Last edited by Atmchicago; 07-10-2004 at 02:40 PM.
 
Old 07-10-2004, 03:51 PM   #5
patrickclay
Member
 
Registered: May 2004
Location: San Antonio
Distribution: Slackware, Gentoo
Posts: 35

Original Poster
Rep: Reputation: 15
I also can't set ESSID. I try using iwconfig and editing the ifcfg-wlan0 file but it doens't still doensn't show up.
 
Old 07-11-2004, 04:08 AM   #6
lucas2676
LQ Newbie
 
Registered: Oct 2003
Distribution: RedHat
Posts: 12

Rep: Reputation: 0
I saw the same thing as both of you. I ran ifconfig wlan0 up 192.168.x.xxx and set it up as a static ip. Then I added the route for the default gw(route add default gw <gwipaddress>) and I set up just fine.
 
Old 07-11-2004, 08:20 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
OK, a couple of things to try:

Turn on SSID broadcast from your router. Some people here have reported that they can't connect to their router unless this is on. Weird, but apparently it happens.

You might look for an older set of windows drivers (for win 98 even). If windows drivers came with your card try those instead of downloading new ones. This may be one of those cases where going with the latest and greatest may be causing trouble.


For what it's worth, this is a pretty common problem and unfortunately I haven't seen a single, clear answer.
 
Old 07-11-2004, 10:54 PM   #8
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 220

Rep: Reputation: 32
I have a truemobile 1170 router from dell. Not sure who actually makes it (maybe dell gives me gimp firmware that has fewer options than the actual?), but the only option I have for SSID is to give it a name. How can I have it broadcast?

As for the win98 drivers, I doubt they would exist - the centrino is brand new, and win98 is ooold... The cd that has drivers on it only has win2k and wixp drivers on it (I actually already tried the win2k drivers and it didn't even work as well as the winxp ones).

Lucas, I tried your route command, and it didn't give any errors, but didn't fix the problem.

Thanks for the help, I hope I can get this working soon.
 
Old 07-12-2004, 10:33 AM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
I was looking at the ndiswrapper help forums on sourceforge and for probelms setting the ESSID, try switching your mode to Auto instead of Managed. Apparently this trick works well for Broadcom chipsets. Maybe it works for others as well.
 
Old 07-12-2004, 12:17 PM   #10
Atmchicago
Member
 
Registered: Apr 2003
Location: Baltimore
Distribution: Fedora
Posts: 220

Rep: Reputation: 32
Ok well it just looks to me like the status of the driver is still in beta development, because I tried changing the mode with
Code:
 % iwconfig wlan0 mode Auto (or auto)
and it didn't change it from managed. So when a new version of ndiswrapper, or the ipw2200 drivers come out, then it might work. The reason I say this is because I can change some things, like static ip, nick name, but not others - they either don't do anything or give errors.

Oh well, guess i'll have to stick to using my ethernet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel PRO/Wireless 2200BG henriette Linux - Laptop and Netbook 5 05-20-2007 02:50 PM
Intel PRO/Wireless 2200BG wfischer Linux - Wireless Networking 3 10-25-2006 09:20 AM
Intel pro/wireless 2200BG lobwolf Linux - Wireless Networking 27 11-01-2005 10:20 AM
please help intel pro wireless 2200BG with fedora core 4 terrence Linux - Wireless Networking 19 09-05-2005 12:32 AM
FC2 not recognizing the Intel PRO/Wireless 2200BG wireless card mdslf Linux - Laptop and Netbook 2 08-24-2004 02:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 04:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration