Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 07-18-2004, 03:53 AM   #1
LQ Newbie
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
ndiswrapper, linksys 802.11g, essid not "sticking"

Alright, a bit of background: I'm running debian sid, 2.6.6 kernel. Newest everything with apt-get update / upgrade.

When I bring wlan0 (my wireless adapter) up with ifup wlan0, I get no errors. ndiswrapper lists "present" next to the driver (lsbcmnds). However, I cannot get an essid to "stick" with this card.

I execute the command:

iwconfig wlan0 essid "myessid"

and see confirmation of that command in iwevent in another xterm. I also see no events after it in iwevent, so no daemon is changing things back.

Then I run iwconfig once more, and see that my ESSID is blank.

Also, my security mode defaults to restricted, even though I have this line in my interfaces file:

wireless_mode Managed yeah. I'm kinda frustrated.
Old 07-18-2004, 12:34 PM   #2
LQ Veteran
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 417Reputation: 417Reputation: 417Reputation: 417Reputation: 417
With some cards, particularly those using Broadcom chipsets, you need your mode to be Auto for ESSID changes to stick. I'm not sure if it is a bug in ndiswrapper or just the facts of life when trying to make Windows drivers work under linux.
Old 07-18-2004, 02:59 PM   #3
LQ Newbie
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
No luck. After turning off encryption and setting the mode to auto, the essid still doesn't stick. The mode does change to auto, however. My AP mac address seems bogus; FF:FF:FF:FF:FF:FF .. I can find the stuff on iwlist wlan0 -scanning. I may try some other drivers, even though this one is shown as "present" by ndiswrapper.
Old 07-18-2004, 03:23 PM   #4
Registered: Oct 2003
Location: United Kingdom
Distribution: SuSE 10.0 - 11.4
Posts: 347

Rep: Reputation: 30
AP address of all FFs means that it's not connecting. Could be driver problem. Could also be some error in order of loading - I've got a cardbus wireless card and my system default order of loading was network first and then pcmcia - so ndiswrapper reports card present but nothing works.

Could try rmmod ndiswrapper then insmod ndiswrapper and then iwconfig command to see if that makes a difference.
Old 07-18-2004, 03:48 PM   #5
LQ Newbie
Registered: Jul 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Nope, no difference. I tried using the linuxant driver loader, and it says it cannot find a device that goes with the driver I supplied (even though the driver I supplied was from the linksys website for my specific card)...
Next thing I'm gonna try is bcmwl5a.sys or whatever that alternative is.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper worked fine "ESSID:off/any" ??? cant put in an ssid?? fatrandy13 Linux - Wireless Networking 12 08-21-2011 11:32 PM
Mandrake: Linksys 802.11G PCI alacritous Linux - Wireless Networking 1 10-09-2004 07:09 PM
ndiswrapper with Broadcom WLAN mini-PCI :: iwconfig returns ESSID:"" chr15t0 Linux - Wireless Networking 17 07-27-2004 07:40 AM
linksys wireless 802.11g ronss Linux - Wireless Networking 2 11-10-2003 05:11 PM
Console text "sticking" Stormski Debian 3 10-14-2003 01:52 AM > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 09:39 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration