-   Linux - Wireless Networking (
-   -   ndiswrapper, linksys 802.11g, essid not "sticking" (

bishiraver 07-18-2004 04:53 AM

ndiswrapper, linksys 802.11g, essid not "sticking"
Alright, a bit of background: I'm running debian sid, 2.6.6 kernel. Newest everything with apt-get update / upgrade.

When I bring wlan0 (my wireless adapter) up with ifup wlan0, I get no errors. ndiswrapper lists "present" next to the driver (lsbcmnds). However, I cannot get an essid to "stick" with this card.

I execute the command:

iwconfig wlan0 essid "myessid"

and see confirmation of that command in iwevent in another xterm. I also see no events after it in iwevent, so no daemon is changing things back.

Then I run iwconfig once more, and see that my ESSID is blank.

Also, my security mode defaults to restricted, even though I have this line in my interfaces file:

wireless_mode Managed yeah. I'm kinda frustrated.

Hangdog42 07-18-2004 01:34 PM

With some cards, particularly those using Broadcom chipsets, you need your mode to be Auto for ESSID changes to stick. I'm not sure if it is a bug in ndiswrapper or just the facts of life when trying to make Windows drivers work under linux.

bishiraver 07-18-2004 03:59 PM

No luck. After turning off encryption and setting the mode to auto, the essid still doesn't stick. The mode does change to auto, however. My AP mac address seems bogus; FF:FF:FF:FF:FF:FF .. I can find the stuff on iwlist wlan0 -scanning. I may try some other drivers, even though this one is shown as "present" by ndiswrapper.

andrewdodsworth 07-18-2004 04:23 PM

AP address of all FFs means that it's not connecting. Could be driver problem. Could also be some error in order of loading - I've got a cardbus wireless card and my system default order of loading was network first and then pcmcia - so ndiswrapper reports card present but nothing works.

Could try rmmod ndiswrapper then insmod ndiswrapper and then iwconfig command to see if that makes a difference.

bishiraver 07-18-2004 04:48 PM

Nope, no difference. I tried using the linuxant driver loader, and it says it cannot find a device that goes with the driver I supplied (even though the driver I supplied was from the linksys website for my specific card)...
Next thing I'm gonna try is bcmwl5a.sys or whatever that alternative is.

All times are GMT -5. The time now is 02:43 PM.