-   Linux - Wireless Networking (
-   -   Ndiswrapper kernel-module version mismatch (

Ian 04-04-2004 11:15 AM

Ndiswrapper kernel-module version mismatch

I installed ndiswrapper on Mandrake 9.2 for my wpc54g wireless card and am using KDE. I had ndiswrapper working perfectly, but then I was tinkering with the network settings and now I cannot get it to work.

What I tried:

I created a link: ln -s /usr/src/linux /lib/modules/2.4.2-10mdk

I ran ./ and the program loaded without a hitch.

Then I tried to run the following script (which had worked before):

ifdown wlan0
modprobe ndiswrapper
# /usr/local/bin/loadndisdriver 14e4 4320 \
/usr/sbin/loadndisdriver 14e4 4320 \
/usr/local/ndiswrapper/*.sys \


The error I get:

[root@Goblin ndiswrapper]# wifiup
/lib/modules/2.4.22-10mdk/misc/ndiswrapper.o: kernel-module version mismatch
/lib/modules/2.4.22-10mdk/misc/ndiswrapper.o was compiled for kernel version 2.4.22-28mdkcustom
while this kernel is version 2.4.22-10mdk.
modprobe: insmod /lib/modules/2.4.22-10mdk/misc/ndiswrapper.o failed
modprobe: insmod ndiswrapper failed
Cannot find minor for kernel module. Module loaded?

So, obviously ndiswrapper.o was compiled with the wrong kernel, but how do I compile it with the correct one? ...also, why do I have two kernel sources at all: shouldn't there be just one?



beyer42 04-06-2004 05:46 PM

If the kernel version is pre-existing (2.4.2-10mdk) when you build a kernel generally the kernel will by default have "custom" tagged onto the end.
If you build a kernel whose version number does not already exist then the "custom" will generally not be attached on the end of the version.

Should recompile ndiswrapper while booted up in 2.4.22-28mdkcustom kernel.

Hope this helps.

Ian 04-07-2004 12:53 PM


Thanks for the tips...I ended up upgrading from ndiswrapper version 4 to version 6 and the installation went fine.

However, now I am having another problem with wlan0 due to the upgrade, but since this is a new problem, I think I'm supposed to start a new thread...


All times are GMT -5. The time now is 03:42 PM.