-   Linux - Wireless Networking (
-   -   Mandrake can't detect my wireless device (

joshknape 08-29-2005 12:10 AM

Mandrake can't detect my wireless device
I tried to install my Linksys USB wireless adapter; but according to the system log, not only did Ndiswrapper fail to load, but Mandrake didn't even detect it. It detected eth0, my Ethernet adapter, but there was no eth1 (should have been the wireless adapter). I also installed my other wireless device, a PCI card (I have it because I'm going to switch over), but it wasn't detected either. It has to be a problem with Mandrake and not the devices, because my other distributions (Xandros, Knoppix) found them. The Mandrake version is 10.1. And the reason I'm posting here is because nobody in Mandrake knew anything about it.

jonlake 08-30-2005 03:59 PM

Do an lspci (for the pci card) and an lsusb (for the usb adapter). Lets make sure they are being recognized there. If they are, and since you are using ndiswrapper, you will need to ndiswrapper -i driver.inf. Then do ndiswrapper -l to see what drivers are installed in ndiswrapper, then modprobe ndiswrapper. Let us know how far you can get with these steps and please post your output to the commands.

joshknape 08-31-2005 12:02 AM

The commands you specified work up through modprobe ndiswrapper, but when I type dmesg, the part of the system log which appears to be relevant (I can print all of it on request) says:

eth0: no IPv6 routers present
cdrom: hdc: mmc-3 profile capable, current profile: 8h
cdrom: hdc: mmc-3 profile capable, current profile: 8h
ISO 9660 Extensions: Microsoft Joliet Level 3
ISOFS: changing to secondary root
ndiswrapper version 0.8 loaded
ndiswrapper: loadndiswrapper failed (256)
VFS: busy inodes on changed media.
VFS: Can't find ext2 filesystem on dev fd0.
usb 1-1: USB disconnect, address 2
usb 1-1: new full speed USB device using address 3

Note that it's not even detecting my wireless device at eth1.

oobnuker 08-31-2005 08:08 AM

I think what jonlake is looking for is the PCI ID of the Wireless card as returned by lspci. It will look something like: 0000:0203 or something to that effect and should cleary say something related to being a wifi card. This is needed to identify which piece of hardware ndiswrapper is supposed to work with.

joshknape 08-31-2005 01:25 PM

Oh, I already have the device's (USB) ID memorized; it is 1915:2234.

jonlake 09-01-2005 12:07 PM

Why don't you try an updated version of ndiswrapper? Make sure you uninstall the old version first.

joshknape 09-02-2005 07:02 PM

If the version is wrong, it seems to be beyond my control. I have installed the RPM of Ndiswrapper 1.2, the most current version I can find. (I have also tried the .src file.) I installed it, but at some point, I saw an indication that my Mandrake was *still* running 0.8 even though I had typed "urpme ndiswrapper" to remove 0.8 before installing 1.2. If I recall, I noticed it after typing "whereis ndiswrapper": some of the files or directories, I forget which, had 0.8 in their name.

jonlake 09-03-2005 12:58 AM

You will defenitely make sure you want to be using the updated version of ndiswrapper. Why don't you try to uninstall both versions and then start over, making sure you use the current one.

joshknape 09-04-2005 03:10 PM

Well, I urpme'd whatever version I had so that there was nothing there, and then installed the Ndiswrapper 1.2 RPM that I just downloaded. I installed my wireless driver, and modprobe'd ndiswrapper. I looked at the system log, and it reported Ndiswrapper version 0.8 working; so I give up. Don't ask me why a 1.2 RPM installs version 0.8.

jonlake 09-07-2005 11:08 AM

After uninstalling, do
# updatedb
# locate ndiswrapper
and see if it is in fact still there. I would also compile from source rather than using rpm.

All times are GMT -5. The time now is 05:31 AM.