LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 01-05-2005, 03:26 PM   #16
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware
Posts: 1,876

Rep: Reputation: 49

No, and it's dangerous - especially if you're new to Linux.

I suggest you start a new thread with details: errors, logs, symptoms, how you're connecting and with what applications.
 
Old 01-12-2005, 07:59 PM   #17
flystar06
LQ Newbie
 
Registered: Apr 2004
Location: Tennessee
Distribution: SimplyMEPIS3.3.1
Posts: 20

Original Poster
Rep: Reputation: 0
i tried to figure out where the files i need are so i can build it from the source, but i can't find files for my kernel version...and i can't follow the man pages on the site...i know NOTHING about how to do that...never ever done it before...help
 
Old 01-13-2005, 12:22 PM   #18
Hockeyfan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 154

Rep: Reputation: 30
Cool

I suggest downloading the files through cvs. When the files are downloaded through cvs all the files that are needed are put into a directory called "madwifi". I suggest that you be logged in as root when you get the driver from cvs. To get the driver from CVS open a terminal window and type this:

cvs -z3 -dserver:anonymous@cvs.sourceforge.net:/cvsroot/madwifi co madwifi

After getting the driver, make sure you have the sharutils rpm installed. You will need that to compile the driver.

Nopw compile the driver. In order to compile the driver go into the top level of the madwifi directory and type make. During the make process you might see a bunch of undefined warnings. Ignore them. After this completes and assuming you don't see a message that says error, type make install

Once the driver is installed type modprobe ath_pci . This will start the driver and give you a new network connection. To make sure that your wireless card is working type iwconfig ath0.

Tell me if you get this far with the madwifi driver. Before I go on to tell you how to configure the card, I want to make sure that the driver works.

Hockeyfan
 
Old 01-13-2005, 11:38 PM   #19
DirtyDan
Member
 
Registered: Aug 2004
Posts: 41

Rep: Reputation: 15
I have the driver working, and my router even has the PCMCIA card's MAC adress recognized, but it wont connect to the network/internet or anything, so I havnt configured the card right yet. Ah!
 
Old 01-14-2005, 12:08 PM   #20
Hockeyfan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 154

Rep: Reputation: 30
Ok here are the commands to get the network card working

Do these as root.

ifconfig ath0 up

iwconfig ath0 key yournetworkkeyhere
iwlist ath0 scan (this will list all access points in your broadcast area. If you can see your access point your card works.)
iwconfig ath0 ap yourapaddresshere
iwconfig ath0 channel yourbroadcastchannelhere
iwconfig ath0 essid yourssidnamehere
iwpriv ath0 authmode 2 (use this if you have a network key)

now here is what I am unsure of. This depends on your distribution. If you have Fedora/Redhat execute
dhclient ath0

if you have any other execute
dhcpcd ath0

if you tell me which distribution you are using I can show you a configuration file that willl start the network card up on boot.

By the way I got the commands from the netgear WG311 HCL entry

Hockeyfan
 
Old 01-14-2005, 10:16 PM   #21
DirtyDan
Member
 
Registered: Aug 2004
Posts: 41

Rep: Reputation: 15
It never is able to find the AP on "ifconfig ath0 up", but my AP sees my card. Its um... Out of control
 
Old 01-14-2005, 10:33 PM   #22
Hockeyfan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 154

Rep: Reputation: 30
have you started the driver? If not, at the command prompt type modprobe ath_pci. Also, you should try iwconfig. iwconfig will show all network connections whether they are wireless or not.
 
Old 01-14-2005, 11:31 PM   #23
DirtyDan
Member
 
Registered: Aug 2004
Posts: 41

Rep: Reputation: 15
On iwconfig I get ;
Code:
lo: (Stuff, if its important I will post)

ath0:

IEEE 802.11b ESSID:"wireless"
Mode:Managed Frequency:2437GHz Access Poin: 00:0C:41:D@:DB:07
Bit Rate:11Mb/s Tx-Power: 50 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr: off
Encryption key: off
Power Management:off
Link Quality:42/94 Signal level:-53dBm Noise Level:-95dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed Beacon:0
On ifconfig:
Code:
Link encap:Ethernet HWaddr 00:20:A6:4C:17:04
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 63 errors:13 dropped:0 overruns:0 frame:13
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txquelen:199
RX bytes:9.4Kb TX bytes: 0.0b
Interrupt:11 Memory:c70c0000-c70d0000
And finally iwlist ath0 scan
Code:
ath0 Failed to read scan data : Resource temporarily unavailable
The lights on my card (Orinoco 8460-05 (168c:0012)) Blink indicating an AP cannot be found, with both on once every 10 seconds after a scan in which they alternate.

(**ahh, there it is, I knew I had seen it somewhere...**)

Pss. Im in slackware


Wha!!!?!?!?!?! Its working, I just ran a ping. So the cards lights are freaking out, but um... Hey, who cares?

Thank you so much. I very well might have had internet for the past 3 days, but I just today ran #dhcpcd ath0 and damnit!

Last edited by DirtyDan; 01-15-2005 at 02:05 AM.
 
Old 01-15-2005, 12:42 AM   #24
Hockeyfan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 154

Rep: Reputation: 30
I just searchered the madwifi mailling list on sourceforge's madwifi website. Someone had the same problem you did. The answer they gave was to upgrade to the latest wireless tool pre-release. Try that Hopefully that works. If not try adding all of your network configuration without doing the iwlist scan. Iwlist may be the only problem

Also there is a checkbox below the reply textbox to disable smiles in your post
 
Old 01-15-2005, 02:06 AM   #25
DirtyDan
Member
 
Registered: Aug 2004
Posts: 41

Rep: Reputation: 15
Im reinstalling linux right now and scaling down to Vector linux, (hopefully no moduleutils vs. module-init-tools conflicts this time...) But then I will try upgrading. Thanks for the tip!
 
Old 01-16-2005, 03:32 AM   #26
DirtyDan
Member
 
Registered: Aug 2004
Posts: 41

Rep: Reputation: 15
Everything is working great, but I had another question about speed. I am able to ping websites as fast or faster than my wired pc's on the newtork. But, while connecting to the internet, downloading is considerably slower. While a wired pc downloads at 400kb/s, the wireless one downloads at 6Kb/s. I know wireless has its limits, but I have seen 100-200kb/s on this same pc with the same Wi-Fi card in linux. Is it a driver conflict, or is there something I can do about it?
 
Old 01-30-2005, 03:59 AM   #27
rathel
LQ Newbie
 
Registered: Jan 2005
Posts: 6

Rep: Reputation: 0
i'm having some problems with connect dhcp
iwconfig:
ath0 IEEE 802.11g ESSID:"admin_net" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.437GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:1Mb/s Tx-Power:50 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:****-****-** Security mode:restricted
Power Management:off
Link Quality=45/94 Signal level=-50 dBm Noise level=-95 dBm
Rx invalid nwid:376 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
ifconfig:
ath0 Link encap:Ethernet HWaddr 00:0E:9B:24:6E:B6
inet6 addr: fe80::20e:9bff:fe24:6eb6/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:131 errors:325 dropped:0 overruns:0 frame:325
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:40778 (39.8 KiB) TX bytes:2160 (2.1 KiB)
Interrupt:11 Memory:1ebc0000-1ebd0000
dhclient:
I get this at the end of it
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

how do i fix this?

nevermind my security settings was wrong

Last edited by rathel; 01-30-2005 at 04:38 AM.
 
Old 02-07-2005, 10:24 PM   #28
flystar06
LQ Newbie
 
Registered: Apr 2004
Location: Tennessee
Distribution: SimplyMEPIS3.3.1
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by drj000
Go here: http://atrpms.net/dist/fc3/madwifi/
After where it says kernel-module-madwifi- find the one that matches your kernel. If you keep your kernel uptodate, you should be using 2.6.9-1.681_FC3, so get kernel-module-madwifi-2.6.9-1.681_FC3-0.9.4.11-12.rhfc3.at.i686.rpm
Install it using the rpm command rpm -Uvh foo.rpm, while logged in as root.
There's a couple more steps that I had to do, you'll probably have to do them too.
Add "alias ath0 ath_pci" to your /etc/modprobe.conf file
Then create a file /etc/sysconfig/network-scripts/ifcfg-ath0. It should contain info something like this:
STARTMODE=onboot
DEVICE=ath0
BOOTPROTO=dhcp
WIRELESS=yes
MODE=Managed
ESSID=your-essid
CHANNEL=your-channel
KEY=your-key-here-if-you-use-encryption or off
This will of course, depend on your configuration. Finally ifconfig ath0 up, to see if it's working.
Also, next time you reboot, it'll detect some new hardware: Ahteros something-or-other. Just ignore it.

P.S. I learned how to do this from this help: http://www.linuxtested.com/notes/CFG...DWIFI_RH9.html
If your setup is very different from mine, consult that page to see if it can help. It's written for RH9 users, but a lot of it still applies to FC3 users.
I followed your instructions to a T. I thought it might have worked, but I keep getting this error message when trying to activate ath0 "ath_pci device ath0 does not seem to be present, delaying initialization." In the network configuration app under the hardware tab, is shows the Atheros Comm. but for type it says unknown. I don't know why more I can do. I have the 2.6.9-1.724 kernel. Any ideas? this is very frustrating and getting very tiresome.
 
Old 02-07-2005, 11:01 PM   #29
Hockeyfan
Member
 
Registered: May 2004
Distribution: SuSe 10.0
Posts: 154

Rep: Reputation: 30
try adding IWPRIV="authmode 2" to your ifcfg-ath0 file. That may be the problem. I had problems with gainning access to my router without it.

Try that

Hockeyfan
 
Old 02-08-2005, 04:27 PM   #30
flystar06
LQ Newbie
 
Registered: Apr 2004
Location: Tennessee
Distribution: SimplyMEPIS3.3.1
Posts: 20

Original Poster
Rep: Reputation: 0
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0... failed.


this is the error i get when i try to activate ath0...i've update the kernel to 760, and the madwifi drivers. it now looks for an IP address, and it actually knows the MAC address (didn't before). I'm getting real tired of these error messages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MadWiFi klmbrt Linux - Wireless Networking 6 03-18-2005 12:49 PM
Madwifi sc30317 Linux - Wireless Networking 2 10-27-2004 07:01 PM
Can someone email me "madwifi-2.6.8_and_-mm-040821.patch.bz2"? (madwifi 2.6.8 patch) 95se Linux - Wireless Networking 0 09-01-2004 10:34 AM
Madwifi Help FXRS Linux - Wireless Networking 11 06-15-2004 08:15 AM
MADWifi k1ng Linux - Hardware 0 05-25-2004 08:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 07:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration