LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 02-08-2006, 10:19 PM   #16
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15

Code:
lo        no wireless extensions.

sit0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"ESSIDHERE"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:09:5B:F8:85:23
          Bit Rate:54 Mb/s   Tx-Power:15 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=29/94  Signal level=-66 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
That was from typing iwconfig.

I'm not so sure about my Linux firewall settings.
 
Old 02-09-2006, 02:33 AM   #17
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & Linux Mint
Posts: 488

Rep: Reputation: 31
OK, that certainly looks like a good connection to me. You can enable/disable the firewall in YaST. And are you now still getting the same errors for "dhcpcd ath0" or "ifup ath0"?
 
Old 02-09-2006, 04:10 AM   #18
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
Well, this is what I got when I typed "ifup ath0"

Code:
    ath0      device: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
    ath0      configuration: wlan-id-00:09:5b:eb:b2:23
    ath0      warning: wpa_supplicant already running on interface
DHCP client is already running on ath0

Typing "ifstatus ath0" came up with:

Code:
5: ath0: <BROADCAST,MULTICAST,NOTRAILERS,UP> mtu 1500 qdisc noqueue
    link/ether 00:09:5b:eb:b2:23 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::209:5bff:feeb:b223/64 scope link
       valid_lft forever preferred_lft forever
wpa_state=SCANNING
Supplicant PAE state=DISCONNECTED
suppPortStatus=Unauthorized
EAP state=DISABLED
My firewall was turned off, and nothing changed. My device is set to "External Zone".

Last edited by Cb6000; 02-09-2006 at 04:12 AM.
 
Old 02-09-2006, 05:03 AM   #19
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & Linux Mint
Posts: 488

Rep: Reputation: 31
Quote:
Originally Posted by Cb6000
Well, this is what I got when I typed "ifup ath0"

Code:
    ath0      device: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
    ath0      configuration: wlan-id-00:09:5b:eb:b2:23
    ath0      warning: wpa_supplicant already running on interface
DHCP client is already running on ath0
And what happens when you try "ifdown ath0" and then "ifup ath0"?
 
Old 02-09-2006, 11:46 PM   #20
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
ifdown ath0

Code:
    ath0      device: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
    ath0      configuration: wlan-id-00:09:5b:eb:b2:23
ifup ath0

Code:
    ath0      device: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
    ath0      configuration: wlan-id-00:09:5b:eb:b2:23
    ath0      starting wpa_supplicant
Starting DHCP Client Daemon on ath0... . . . . . no IP address yet...backgrounding.
Could something be wrong with the wpa_supplicant?
 
Old 02-10-2006, 05:24 AM   #21
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & Linux Mint
Posts: 488

Rep: Reputation: 31
That is possible. To make sure, the following commands I think should let you connect to your AP without using wpa_supplicant:
Code:
# ifdown ath0 
# ifconfig ath0 up
# iwconfig ath0 essid <your_ssid> key off
Now again check that you have indeed connected to your AP, it should be no problem assuming that you have turned off encryption on the app first. Check to see if wpa_supplicant was indeed halted with "ps x | grep wpa_supplicant" (it shouldn't be listed in the output).
Then try "dhclient ath0" and if this now works, we know wpa_supplicant is the problem.
 
Old 02-13-2006, 01:08 AM   #22
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
It actually worked, even though I had to mess with the YaST2 stuff!! It does appear that the wpa_supplicant may be the culprit. What next?
 
Old 02-13-2006, 06:52 PM   #23
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
All right, can someone tell me how to get wpa_supplicant compiled, etc. using WPA-PSK? I may not have used the right tutorial.
 
Old 02-14-2006, 06:19 AM   #24
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & Linux Mint
Posts: 488

Rep: Reputation: 31
Updating is not a bad idea, just as long as you are not updating to the same version or anything. But I'm guessing you checked with "wpa_supplicant -v". I also assume you have a working gcc compiler installed, make, etc. You also need to have the sources of the madwifi driver you are using. Next go into the root directory of your wpa_supplicant sources. You need to create a .config file that will be used by make to compile the program for your system. The sources include a text file called "defconfig", which indeed means "default configuration", so you execute "cp defconfig .config".
Next you open the new .config file in a text editor and begin enabling options that are pertinent to your environment. If you are not sure whether you need something, first read the README. Then if you are still in doubt, try saying "y" to it. Remember that if you think you probably don't need an option, don't say "n", just comment it out.
The most important part is this:
Code:
# Driver interface for madwifi driver
CONFIG_DRIVER_MADWIFI=y
# Change include directories to match with the local setup
CFLAGS += -I/usr/src/madwifi-old
Make sure all other wireless drivers are commented out, because you either don't need them or don't have their sources anyway.
The CFLAGS line may be different for you, change it if necessary like this "CFLAGS += -I</your/path/to/madwifi-src>"
Save the file, then execute "make". If it fails with errors, you probably need to tweak .config a little more. If it compiles cleanly, first remove the old wpa_supplicant (I am guessing this should be done from within YaST) and then execute "make install" (or copy the binaries manually to any location you prefer). See also the install section of the README.
Hope that helps.

Last edited by JunctaJuvant; 02-15-2006 at 05:28 AM.
 
Old 02-15-2006, 03:14 AM   #25
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
Why do I get a message of...

Code:
ifup-wireless: cannot find 'awk', please install
...when typing 'ifup ath0'?

I never had that error before.
 
Old 02-15-2006, 05:24 AM   #26
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & Linux Mint
Posts: 488

Rep: Reputation: 31
That means 'awk' was somehow uninstalled, and you need to install it again. Perhaps it got uninstalled by YaST for some unfathomable reason, I really don't know. It would help, when you post these errors, to know exactly what changes you have made to your system right up to the point when you received the error. Have you tried (re)installing awk?
 
Old 02-15-2006, 07:45 AM   #27
Mr_C
Member
 
Registered: Jan 2004
Location: Trinidad & Tobago
Distribution: Slackware
Posts: 317

Rep: Reputation: 30
Quote:
Gawk is the GNU Project's implementation of the AWK programming language. It conforms to the definition of the language in the POSIX 1003.2 Command Language And Utilities Standard.
Well thats what it does..
 
Old 02-15-2006, 03:30 PM   #28
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
When visiting the YaST, it does show that gawk is still installed. The last thing I did was uninstall wpa_supplicant from YaST.

Would typing in this cause the issue?

Code:
ps x | grep wpa_supplicant
 
Old 02-15-2006, 04:39 PM   #29
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & Linux Mint
Posts: 488

Rep: Reputation: 31
No, that just pipes the output of "ps x" to the "grep" command, which is just a convenient method of isolating wpa_supplicant from the other running processes. I think this is a pretty weird error if you ask me. I'm afraid I don't use SuSE very much these days. Are you sure YaST did not prompt you in any way to remove the dependencies as well? If not, try re-installing wpa_supplicant again in YaST to see if that corrects this dependency error. You could then just try replacing the wpa_supplicant binaries with the ones you compiled yourself. Hope that works.
 
Old 02-16-2006, 03:14 AM   #30
Cb6000
LQ Newbie
 
Registered: Feb 2006
Distribution: OpenSUSE 10.0
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by JunctaJuvant
No, that just pipes the output of "ps x" to the "grep" command, which is just a convenient method of isolating wpa_supplicant from the other running processes. I think this is a pretty weird error if you ask me. I'm afraid I don't use SuSE very much these days. Are you sure YaST did not prompt you in any way to remove the dependencies as well? If not, try re-installing wpa_supplicant again in YaST to see if that corrects this dependency error. You could then just try replacing the wpa_supplicant binaries with the ones you compiled yourself. Hope that works.
Yeah, re-installing wpa_supplicant (which I believe is installled on "/usr/sbin/") from the OpenSuSE CD did eliminate the awk error. I had a feeling that removing the supplicant from YaST was the reason of the 'awk' error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear WG311T, MadWiFi installation woes on OpenSuSE 10.0 Cb6000 Linux - Networking 3 02-02-2006 04:48 PM
MadWiFi for WG311T - RedHat 9 eSsence Linux - Wireless Networking 0 09-17-2005 06:58 PM
WG311T and Madwifi j_70 Linux - Wireless Networking 1 08-15-2005 08:17 AM
WG311T - Installing madwifi drivers - warning messages?? LChalupa Linux - Wireless Networking 1 04-08-2005 10:30 AM
SuSE and Netgear WG311T stan03 Linux - Hardware 1 05-14-2004 12:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration