-   Linux - Wireless Networking (
-   -   Madwifi ad-hoc mode wuth Atheros Chipset (

mkirc 04-29-2006 11:20 AM

Madwifi ad-hoc mode wuth Atheros Chipset
I have a HP Pavillion with Wlan:

After installing Madwifi according description, it seems to work:

hwinfo --netcards
Model: "Lite-On WLAN controller"
Vendor: pci 0x168c "Atheros Communications, Inc."
Device: pci 0x001b
SubVendor: pci 0x11ad "Lite-On Communications Inc"
SubDevice: pci 0x5000
Revision: 0x01
Driver: "ath_pci"
Device File: wifi0
Device Files: wifi0, wlan0
Features: WLAN
Memory Range: 0xbffe0000-0xbffeffff (rw,non-prefetchable)
IRQ: 50 (8104638 events)
HW Address: 00:02:e3:46:c5:7e
Module Alias: "pci:v0000168Cd0000001Bsv000011ADsd00005000bc02sc00i00"
Driver Info #0:
Driver Status: ath_pci is active
Driver Activation Cmd: "modprobe ath_pci"

BUT: I cannot switch the card into ad-hoc or monitor mode:
darkstar:/data/ftp # iwconfig
wlan0 IEEE 802.11Ta ESSID:"wl2004"
Mode:Managed Frequency:5.76 GHz Access Point: 00:00:00:00:00:00
Bit Rate:0 kb/s Tx-Power:13 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:140044 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

---> Here is the problem
darkstar:/data/ftp # iwconfig wlan0 mode ad-hoc
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.

Same effect when I try to switch to monitor mode ?

Any help is most apprectiated, I spent several hours , but now I'm sticking !

mkirc 04-29-2006 11:28 AM

Additional Info:
Sorry, I forgot to mention: I run Suse 10.0, latest madwifi, and installed the nongpl-kernel in addition. This worken on my other computer with WG511T quite well ?

mkirc 04-30-2006 08:15 AM

Found solution !
Why did no one respond ?

Was the issue that clear or that complicated ?

Anyway: With wlanconfig it worked to switch the card into monitor mode !

What surprises me, is that there are afa. 3 ways to switch a Wifi-device into Monitor mode:

-iwconfig (comes with aircrack)

It depends on the chipset which one works and which one doesn't ?

Is this really the way to make Linux more successful against Windows ?

okok: Windows is not supported by Aircrack anyway !

Crito 04-30-2006 08:28 AM

You probably would have gotten a better response in the SuSE forum. In fact, since you're using SuSE, my first instinct would have been to open up YaST and try to configure it there. Most distros come with their own network config tools. Here's Red Hat's, for example, showing dialog when I can simply pick the wifi card's mode from a drop-down list-box:

mkirc 04-30-2006 08:56 AM

suse10 wlan atheros
thanks for reply !

My first attempt was Yast to configure the Wlan.
But Yst recognized an Ethernet Device and stated that there is no driver.....

So I made my way via ndiswrapper and madwifi, which took me several hours.

Now it works, but wifi support under Linux deserves definitevely improvement !


Crito 04-30-2006 09:20 AM

Well, the problem is madwifi and (obviously) any Windows drivers installed via ndiswrapper are not GPLed. In fact, if you had bought the commercial version madwifi would have worked out of the box. My retail copy of SuSE 9.3 detected my atheros chipset wifi card, installed the madwifi driver and configured the card all automagically. It's only the Free Software (download) version that doesn't.

Unfortunately, in the case of FC5, there is no "commercial" version anymore so it's always like pulling teeth. ;)

mkirc 05-01-2006 05:04 AM

Atheros & Suse 10
Hi Crito !

I used a commercial copy of Suse 10.0 !
Bought it at a bookstore regularely ?

My Atheros-PCMCIA Card WG511T was supported neither.
I had to install the nongpl-kernel update ?

Anyway, Merci for your explanations !

All times are GMT -5. The time now is 04:03 AM.