LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 02-15-2006, 11:56 AM   #1
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 135

Rep: Reputation: 17
Lost with ipw2200 & wpa


I know this has been posted before (I searched), but there wasn't a real clear answer as to how to resolve the problem of getting wpa_supplicant to work with an Intel ipw2200 in a Dell Inspiron 9300 running Slackware 10.1 (with a custom 2.6.15.2 kernel).

I've read through so many different howtos and walkthroughs online that I'm sure I've looked at them all at least 5 times. I've in particular followed this walkthrough:
http://www.linuxquestions.org/linux/...2200_Slackware

Everything has compiled successfully, and I've configured my /etc/wpa_supplicant.conf file according to the output provided by wpa_passphrase:

network = {
ssid="PheonixNet"
psk=mypassphrasefrombywpa_passphrase
}

I *have* tried adding other items to this definition as well (can't remember them off the top of my head - don't have the laptop in front of me), but they don't seem to do anything either.

I *can* connect to an 'insecure' connection from a neighbor easily, and I can *se* my AP using iwlist, but wpa_supplicant results in the following output:

Code:
                                                                     
                                                                     
                                                                     
                                             
Initializing interface 'eth0' conf '/etc/wpa_supplicant.conf' driver 'ipw' ctrl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
Line: 16 - start of a new network block
ssid - hexdump_ascii(len=10):
     50 68 65 6f 6e 69 78 4e 65 74                     PheonixNet
PSK - hexdump(len=32): [REMOVED]
Priority group 0
   id=0 ssid='PheonixNet'
Initializing interface (2) 'eth0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ipw_init is called
SIOCGIWRANGE: WE(compiled)=19 WE(source)=16 enc_capa=0x0
  capabilities: key_mgmt 0x0 enc 0x3
Own MAC address: 00:12:f0:29:7a:84
wpa_driver_ipw_set_wpa: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_drop_unencrypted: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Setting scan request: 0 sec 100000 usec
Added interface eth0
Wireless event: cmd=0x8b06 len=8
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
RTM_NEWLINK, IFLA_IFNAME: Interface 'eth0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 1162 bytes of scan results (6 BSSes)
Scan results: 6
Selecting BSS from priority group 0
0: 00:12:17:c6:41:c1 ssid='PheonixNet' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   selected based on WPA IE
Trying to associate with 00:12:17:c6:41:c1 (SSID='PheonixNet' freq=0 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
wpa_driver_ipw_set_auth_alg: auth_alg=0x1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: set AP WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
WPA: clearing AP RSN IE
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_ipw_set_drop_unencrypted: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
State: SCANNING -> ASSOCIATING
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=19


Authentication with 00:00:00:00:00:00 timed out.
Added BSSID 00:00:00:00:00:00 into blacklist
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 0 usec
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Scan timeout - try to get results
Received 937 bytes of scan results (5 BSSes)
Scan results: 5
Selecting BSS from priority group 0
0: 00:12:17:c6:41:c1 ssid='PheonixNet' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
   selected based on WPA IE
Trying to associate with 00:12:17:c6:41:c1 (SSID='PheonixNet' freq=0 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
wpa_driver_ipw_set_auth_alg: auth_alg=0x1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
WPA: set AP WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
WPA: clearing AP RSN IE
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
wpa_driver_ipw_set_drop_unencrypted: enabled=1
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
State: SCANNING -> ASSOCIATING
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Wireless event: cmd=0x8b1a len=19


CTRL-EVENT-TERMINATING - signal 2 received
Removing interface eth0
State: ASSOCIATING -> DISCONNECTED
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
wpa_driver_ipw_set_wpa: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_drop_unencrypted: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
wpa_driver_ipw_set_countermeasures: enabled=0
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
No keys have been configured - skip key clearing
Removed BSSID 00:00:00:00:00:00 from blacklist (clear)
Cancelling scan request
... when I run the comamnd:

wpa_supplicant -i eth0 -c /etc/wpa_supplicant.conf -D ipw -d

Oddly enough, my wifi shows up as eth0, but if I have a cable connected to my ethernet port, it shows up as eth1.

I imagine it has to do with the following:

ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.

I'm at a total loss as to what to try next. I have all the encryption methods compiled as modules from the kernel, but none of them seem to ever get loaded. I have tried manually loading them with modprobe, but to no avail.

Any thoughts?

Thanks,

- skubik.
 
Old 02-15-2006, 02:35 PM   #2
metabaron
LQ Newbie
 
Registered: Feb 2006
Posts: 11

Rep: Reputation: 0
From 2.6.14 kernel, wpa_supplicant driver to use is no more ipw but wext so use
wpa_supplicant -D wext, not wpa_supplicant -D ipw

http://www.ubuntuforums.org/showthread.php?t=102447

Last edited by metabaron; 02-15-2006 at 02:41 PM.
 
Old 02-16-2006, 09:58 AM   #3
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 135

Original Poster
Rep: Reputation: 17
Soooooo close. I can now use wpa_supplicant to *connect* to my AP, but when I try to access anything (www, ssh, etc) it doesn't connect at all. ssh specifically said something about the network being down or disabled.
When I look at the iwconfig output, all looks good, but the security mode is set to 'open', and during the last few weeks of reading and tinkering I'm sure I read somewhere that this should be set to 'restricted' instead.
I know I've seen this posted somewhere before, so I'll have to start searching for it today. If anyone knows how to remedy this, or know where a solution might be posted, please post.

Thanks,

- skubik
 
Old 02-17-2006, 02:05 AM   #4
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 135

Original Poster
Rep: Reputation: 17
Followup

Followup: I have been able to successfully connect to and *use* my AP using wpa_supplicant using the following steps:

ifconfig eth0 down
wpa_supplicant -Dwext -ieth0 -c/etc/wpa_supplicant.conf
ifconfig eth0 up
dhcpcd eth0 -n

However, wpa_supplicant only seems to want to properly work when run from within a console (vterm, konsole, whatever). Using the -B flag, or even an & to force the command into the background doesn't want to load the config file. I've checked this by looking at the contents of 'iwconfig' after I've started wpa_supplicant. Specifically, when run as a daemon, the Encryption Key value is not set (is set to off), yet is clearly defined in wpa_supplicant.conf. It does, however, properly set the essid.
Any ideas as to why this might be happening?


Also, I've noticed that sometimes when I attempt to run wpa_supplicant from the console, sometimes the following output is displayed:

Trying to associate with SSID 'PheonixNet'
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys

... and then nothing else, at which time I break out (ctrl+c) and run it immediately again. This time it works just fine. Am I missing something here?


I've also noticed that sometimes when wpa_supplicant *is* running, dhcpcd eth0 -n will sit there and do nothing for a while. I've only ever let it go a minute before breaking out of it, so I'm not sure if it would eventually refresh the ip address or not. Any ideas why this happens?

Any help would be greatly appreciated.

Thank you,

- skubik.
 
Old 02-20-2006, 08:33 PM   #5
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 135

Original Poster
Rep: Reputation: 17
Followup 2

For the sake of documentation, I'll post my recent discoveries in using wpa_supplicant in hopes that someone might have a solution for the final push over the finish line.

Turns out I had compiled wpa_supplicant WITHOUT CTRL_IFACE support. So my first order of business was to edit my .config file and add the line 'CONFIG_CTRL_IFACE=y' to the top of the file, 'make clean', 'make' and 'make install'. Edit my /etc/wpa_supplicant.conf file to uncomment the line 'ctrl_interface=/var/run/wpa_supplicant'.
NOW, 'wpa_supplicant -Dwext -ieth0 -c/etc/wpa_supplicant.conf -Bw' works just fine, and I can use wpa_cli to check the status and reassociate with a defined network.

So everything seems to be working from the wpa_supplicant-front, but now the problem has been in obtaining an IP address from the DHCP server on my router (Linksys WRT52GP2). Obtaining any kind of connection has been VERY shotty and even more random.
'ifconfig' displays the local HWaddr properly, and sometimes even states an IP address (when ipw2200 is loaded, it somehow automatically connects to an insecure AP somewhere around my apartment - this is how I'm connected now). 'iwconfig' shows the correct essid, encryptmodprobe ipw2200 hwcrypto=0 led=1ion key, and indicates the use of IEEE 802.11g.
However, 'dhcpcd eth0 -n' just sits there and timesout, but not always, and I can't seem to figure out the conditions under which it succeeds, or whether there even is one. Once it times-out, the eth0 entry in ifconfig ceases to exist, iwconfig still shows up properly.

I tried to ping the router itself (192.168.15.1), but results in a 'connect: Network is unreachable' error. During my travels online I came across a posting describing the dhcpcd issue, and stated that loading ipw2200 with the option 'hwcrypto=0' tends to fix this problem, unfortunately it hasn't seemed to work for me.

Does anyone have any other suggestions how to get dhcpcd working consistently when using wpa_supplicant???

Thanks,

- skubik.

[PS: I've also found that when I initially invoke wpa_supplicant as a daemon, 'wpa_cli status' results in:
> status
bssid=xx:xx:xx:xx:xx:xx
ssid=PheonixNet
pairwise_cipher=TKIP
group_cipher=TKIP
key_mgmt=WPA-PSK
wpa_state=COMPLETED

But that doesn't change anything with dhcpcd. However, if I 'disconnect' and 'reassociate', it will usually get to the 'ASSOCIATED' status, but has difficulty getting to 'COMPLETED'. Just FYI.]

Last edited by skubik; 02-20-2006 at 09:51 PM.
 
Old 02-23-2006, 10:14 AM   #6
skubik
Member
 
Registered: May 2003
Location: A dark corner in Canada
Distribution: Slackware 13.37 / Slackware64 14.x
Posts: 135

Original Poster
Rep: Reputation: 17
Giving Up... for now

Haven't had any further success with getting dhcpcd to work consistently, and no followups/suggestions on this thread have bene posted. At this point my frustration level in getting this to work doesn't justify the effort anymore.
If anyone has had any success getting dhcpcd to work consistently with wpa_supplicant under Slack 10.1 (custom 2.6.15.2 kernel) on a ipw2200 chipset (Dell Inspiron 9300), please post your results. I will continue to periodically attempt to fiddle with it, and will post my results when/if I ever figure it out.
 
Old 02-24-2006, 07:02 AM   #7
metabaron
LQ Newbie
 
Registered: Feb 2006
Posts: 11

Rep: Reputation: 0
I do no use dhcpcd but dhclient. I neither set up it manually, just using the w-e script:

#cat /etc/sysconfig/network-scripts/ifcfg-ethX:
DEVICE=ethX
BOOTPROTO=dhcp
ONBOOT=yes
METRIC=15
MII_NOT_SUPPORTED=no
USERCTL=yes
WIRELESS_MODE=Secondary
WIRELESS_ESSID=xxx
WIRELESS_WPA_DRIVER=wext
DHCP_CLIENT=dhclient
NEEDHOSTNAME=yes
PEERDNS=yes
PEERYP=no
PEERNTPD=no


and up it with
# ifup ethX
with no pb

Security is set via wpa_supplicant, not via w-e, that's why encryption key/mode don't appear via iwconfig
#iwconfig ethX

eth2 IEEE 802.11g ESSID:"xxx" Nickname:"nick"
Mode:Managed Frequency:2.472 GHz Access Point: 00:xx:xx:x
Bit Rate=36 Mb/s Tx-Power=20 dBm
Retry limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality=86/100 Signal level=-39 dBm Noise level=-85 dBm
Rx invalid nwid:0 Rx invalid crypt:1 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


wpa_supplicant config takes precedence over w-e config (like ESSID config):

# cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant

network={
ssid="xxx"
scan_ssid=1
proto=WPA
pairwise=TKIP
key_mgmt=WPA-PSK
psk="...."
}



If wpa_supplicant only start manually you should check the launch script, maybe your wpa files are at wrong place so wpa_supplicant is not called:

# cat /etc/sysconfig/network-scripts/ifup-wireless
...
if [ -n "$WIRELESS_WPA_DRIVER" -a -x /usr/sbin/wpa_supplicant -a -f /etc/wpa_supplicant.conf ]; then
/usr/sbin/wpa_supplicant -B -i ${DEVICE} -c /etc/wpa_supplicant.conf -D ${WIRELESS_WPA_DRIVER}

fi


Hope this help

[Edit]
Maybe you should not try to solve all problems at the same time:
be sure you have a running dhcp/AP by enabling your wireless without encryption,
then if it's OK, make a try with wep enabled (adding WIRELESS_ENC_KEY="..."),
and then enable wpa (adding WIRELESS_WPA_DRIVER=wext).
[/edit]

Last edited by metabaron; 02-24-2006 at 07:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(K)ubuntu: WPA and IPW2200 Intermittent Connection bennettg Linux - Wireless Networking 5 01-31-2006 09:49 AM
wpa-psk, ipw2200 on Fedora Core 4 doesn't work RoyalGala Linux - Wireless Networking 3 01-25-2006 03:35 PM
wpa problems with ipw2200 inhalentbroom Slackware 1 12-04-2005 12:08 PM
WPA-TKIP ipw2200 havelino Linux - Wireless Networking 0 04-24-2005 10:24 AM
WPA & ipw2200 havelino Linux - Wireless Networking 5 03-26-2005 06:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration