LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   load wireless card at reboot(Fedora 4) (https://www.linuxquestions.org/questions/linux-wireless-networking-41/load-wireless-card-at-reboot-fedora-4-a-338240/)

beyondreality 06-28-2005 11:48 PM

load wireless card at reboot(Fedora 4)
 
after using ndiswrapper -m
the fedora 4 can not remember it even after I edit /etc/sysconfig/network-scripts/ifcfg-wlan0

when it boots, got error information
Determine IP address for wlan0: failed no link present. check cable.

but after I log in, using iwconfig and dhclient. everything works fine.

Really got lost here.

Wondering if anyone has the same problems?

Thanks for your help!

Ryand833 06-29-2005 08:42 AM

I followed the same tutorial you did for FC4 (Going into /etc/sysconfig/network-scripts and making that config file), and it did not work for me either.

Instead, I did...

(Assuming you've already installed ndiswrapper, and ndiswrapper -l already lists your network card.)

1) I could not get the dhclient command to work correctly for me, so I downloaded dhcpcd from http://www.phystech.com/download/dhcpcd.html

2) Install it by running ./configure, make, and then make install. It will install in /usr/local/sbin

3) Make a script somewhere (/etc/startwifi), put this in it...

Code:

echo "Starting ndiswrapper..."
modprobe ndiswrapper

echo " -- Setting mode managed"
iwconfig wlan0 mode Managed

echo " -- Setting WEP key"
iwconfig wlan0 key restricted <your key here>

echo " -- Setting Channel"
iwconfig wlan0 channel <your channel>

echo " -- Bringing up wlan0"
ifconfig wlan0 up"

4) chmod it to 755

5) Edit /etc/rc.d/rc.local and add this to the end of it...

Code:

/etc/startwifi
/usr/local/sbin/dhcpcd wlan0

After I did all this stuff, my wifi works great on each reboot.

beyondreality 06-29-2005 08:41 PM

Cool. Got it. But the speed becomes extremely slow
 
That really helps! It does get around that problem.
I edit rc.local and add two lines
/sbin/iwconfig wlan0 key open ***********
/sbin/dhclient wlan0
Now it is loaded at the reboot. But for some reason it is extremely slow.
Buddy, do you have the same problem?

Thanks again!

beyondreality 06-29-2005 09:27 PM

It works fine
 
Sorry. I think my whole system is slowed down for other reasons, since the speed did not increase even after I remove it.
Thanks!

Ryand833 06-29-2005 10:09 PM

Hmm, strange.

But, no I didn't experience any slow-downs when I got mine working. (I'm using my wireless right now, in fact.)

Keep me updated if you find out what the problem is.

beyondreality 07-01-2005 10:06 AM

No problem anymore
 
I didn't experience that anymore. And I don't think there is any difference by loading the Wireless driver at rc.loca or rc.sysinit. But it is still strange why it cannot load the configuration at rc.sysinit from /etc/sysconfig/network. Thanks!


All times are GMT -5. The time now is 11:52 PM.