LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 03-09-2004, 02:39 PM   #1
qmm
LQ Newbie
 
Registered: Feb 2004
Location: Netherlands
Distribution: Debian
Posts: 5

Rep: Reputation: 0
Linux/Windows networking: ping only works one way


Hello everyone,

I've got a bit of a strange problem. I'm trying to get a samba server up and running to be able to share files between a linux and a win XP machine, but I'm having little success.

After doing some of the recommended test in a samba manual I discovered that if I do a ping from the linux machine to the windows machine it fails. However if I ping the other way it succeeds and if I ping the router on the network from the linux machine that also works.
There is not firewall running on the XP machine so that can't be the problem. Can anyone help me please?

Q.

P.S.: I realize I might be on the wrong forum, because the problem might be my windows machine, but I'm near desperate to get this thing going.
P.P.S.: Should the windows machine not still be able to see the sambe shares if it is able to ping the linux machine. Because then there might be another problem altogether.
 
Old 03-09-2004, 03:03 PM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,571

Rep: Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660
The XP system may not see the samba shares even though you can ping in one direction. You have to get the smb.conf file set up correctly tor that to work.

Have you verified the network mask is the same on XP Linux and your router? Are all machines on the same sub-network? For eaxmple, if you are using 192.168.1.x on one machine, make sure the other two are also 192.168.1.x

Have you looked at your linux ethernet configuration with ifconfig? You have to go to the directory as a regular user to run it, or log as SU and it should work. Possibly post the results and we can go from there.
 
Old 03-11-2004, 12:41 PM   #3
qmm
LQ Newbie
 
Registered: Feb 2004
Location: Netherlands
Distribution: Debian
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your reply. I'll try to give as much information as necessary.

My smb.conf file:
# Global parameters
[global]
wins support = Yes

[pub]
path = /home/quint/pub
read only = No
guest ok = Yes
public = yes

I know this is not smart security wise, but it's just for testing. I can connect to the samba server from my Linux machine with smbclient and smbmount.

All machines are on the same sub network and the two machines (XP and Linux) get their IP address through a DHCP request from the router, which is the DHCP server for my network.

ifconfig produces:
eth0 Link encap:Ethernet HWaddr 00:10:4B:C11:74
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1492 Metric:1
RX packets:862573 errors:0 dropped:0 overruns:1 frame:0
TX packets:697594 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1036932923 (988.8 MiB) TX bytes:49535518 (47.2 MiB)
Interrupt:11 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:34118 errors:0 dropped:0 overruns:0 frame:0
TX packets:34118 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13706309 (13.0 MiB) TX bytes:13706309 (13.0 MiB)

The other (XP) machine has gotten ip address 192.168.0.2

Does this give you any ideas?

Cheers,

Quint
 
Old 03-12-2004, 07:07 AM   #4
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,571

Rep: Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660
I don't see any problems with ifocnfig information. Your Linux box is communicating with the outside world going by the transmited and received packets. I'm assuming the XP box is working with the internet as well. If th at is not correct, please advise.

The only thing left I can think of is your router configuration. You may need to look into it to see if there are any MAC filters of IP filters configured there.

The smb.conf file seems very small. For it to work, I believe the global section will need a bit more. I'm going to post mine, it works with security and printing. Things you will need are: workgroup, netbios name, socket options. There may be more, but I would start there. Just a suggestion, I have used Webmin to configure mine and that helped me get going faster. It comes with most of the larger distros.

I'll also include my public section. I have tested it, adn it works. Hope this helps.

[global]
printing = cups
workgroup = cliffshome
wins support = true
netbios name = sluggy
os level = 20
smb passwd file = /etc/samba/smbpasswd
printcap name = cups
guest account = smbuser
dns proxy = no
log file = /var/log/samba/%m
log level = 2
public = yes
max log size = 50
map to guest = bad user
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
encrypt passwords = yes
server string = Samba Server %v
security = user
printer admin = @adm, cliff ,corinne
load printers = yes
printer = lexmark4039

[Public]
comment = public stuff
path = /home/samba/public
public=yes
writable = no
write list = cliff
valid user = cliff , corinne
 
Old 03-23-2004, 05:25 PM   #5
DaDoom
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Too bad this thread doesn't go any further, it pretty much contains what I need.

I have set up a machine with a free dirstribution of Suse 9.0 that I got in a magazine. The second machine runs Win XP. Both are connected to a Router/Switch/DHCP-Server. Internet works on both the the Win XP and the Linux machine.

ifconfig on the Linux machine produces pretty much the same results. What I did on the Linux pc is: go to the control center and under the Network-Browser tab enter a workgroup name (same as on the Win machine) and a user name.

I have no clue what else I need to do. I read somewhere that I must start the samba server on the Linix machine but I havent found out how. Can someone help?
 
Old 03-23-2004, 07:07 PM   #6
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,571

Rep: Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660
DaDoom,

Here is a useful link. You will need to do some reading. This document is very complete. It deals with samba and windows configuration. There is a section on troubleshooting, you may need it after you get the samba server installed, and configured.

http://us1.samba.org/samba/docs/using_samba/toc.html
 
Old 03-24-2004, 04:21 AM   #7
DaDoom
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Talking

Wow

Thx a lot for the link Cliff. I guess I'll find my answers in there!

If not I'll be back with more questions.

In the mean time thx again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Filesharing works in Win but not Linux...Networking settings? oudent Linux - Networking 2 10-25-2005 11:20 PM
Can't ping from linux to Windows XP paulsm4 Linux - Networking 1 09-18-2005 08:25 PM
Networking Linux and Windows - Ping doesn't work njs12345 Linux - Wireless Networking 5 02-20-2004 03:29 PM
Networking Troubles: Can't ping windows computers phishead Linux - Networking 3 04-05-2003 03:08 PM
Windows can't ping Linux frkstein Linux - Networking 1 09-12-2002 08:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 12:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration