-   Linux - Wireless Networking (
-   -   Linksys WUSB600N Driver and DLINK DWL-AG132 driver (

linux4john 02-20-2008 04:44 AM

Linksys WUSB600N Driver and DLINK DWL-AG132 driver
Hi all,
i would like to know whether the devices,
1.Linksys WUSB600N (802.11a/b/g/n compliant)
2.DLINK DWL-AG132 (802.11a/b/g compliant)
are being used on any Linux platforms(Redhat Enterprise Linux V5, Fedora 8/9, Ubuntu, SUSE etc).

If so,Are the device drivers available for download?
(any pointers)

thanks in advance

Drakeo 02-20-2008 09:03 PM

they all work with some help but it is the chip on the card not the company that sales it you can have. I have got both of them to work. but then not sure what cip all the chips i know work right now with then ndiswrapper program and then you use a windows driver. i have mine set up both ways i am a hard ware geek but to ask a question you could google sure would help me out. good luck

linux4john 02-24-2008 11:12 PM

Thanks Drakeo.

using ndiswrapper is the only option for these devices?
what is the performance penalty one has to pay for this.

is the driver for these devices being provided by the product vendor or the chip vendor?
instead,will it be available to me if i buy RED HAT ENT Edition 5 along with the support or maintenance?


e-vaderpunk 07-06-2008 08:52 AM

Im having problems installing the wusb600n driver, i have downloaded them from the linksys web site. The files im using are the ones used for XP:
Driver.2K** rt2870.inf* rt2870.sys*
Im using ndiswrapper to load the rt2870.inf and it tells me that ndiswrapper does not have an interface. Im using PClinuOS on kde, kernel version

Any help will do, thank you.


markackerman8@gmail. 08-07-2008 02:04 PM

I would like to use the usb600n adapter as well!!
I can't find a driver on Linksys's website at all for the 600N (it's greyed out)

does anyone know where to download it??


thanks in advance!


e-vaderpunk 08-08-2008 09:31 AM

Download drivers

markackerman8@gmail. 08-12-2008 09:47 PM

I have had success with the WUSB600N with the XP driver it comes with on disk and ndiswrapper but it is unstable when in WPK1 encryption mode and stops receiving after a short time of any slightly aggressive load.

I would like to point out that I tried the Ralink usb2870 driver and ndiswrapped crashed trying to install it??? any suggestions anyone,

Thanks in advance, Mark

Iyeru 09-07-2008 10:21 AM

I'd like to know if it was possible to get the drivers working without having to use ndiswrapper. Or am I just hoping for nothing and will have to wait for ReactOS to become more stable?

rich165p 01-12-2009 02:42 PM

try this page
ralinktech/ralink/Home/Support/Linux.html tiis is the chip set for wusb600n at bottom of page Firmware RT2870USB(RT2870/RT2770)

BabyStuey 04-19-2010 05:07 PM

WUSB600N v2 Quickstart Guide for Linux
A present for everyone having trouble with the Cisco/Linksys Wireless-N USB Network Adapter with Dual-Band Version 2 (aka WUSB600N v2)!

NOTE: The code for the Ralink driver is currently NOT 64-bit clean, so any success compiling and installing on a 64-bit kernel (amd64, x86_64, etc.) is pure fluke. If anyone has any luck getting the adapter to work in a 64-bit environment, please let me know! These instructions are proven only for 32-bit environments.

NOTE: These were the steps required to install the driver on a system running Debian GNU/Linux 2.6.26-2-686, installed from the 5.0.4 (lenny) i386 image available at:

They were revised to be clearer for users running different distributions, including Ubuntu and Fedora. Others may require minor tweaks, but should work as well.

Additional Tests Performed:

Fedora 12 (
Installed from: Desktop Edition i686 Live CD
Result: EASY! No added packages were required. Only requires you compile and install the driver - no additional tweaks necessary.

Ubuntu 10.04 Lucid Lynx (2.6.32-21-generic)
Installed from: PC (Intel x86) desktop CD image, ubuntu-10.04-desktop-i386.iso
Result: Pretty easy. No added packages were required. Follow the instructions and it should work.

Ubuntu 10.10 Maverick Meerkat (2.6.35-22-generic) requires version or newer of the driver to work correctly.

NOTE: pico and nano are command-line text editors. If nano doesn't work in the commands below, try pico. You can always link one to the other by making a link:

# ln /usr/bin/nano /usr/bin/pico
which will run nano whenever you (accidentally) type pico.

NOTE: Ubuntu users, please read: for information running commands as the super-user.

NOTE: Fedora users are able to ignore the prerequisites, perform Steps 0 through 6, 11 and 12, skipping steps 7 through 10 completely.

WUSB600N v2
Quickstart Guide for Linux

Debian Prerequisites (mostly precautionary):
- Plug into a wired connection and do a full update with System > Administration > Update Manager.
- Load Synaptic Package Manager
- You will have have "linux-image-${VERSION}" installed
- ...where ${VERSION} is the output from the command `uname -r`. For example: linux-headers-2.6.26-2-686.
- Make sure you have "linux-headers-${VERSION}" installed
- Make sure you have "linux-source-${VERSION}" installed
- Install "build-essential" (and also possibly "kernel-package", "kbuild", "linux-kbuild-${VERSION}", "linux-support-${VERSION}", though I doubt if these were actually required)

Step 0.
Stop pretending ndiswrapper will work reliably! lol.

Step 1.

Download the correct chipset driver from Ralink:
- You need RT3572USB (12/22/2009) or similar
- NOT RT2870USB (This is for Version 1 only!)
Step 2.
Unpack the tarball {DATE}_RT3572_LinuxSTA_{VERSION}.tar.bz2 to a location where you can find it (home folder, Desktop, etc.) All paths listed below are in reference to the folder you just unpacked, for example ${BASE} actually refers to the folder: "/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/" (or similar)

Step 3.
From the command line, run lsusb. You should get some output that looks like this:
"ID 1737:0079 Linksys WUSB600N Wireless-N USB Network Adapter with Dual-Band ver. 2"
Step 4.
- Open the file ${BASE}/common/rtusb_devid.c (this file has been renamed to rtusb_dev_id.c in newer releases)
- Line 103 shows the device id for WUSB600N Version 1:
{USB_DEVICE(0x1737,0x0071)}, /* Linksys WUSB600N */
- We need to tell the driver to work with Version 2.
- At line 119, add (which should match your output from Step 3):
{USB_DEVICE(0x1737,0x0079)}, /* Linksys WUSB600N v2 */
- Like so:


#ifdef RT35xx
        {USB_DEVICE(0x148F,0x3572)}, /* Ralink 3572 */
        {USB_DEVICE(0x167B,0x4001)}, /* 3572 */
        {USB_DEVICE(0x1737,0x0079)}, /* Linksys WUSB600N v2 */
#endif // RT35xx //
        { }/* Terminating entry */

Step 5.
As per the ${BASE}/README_STA file's instructions, change the two values in ${BASE}/os/linux/ from =n to =y:

Step 6. --- more on this step below in post #13.
Compile the driver:
- cd to the driver's home folder ${BASE}

$ cd ${BASE}
$ make
- Deal with any missing package and/or configuration issues that may be displayed.

- Once the driver compiles correctly, install it as the superuser:
$ sudo make install
$ su
# make install
Step 7.
If you scroll waaaay to the bottom of ${BASE}/README_STA, you'll see some confusing instructions. What they are trying to say is:
- As the superuser, open /etc/modules
$ sudo nano /etc/modules
$ su
# nano /etc/modules
- In Ubuntu, add the lines:
rt3572sta # Ubuntu only!
alias ra0 rt3572sta
- In Debian, add only the line:
alias ra0 rt3572sta
Step 8.
If you want your driver module to load at startup (and this you do)...
- As the superuser, open /etc/network/interfaces
$ sudo nano /etc/network/interfaces
$ su
# nano /etc/network/interfaces
- Update the line that starts with "auto" to include "ra0", for example:
auto lo ra0
and add the line:
allow-hotplug ra0
- For more information on this step, type the command:
man 5 interfaces

Step 9.

Blacklist the alternate drivers:
- As the superuser, open /etc/modprobe.d/blacklist or blacklist.conf (whichever you have)
$ sudo nano /etc/modprobe.d/blacklist.conf
$ su
# nano /etc/modprobe.d/blacklist
- Add the lines:

#default WUSB600 staging drivers
blacklist rt2870sta
blacklist rt2800usb

Step 9 Troubleshooting:
You may have to also blacklist a selection of additional drivers that come with your kernel. For example, the default Ubuntu 2.6.32-21-generic installation may require the following:

blacklist rt2860sta
blacklist rt2870sta
blacklist rt3090sta

blacklist rt2x00usb
blacklist rt2500usb
blacklist rt2800usb
blacklist rt73usb

If you do a module listing, you can see the kernel object modules attached to your kernel:

modprobe -l
This is a pretty long list, so let's shorten it to see what we want. One of these should do the trick:


modprobe -l | grep wireless
modprobe -l | grep sta.ko
modprobe -l | grep usb.ko

Look for any drivers that match rtXXXXsta.ko or rtXXXXusb.ko that are NOT rt3572sta.ko and try blacklisting them as well (minus the .ko extension).

Step 10.


Step 11.
Open up your favourite network manager and configure your wireless connection.

If you're still not getting a connection, repeat Step 3 to ensure your adapter is present. If it does not show, unplug it and reinsert. lsusb should now show your adapter and you should be able to connect.

If you're STILL not getting a connection, Consider installing "Wicd", an alternative network manager. You will need to manually input "ra0" as your "Wireless interface in the Preferences pane.

Step 12.
Happy surfing, dude(tte)! :D

ralphie 04-22-2010 04:09 PM

Hey thanks a lot babystuey!

I made it to # 5 and then i hit a dead end because im a nub.

Ive never had to compile drivers before. I tinkered with it and googled how to compile drivers but it confused me more.

I believe im suppose to point the terminal to the folder that all the drivers ect are in and then it will let me give the command make?

Well if thats true i could not get the terminal to point to the correct place, all i got was no such file or directory.

So yea if you could(or someone) go into a little more detail about the compiling section so i can finish the rest id be really appreciative.

Thanks in advance.

Oh yea and two more questions.

One will this effect the usb adapter when i boot over into Windows?

And after everything is all done as far as getting this to work, can i delete the folder 2009_1214 etc from the computer? I dont need to keep it around do i?

BabyStuey 04-22-2010 07:20 PM

I thought this was complete, but you're right...I forgot a couple of things! Firstly, you must have the complete suite of packages installed that will allow you to compile software. Be sure you have compilers installed: "gcc", "gcc-base", etc. installed. (Version 3.4 for compatibility, version 4.3 for newness). Some distros, I believe, have a special option for "Development System", which if left unchecked will probably exclude some of these essentials at installation time. This can be remedied from your package manager though.

Secondly, I'll empasise that wherever I put "${BASE}" above, I really meant "/home/username/Desktop/2009_1214_RT3.../" or wherever you decided to unpack the archive.

I'll give you a full terminal output in a bit (not on Linux right now)


Oh yea and two more questions...One will this effect the usb adapter when i boot over into Windows?
Negative. Windows drivers control the adapter in Windows; Linux drivers make it work in Linux. As soon as you restart, it's a clean slate. Though I've sometimes found that making the adapter work in Windows kick-starts it for use in Linux...don't ask me why.


And after everything is all done as far as getting this to work, can i delete the folder 2009_1214 etc from the computer? I dont need to keep it around do i?
Technically, you CAN, but I usually shove drivers, install programs, etc. into a folder called "build" in my home folder, just in case I need to refer back to them at any point. If you ever want to remove the driver, you can do a "make uninstall" from the "2009_1214_RT3..." folder to get rid of the drivers automatically. The saved drive space is barely worth the effort to delete them anyway. :)

BabyStuey 04-22-2010 08:12 PM

Here's a complete terminal output...with some extra steps added for clarity! :)

$ is a user terminal prompt
# is a root terminal prompt
~ is your home folder

I unpacked the driver archive to the Desktop. My system is named "debian-i686" and "username" is the username used to login (just substitute accordingly).

Commands to input are coloured.
Output generated is also coloured.



username@debian-i686:~$ pwd

username@debian-i686:~$ cd Desktop/

username@debian-i686:~/Desktop$ ls -l
total 16
drwxr-xr-x 8 username username 4096 2009-12-22 02:09 2009_1214_RT3572_LinuxSTA_V2.3.0.0
lrwxrwxrwx 1 username username  19 2010-04-12 06:05 Downloads -> /home/username/Download
-rw-r--r-- 1 username username 9548 2010-04-20 09:19 wusb600n.txt

username@debian-i686:~/Desktop$ cd 2009_1214_RT3572_LinuxSTA_V2.3.0.0/

username@debian-i686:~/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0$ make
make -C tools
make[1]: Entering directory `/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/tools'
cp -f os/linux/Makefile.6 /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/Makefile
make -C /lib/modules/2.6.26-2-686/build SUBDIRS=/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.26-2-686'
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/crypt_md5.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/crypt_sha2.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/crypt_hmac.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/crypt_aes.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/crypt_arc4.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/mlme.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_wep.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/action.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_data.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtmp_init.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_tkip.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_aes.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_sync.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/eeprom.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_sanity.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_info.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_cfg.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_wpa.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/dfs.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/spectrum.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtmp_timer.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rt_channel.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_profile.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_asic.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_cmd.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/assoc.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/auth.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/auth_rsp.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/sync.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/sanity.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/rtmp_data.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/connect.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/wpa.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../sta/sta_cfg.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtmp_init_inf.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_profile.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/sta_ioctl.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_linux.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_main_dev.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/ba_action.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_mac_usb.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtusb_io.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtusb_bulk.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtusb_data.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/cmm_data_usb.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/ee_prom.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/ee_efuse.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtmp_mcu.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../chips/rt30xx.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rt_rf.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../chips/rt35xx.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../common/rtusb_dev_id.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_usb.o
/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_usb.c: In function ‘RtmpMgmtTaskInit’:
/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_usb.c:70: warning: passing argument 2 of ‘RtmpOSTaskAttach’ from incompatible pointer type
/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_usb.c:80: warning: passing argument 2 of ‘RtmpOSTaskAttach’ from incompatible pointer type
/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_usb.c:90: warning: passing argument 2 of ‘RtmpOSTaskAttach’ from incompatible pointer type
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/rt_usb_util.o
  CC [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/../../os/linux/usb_main_dev.o
  LD [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/rt3572sta.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/rt3572sta.mod.o
  LD [M]  /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux/rt3572sta.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-2-686'

username@debian-i686:~/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0$ su
Password: ********

debian-i686:/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0# make install
make -C /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux -f Makefile.6 install
mkdir: cannot create directory `/etc/Wireless': File exists
make[1]: Entering directory `/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux'
rm -rf /etc/Wireless/RT2870STA
mkdir /etc/Wireless/RT2870STA
cp /home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/RT2870STA.dat /etc/Wireless/RT2870STA/.
install -d /lib/modules/2.6.26-2-686/kernel/drivers/net/wireless/
install -m 644 -c rt3572sta.ko /lib/modules/2.6.26-2-686/kernel/drivers/net/wireless/
/sbin/depmod -a 2.6.26-2-686
make[1]: Leaving directory `/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0/os/linux'

debian-i686:/home/username/Desktop/2009_1214_RT3572_LinuxSTA_V2.3.0.0# exit


And you're done! :) Let me know if this is still confusing.

ralphie 04-22-2010 08:28 PM

Ok well im posting this from within Ubuntu right now.

I found a thread on this topic(but for an older model usb adapter) on the ubtunu forums and that helped me figure out the things i was missing from your post.

Your post i must say was very accurate.

I mean i went down the list and it is working right now.

It is at 54mb so im not sure if that is the speed it is suppose to be or what state it is in(G, N etc) but it is working and it autoloads as well.

I hope you don't drive yourself crazy for me since i got it working but it might help the next guy.

One thing i did do was instead of having to type su i just made the root terminal visible and used that instead.

For some reason when i typed su it would ask for password and then say authentication failed so i realized that root terminal worked a lot better.

My problem though was that i didn't know what you meant when you said

Step 6.
Compile the driver:
- From the driver's home folder ${BASE}

$ make

Now i know that you have to get the terminal to basically point to the correct folder and then type $ make.

But also i found that you needed to add cd to some commands to get them to work.

So all in all i really thank you this helped me a ton and it was the quickest i ever got this up and running(i switch between Windows and Linux quite often lol)

When the bleep are they going to add this chipset as a permanent has been like this for a while now.

Well no worries, learning Linux is fun.


ralphie 04-22-2010 08:33 PM

Oh you beat me, im sorry!!!

But thank you for clarifying.

and for your quick response!!

One last thing-

I have a USB dongle for my Nintendo Wii, basically it creates a wifi network for the Wii to use. When this is plugged in for some reason Ubuntu defaults to using this to connect to the network and it is SLOWWWWW.

so i have to keep it unplugged on linux but thats no biggie because i rarely use the internet on the Wii.

All times are GMT -5. The time now is 10:42 PM.