LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Linksys WUSB54G v4 on RH9? (https://www.linuxquestions.org/questions/linux-wireless-networking-41/linksys-wusb54g-v4-on-rh9-353331/)

kz26 08-14-2005 11:26 PM

Linksys WUSB54G v4 on RH9?
 
I want to use my WUSB54G v4 (Ralink rt2570 chipset) on my RH9 kernel 2.4.20-8 system.
I tried both the rt2x00 1.1.0b1 drivers from http://rt2x00.serialmonkey.com/
and the original Ralink 2.0.3 drivers.

When I first compiled the make scripts told me that I had to enable kernel loadable module support.
So I recompiled my kernel, and updated my GRUB boot conf without problems.

So I tried compiling the drivers again. However, for both drivers, I get a bunch of
errors mentioning invalid options/unrecognized flags/etc.

Also, I cannot use ndiswrapper because the kernel is too old.
Are the drivers not compiling because of the same reason?

Someone please confirm that the kernel is indeed to old.
If that's true, I guess I'll have to upgrade this box.

pxumsgdxpcvjm 09-03-2005 03:35 PM

Hey I bet you asked this same question on the serialmonkey forum because it has the same question regarding the same kernel version on the same date that you asked on this forum. For anyone else who wants to know the answer to the question, the Serialmonkey forum explains how you find out: "It's not as much the kernel version but the version of the Wireless Extensions in that kernel. Run 'iwconfig -version' to see what version of the Wireless Extensions is in your current kernel. We recommend at least v17."
http://rt2x00.serialmonkey.com/phpBB...opic.php?t=260

kz26 09-04-2005 08:17 PM

Yeah, I did post there too. Thanks for the info.

And Welcome to LQ!


All times are GMT -5. The time now is 06:40 AM.