LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices


Reply
  Search this Thread
Old 09-07-2004, 08:02 PM   #1
shah1701
LQ Newbie
 
Registered: Sep 2004
Posts: 5

Rep: Reputation: 0
Linksys WPC11 Version 4 802.11b wireless pcmcia adapter


Hi, I run Fedora Core 2 (kernel 2.6) on my IBM Thinkpad T23 laptop. I recently purchased a Linksys WPC11 PCMCIA 802.11b wireless card (version 4) and cannot figure out how to get it to work. I'm not the most competent Linux user, but I'm pretty good at getting things like video drivers to work, however this is really stumping me. I can't really get a soild answer...I have no clue if there is a driver for this thing. I paid more money for this card rather than a generic one because I figured there would be more support (guess not). Any ideas?
Thanks!
 
Old 09-07-2004, 08:31 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
Welcome to LQ!

Unfortunately wireless and Linux is sort of a crap shoot. Some cards are extrememly well supported by their manufacturers and others, well, getting them to work can require everything short of animal sacrifice. Your card falls in the middle, but you should feel free to bitch to Linksys about their lack of Linux support. The first thing you need to do is find out what chipset your card is using. Check the output of lspci to find out. If there are native linux drivers, use those. Otherwise you may need to use either ndiswrapper or linuxant, which are programs that allow you to use the Windows drivers under Linux.

One of the next things you want to familiarize yoursefl with is the Search function here. Searching on the card name will bring up a lot of advice as your card is used by a number of people.
 
Old 09-20-2004, 09:32 PM   #3
shah1701
LQ Newbie
 
Registered: Sep 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs up Got it to work

I got the card to work. I had to read a lot of stupid docs and go through about 4 hours of hell, but I hope this will help out other people. I couldn't get the Linux Realtek 8180L driver provided by Realtek to build. From what I can see in the makefile, it looks like it was designed for the 2.4 kernel (which is quite useless for Fedora Core 2).

I then tried ndiswrapper and got it to work. If you're not familiar with ndiswrapper, it is an open source project that allows you to use Windows XP drivers in Linux (i.e. it's a wrapper for the windows driver api). Of course it doesn't work for all drivers becaues it's in early stages of development...in fact the Windows XP Linksys WPC11 V4 driver will not work, rather you have to use Realtek's 8180L Windows driver (the Realtek 8180L is the chipset on the card).

In a nutshell these are the steps you want to take.

1.) Make sure PCMCIA packages are installed (they should be in most cases, otherwise get out of this thread and figure that out). You'll be able to tell if you see 'Starting PCMCIA' in the bootup screen and if at least the power light is on on the wireless card.

2.) Download ndiswrapper 0.10 http://sourceforge.net/project/showf...ease_id=262015

3.) Download the WINDOWS XP (NOT LINUX) Realtek 8180L driver
http://www.realtek.com.tw/downloads/...x?Keyword=8180

4.) Install ndiswrapper by doing the following:
a.) Unpack the gz file
b.) Type make install

5.) ndiswrapper is now installed. Now unzip the realtek driver file (3 files should be there, one called NET8180 .INF)

6.) Use ndiswrapper to load the Windows driver into memory by typing
ndiswrapper -i </path/to/NET8180.INF>

By the way, what happens here is that ndiswrapper copies the INF file as well as the other two files
into a new subdirectory located at /etc/ndiswrapper/net8180. If this doesn't happen, something
went wrong

7.) To see if it was succesful type ndiswrapper -l
You should see something along the lines of 'net8180 is present'

8.) Now type 'modprobe ndiswrapper'. This loads ndiswrapper in as a kernel module. This command
should yield no output. To Linux, there is no Realtek 8180L, there's just some device known as
ndiswrapper.

9.) Go into the Red Hat Menu, System Setting, then Network. Go to Add, then Wireless Devices,
then you should see at least two options. One says ndiswrapper, and the other says 'Other Devices'.
Choose ndiswrapper, use the default settings unless you know what you're doing, hit okay. Then
activate. You might need to restart pcmcia and network services (easiest way to do this is to restart the PC).

I think that should cover it. Check the output of the shell command 'dmesg' (this is the system log) to make sure wlan0 was started up okay. Alright, I'm running out of power. Good luck.

Last edited by shah1701; 09-20-2004 at 09:39 PM.
 
Old 09-22-2004, 06:02 PM   #4
Harmonic
LQ Newbie
 
Registered: Dec 2003
Location: Irvine CA
Distribution: Fedora Core 2
Posts: 7

Rep: Reputation: 0
Thanks almost

It Worked!!! kinda! I got the ndiswrapper going installed it and what not! The problem came when i tried to goto the network settings. I didnt find the second ndiswrapper option you spoke of. I gave the command iwconfig and it showed that I had a wireless connection at wlan0. Any ideas? Also interesting to note I cant delete the network settings that I input when i was trying out different drivers.
 
Old 09-25-2004, 12:08 PM   #5
chidorex
LQ Newbie
 
Registered: Sep 2004
Location: Cancun, Mexico
Distribution: Fedora Core 2
Posts: 4

Rep: Reputation: 0
Unhappy No ndiswrapper on the wireless cards list

Geez, I also almost got it to work. Thanks shah for your great post. It really helped me advance a lot. I have a Netgear MA521 that uses the same Realtek driver, so I used your post as a reference. The first thing I did that really helped me is upgrade my FC1 to Core 2.

However, I am the same stage as Harmonic: the Network setup utility does not show the ndiswrapper wireless device ('System Settings > Network > New > Wireless Connection').

The last lines of dmesg are the following:

Code:
ndiswrapper version 0.10 loaded (preempt=no,smp=no)
PCI: Enabling device 0000:02:00.0 (0000 -> 0003)
ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:02:00.0 to 64
ndiswrapper: using irq 11
divert: allocating divert_blk for wlan0
wlan0: ndiswrapper ethernet device 00:09:5b:64:79:fb using driver rtl8180.sys
ndiswrapper device wlan0 supports WPA with AES/CCMP and TKIP ciphers
ndiswrapper: driver rtl8180.sys (Realtek,07/09/2004,5.170.0709.2004) added
My lspci -v shows
Code:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev 20)
        Subsystem: Netgear: Unknown device 4700
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 4000
        Memory at 2f800000 (32-bit, non-prefetchable) [size=512]
        Capabilities: [50] Power Management version 2
the ndiswrapper command shows the installed driver
Code:
# ndiswrapper -l
Installed ndis drivers:
net8180 hardware present
and iwconfig does show my wireless access point, well, I think...
Code:
lo        no wireless extensions.
 
sit0      no wireless extensions.
 
eth0      no wireless extensions.
 
wlan0     IEEE 802.11b  ESSID:off/any
          Mode:Auto  Frequency:2.412GHz  Access Point: 00:00:00:00:00:00
          Bit Rate:11Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
          RTS thr:2432 B   Fragment thr:2432 B
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-95 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Does anybody have any ideas as to what I should try next?

Thanks a lot
Rex
(newbie of course)
 
Old 09-27-2004, 07:59 PM   #6
RandallC
LQ Newbie
 
Registered: Sep 2004
Distribution: Ubuntu!
Posts: 27

Rep: Reputation: 15
I'm at this point as well. I'm not sure what to do now
Any help out there?
 
Old 10-03-2004, 08:21 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 420Reputation: 420Reputation: 420Reputation: 420Reputation: 420
It looks as if your setting the ESSID to any isn't working. You're not associating with an access point. Try setting the SSID to the real value and see if that does the trick.
 
Old 10-03-2004, 11:34 PM   #8
shah1701
LQ Newbie
 
Registered: Sep 2004
Posts: 5

Original Poster
Rep: Reputation: 0
yeah, you're almost there!

I ran into the same problem. Wireless networks are identified by an ID called the SSID (service set identifier). This is also called the network ID for a wireless LAN. You need to have the SSID to get onto a WLAN. When you're in Windows, Windows is smart enough to probe all the nearby networks and pick the strongest SSID. You can also manually change it by double clicking on the the little network status icon in the system tray and choosing another SSID.

Of course in Linux (particularly FC2), the auto feature doesn't seem to work, so what you do is you manually set it. Go into your network settings and type in your network SSID. On cheap home routers, the default SSID tends to be along the lines of "Linksys" or "NETGEAR" depending on the brand. It's a wise idea to change the name so that it is unique especially if you live in an apartment like I do. If you want to do it using the command line, I think it's something along the lines of: iwconfig -wlan0 essid "YOURID". You can check the exact syntax by doing iwconfig --help or man iwconfig.

I haven't had time to figure out why it isn't working correctly. It is a big inconvenience as I move around a lot to various networks. That means if you go from your home to let's say a Starbucks, you have to manually type in the other SSID and restart the card.

Another problem I run into with Linux is that it takes a while sometimes to get a connect to a particular WLAN. This tends to be because of a difference in the channel. If you set the channel to the exact same channel the wireless router is outputting, you'll connect fast. I do believe Windows sort of keeps a record of which channel is optimal for every SSID. If you don't know much about data communications, wireless routers (in particular IEEE 802.11) broadcast frequencies at around 2.4 GHz. They split up this bandwidth into multiple channels (I believe around 11 for 802.11b). Multiple routers in a building can transmit at different channels to prevent interference and improve network efficency. Wireless cards tend to be smart enough to adjust to the correct channel, they're sometimes a little slow about it though...

Alright, hope that helps.

Last edited by shah1701; 10-03-2004 at 11:41 PM.
 
Old 10-16-2004, 04:23 PM   #9
trjonescp
LQ Newbie
 
Registered: Oct 2004
Location: San Luis Obispo, CA
Distribution: Gentoo
Posts: 1

Rep: Reputation: 0
Thanks shah

Thanks shah. I followed your steps and it worked perfectly on my Gentoo system (running 2.6.8 kernel).
 
Old 10-21-2004, 10:11 AM   #10
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Rep: Reputation: 15
Re: No ndiswrapper on the wireless cards list

Quote:
Originally posted by chidorex
Geez, I also almost got it to work. Thanks shah for your great post. It really helped me advance a lot. I have a Netgear MA521 that uses the same Realtek driver, so I used your post as a reference. The first thing I did that really helped me is upgrade my FC1 to Core 2.

However, I am the same stage as Harmonic: the Network setup utility does not show the ndiswrapper wireless device ('System Settings > Network > New > Wireless Connection').

The last lines of dmesg are the following:

Code:
ndiswrapper version 0.10 loaded (preempt=no,smp=no)
PCI: Enabling device 0000:02:00.0 (0000 -> 0003)
ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:02:00.0 to 64
ndiswrapper: using irq 11
divert: allocating divert_blk for wlan0
wlan0: ndiswrapper ethernet device 00:09:5b:64:79:fb using driver rtl8180.sys
ndiswrapper device wlan0 supports WPA with AES/CCMP and TKIP ciphers
ndiswrapper: driver rtl8180.sys (Realtek,07/09/2004,5.170.0709.2004) added
My lspci -v shows
Code:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev 20)
        Subsystem: Netgear: Unknown device 4700
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 4000
        Memory at 2f800000 (32-bit, non-prefetchable) [size=512]
        Capabilities: [50] Power Management version 2
the ndiswrapper command shows the installed driver
Code:
# ndiswrapper -l
Installed ndis drivers:
net8180 hardware present
and iwconfig does show my wireless access point, well, I think...
Code:
lo        no wireless extensions.
 
sit0      no wireless extensions.
 
eth0      no wireless extensions.
 
wlan0     IEEE 802.11b  ESSID:off/any
          Mode:Auto  Frequency:2.412GHz  Access Point: 00:00:00:00:00:00
          Bit Rate:11Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
          RTS thr:2432 B   Fragment thr:2432 B
          Encryption key:off
          Power Management:off
          Link Quality:100/100  Signal level:-95 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Does anybody have any ideas as to what I should try next?

Thanks a lot
Rex
(newbie of course)
I ran into the same problem. No ndiswrapper listed in the network settings. I ran ndiswrapper -m which gave this output "Adding "alias wlan0 ndiswrapper" to /etc/modprobe.conf". I then ran the modprobe ndiswrapper and then went to the network settings. The ndiswrapper option was there.

Still working on the settings but I'm getting there. Hope this helps someone.
 
Old 10-21-2004, 11:42 AM   #11
mrmcctt
Member
 
Registered: Oct 2004
Posts: 54

Rep: Reputation: 15
Thumbs up Success

Well, it works. The only thing I hate is when I fix something and I'm not really sure how I did it. The network settings with WEP seemed to be my biggest hangup but I am now posting from Firefox 1.0PR on Fedora Core 2 from my Linksys WPC11 wireless adapter. WooHoo!!!!

(It's the small victories that mean so much)

Now on to my next fight. IE6 under Linux. (I know, I know.....My employers have an online timesheet that I have to fill out but so far it has only worked in IE).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cisco 350 wireless adapter 802.11B D_Linux Linux - Software 4 04-19-2005 09:30 AM
Netgear MA311 802.11b Wireless PCI Adapter [DRIVERS]? gujuboy Linux - Wireless Networking 39 10-15-2004 07:45 AM
Linksys 802.11b Wireless Network NiteWolf Linux - Wireless Networking 9 06-17-2004 12:26 PM
Linksys Wireless 802.11b USB tekkid Linux - Hardware 2 03-26-2004 02:34 PM
ZyAIR B-200 802.11b Wireless USB Adapter driver andy69 Linux - Hardware 0 03-09-2004 06:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking

All times are GMT -5. The time now is 05:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration