-   Linux - Wireless Networking (
-   -   Laptop prevents desktop from connecting (wirelessly) to access point (

b0uncer 05-02-2008 11:04 AM

Laptop prevents desktop from connecting (wirelessly) to access point
Put short: if laptop is connected to my wireless access point before desktop, the desktop won't connect at all; if desktop is connected first, laptop has no trouble whatsoever.

More details:

Laptop's wireless card has a Broadcom chipset, uses the b43 kernel module to connect and works without problems. Desktop is connected to the wireless access point using an A-Link wl54usb USB-connected dongle, which uses zd1211rw kernel module, also works without problems. Laptop runs Ubuntu 8.04 operating system, at the moment on the desktop are Ubuntu 8.04 and Windows Vista. Access point is a Buffalo Airstation, don't know much more specifically except that it seems to work well and has worked well for more than a year now. It's configured to use WPA2 encryption, no restrictions for mac addresses or such..

The problem (and some details):

There are three cadgets at the moment that I can use to connect to my wireless access point: the laptop, the desktop and a PSP system. Each of them work flawlessly if used separately. Laptop and PSP work without any problems at the same time, or in other words, they don't care which device is connected first. If the desktop is connected first to the access point and laptop after that, there are no glitches, no problems; but like it says in the subject, if laptop connects before desktop, the desktop won't simply connect. It's not up to the operating system, since this same behaviour happens on both Ubuntu and Vista; hardware is found, but it just won't connect.

I should mention that the access point works as a dhcp server, and both the laptop and desktop use different ip addresses (of course, they are given different addresses). In addition I checked, just to make sure though it sounded stupid, and all devices have different mac addresses. I've thought about this for a few weeks now, and haven't come up with anything that could prevent the desktop from connecting while laptop is connected, that wouldn't do the same vice help is needed :)

If you have any ideas, or better yet knowledge/experience, I'd be happy to hear. It's not a question of life and death, I can easily switch off the laptop's wireless card for a few seconds and then back on to have both connected, but it sure is both annoying and odd. And the first time I have heard this happen.

Thanks for reading and for any answers :)

686plus 05-02-2008 01:56 PM

I have a similar problem, but with two laptops. Each works fine alone, but can't connect while the other is connected. I also use a Buffalo Airstation WHR-HP-54G. I believe its a router issue.

If I use my Ubuntu laptop bash shell, I see DHCP offers from the airstation, but no connection is made because there are no working leases in the database (I think that means there is no cached current lease).

I will try connecting with Wireshark to see if there are any obvious packet problems.

I am considering installing third-party firmware (dd-wrt maybe), which is why I bought the brand and model anyway.

I sent an email to Buffalo tech support and got a canned reply, which was basically an rtfm howto setup guide:


Before attempting the following please verify the switch on the back of the
router is set to router or on and not in BRI mode.
The first thing you would want to do is turn off your modem, router and
computer. You may need to unplug the modem and router to turn them off.
Next verify the modem is not plugged directly into the computer at all, it
should be plugged into the WAN/Internet port on the router.
Next verify the computer is plugged into one if the ports (1-4) on the router.
I would now suggest resetting the modem and router.
To reset the modem, unplug the coaxial cable from the modem for 5 minutes.
To reset the router, turn on the router and wait until the red DIAG light is
off. Next use a paper clip to hold in the INIT/RESET button on the router.
When the red light turn on release it. When the red light is off, for at least
10 seconds unplug the router.
Now in order to setup the connection, please turn on the modem and wait until
it is fully up.
Next turn on the router and wait until the red DIAG light is off for at least
10 seconds.
Finally turn on the computer.
When the computer is fully booted, open up a browser window. (You may not be
able to get online and thats fine)
On the address bar, please type in and hit enter.
You may be asked for a USERNAME and PASSWORD either as soon as you open up the
browser windows or after the address is entered, either way the
default USERNAME and PASSWORD is listed below:

PASSWORD: (leave it blank)

Once at this location the router may have gone straight to the connection
wizard or you may need to click on RUN INTERNET CONNECTION WIZARD.
Once you click on this the router should finish setting up the connection.
If by chance you receive a message indicating DHCP or PPPoE server not found.
Please click on SET MANUALLY.
Now the setup will continue, this may take up to 10 minutes.
Once you see the Successfully connected window you will be all set.

Thank you,

Buffalo Technical Support


> Area of interest: Wireless/Storage/Multimedia Support
> First Name:
> Last Name:
> Email:
> Buffalo Product: Wireless
> Operating System: WINDOWS XP PRO
> Connection Type: LAN/WAN
> How may we assist you?:
> I can only connect one wireless client at a time to my buffalo
> whr-hp-54g router. As soon as I disconnect the first client, I can
> connect the second client.
> I'm using WPA-PSK(TKIP) for the security.
> I can't find anything in the gui settings that would affect that.
> I also checked the knowledge base and could not find a similar problem.
> A google search did not reveal any answers, but did confirm a few others
> are having that problem. Here is one:
> Any suggestions?
> Buffalo Technology (USA), Inc.
> 11100 Metric Boulevard, Suite 750
> Austin, TX 78758 USA
> Phone: 512-349-1300
> Fax: 512-794-8520

b0uncer 05-03-2008 02:16 AM

Sounds like my case, except that it's not about connecting just one device at a time; like I mentioned in my original post, my Sony PSP (which has wireless functionality) and the laptop don't mind each other's connections, it's just between the laptop and the desktop. That's what's so odd about this.

In addition to the wireless devices there's one desktop pc connected to the box with ordinary network cable, and it works all right too so I don't think it's about dhcp then - or why would it only happen to one pc then, independently of the other connected devices or their number?

I'll try to find out more details about this, and post here if I find any.. Thanks for the reply.

EDIT: I visited Buffalo's website, downloaded the latest firmware (2006 or something; not too brand new) for the Airstation and upgraded to it. After that I connected the laptop, rebooted the desktop and both connected; this could be just pure luck, but right now the problem didn't come up. I wonder what the firmware upgrade did; on the site it says "Notes: fixes Auto Channel disconnect issue", but I doubt if that has anything to do with this.

Well, I'll see how it works for a few days and post if I find anything new.

686plus 05-03-2008 08:22 AM

Thanks for the info. I'm pretty sure I have the latest firmware, but I'll double check. I also have a desktop, server, and print server all connected by wire. They never have any problems either.

I think you might be on to something with the auto channel setting. I've seen that crop up in other buffalo router posts. Most recommend setting a channel instead of allowing auto. After your firmware upgrade, are you on auto or a set channel? I've always just used auto, which was the default.

b0uncer 05-04-2008 03:16 AM

Ok, I'll regard this confirmed now -- after the firmware upgrade I've booted these computers in different orders and the connection problem seems to have vanished. So apparently it was after all the router, though I still don't get why only one computer was affected about it.

The firmware version I used was 1.40, available at after selecting the airstation model from the drop-down list ("Wireless-G 125* High-Speed Broadband Router and Access Point"). I usually try to avoid firmware upgrades, as they can do damage if the installation doesn't succeed; well, I guess this time I was lucky.

And about the's been on Auto mode since I bought it, and it still is -- and I doubt if it would be of any use for me to set it to some certain channel, because there are other wireless access points nearby, and some of them come and go, causing it that the channels (frequencies) in use at "my range" change from time to time. To get the best out of my AP would then mean changing the channel manually from time to time (it works best if the used channel is frequency-wise as far from the other used channels as possible), and I don't think I'll go to that -- that's why the auto-feature is there I think :)

Anyway, I'd like to get more knowledge about what this upgrade actually fixes -- what the real problem was -- but if everything is as short-worded about it as the "Notes" at Buffalo-tech's download center, it might prove difficult. If you haven't installed the 1.40 firmware yet, try it out -- or if you have, and still have trouble, then maybe I'm not clear of this yet either..

686plus 05-07-2008 05:21 PM

I have had version 1.40 for some time, but had problems until I changed from auto to a designated channel. I have had no problems since.

With the response from Buffalo I had, I'm guessing all you will get is the notes / change log you already have.

b0uncer 05-11-2008 03:51 AM

Maybe I'm forced to try designated channel too; after the firmware upgrade things did work for a while, but today again not - laptop was connected, but desktop wouldn't connect. It was a little different this time than before, though; instead of just "not doing anything" the desktop actually found the AP, seemed to establish a connection to it but failed at the "logon" part (where it's supposed to send a key to the AP). Curious, but not hilarious.

I'll see if the channel setting helps. Thanks for sharing your knowledge.

EDIT: at least the first time worked with non-auto channel setting..hopefully this isn't just luck, like it seemed to be with the firmware upgrade.

All times are GMT -5. The time now is 09:38 PM.