-   Linux - Wireless Networking (
-   -   iwconfig shows Not-Associated (

Legolas327 06-24-2008 10:04 AM

iwconfig shows Not-Associated

Let me begin by saying "It works" which is the reverse of most "I need help" requests.

I have been pulling my hair out to get a ASUS (fully supported proven rt2500) wifi pcmcia card working with my inspiron 8100 laptop and I have it working now but I haven't a clue how I did it and maybe someone can help me out?

I am using fedora 9 with ndiswrapper. I have the correct driver (rt2500) installed and all checks out with ndiswrapper. I don't see any issues there.

I entered the iwconfig commands for essid "my wifi name"
I entered the iwconfig commands for WEP 128 Hex encryption ( I will change to WPA next) and yes I did have the correct key entered.
I entred the iwconfig command for mode managed

iwlist wlan0 scan found nothing.
Iwconfig showed the card as Not-Associated
Ifconfig showed the card but not connected

When I searched for my ifcfg-wlan0 files they where not created where I expected them to be? I thought that these commands would generate a ifcfg-wlan0 file.
So I used system-config-network and nmanager to configure my connection (not sure which one created the ifcfg-wlan0 file but one of them did where I expected it to before).

Anyways so I restarted the network, "iwconfig'd", and rebooted a zillion times and could not get a scan on the "iwlist wlan0 scan" and iwconfig kept showing that my card was "Not-assoicated"
Misery, pain, tears, maniacal laughter, and I finally pulled the card out and plugged it back in. and omgosh! I have wireless!!!!!!


Two days ago I had the card working just fine and when I rebooted, POOF!!! no wifi, no recognition of said card. I am afraid to reboot unless I know what to look at, save, and how to duplicate.

This is where the cry for HELP comes in :)

What do I save, look at, do to make sure no more pooffng away of miracle baby WIFI?

Thanks in advance,

Hangdog42 06-25-2008 07:23 AM


I have the correct driver (rt2500) installed and all checks out with ndiswrapper. I don't see any issues there.
Maybe I'm not understanding you correctly, but aren't you talking about two different drivers here? There is a native Linux driver for the rt2x00 and if that is loaded at the same time as ndiswrapper, all sorts of weirdness can result.

Check your lsmod output and see if you've got conflicting drivers. Otherwise, you might have to rummage through your logs to see if ndiswrapper is complaining.

prik420 07-02-2008 01:17 AM

i have the same chipset he's using. my usb rt2500 card used to work w/o any prob in earlier versions of fedora using just the default driver.

but like legolas327, i'm also having a similar problem. i can associate it well with the router but it can't get a dynamic ip.

@legolas327 try setting the ap value with iwconfig, that way you'll be able to associate it:

iwconfig wlan ap <mac addy of ur wifi card>

then try getting a dynamic ip with "dhclient wlan0". if my assumption is correct, u'll get the same problem i'm having.

read this(excerpts from

Ralink Chipset Comments

Ralink makes some nice b/g chipsets, and has been very cooperative with the open-source community to release GPL drivers. Packet injection is now fully supported under Linux on PCI/CardBus RT2500 cards, and also works on USB RT2570 devices. However, these cards are very temperamental, hard to get working, and have a tendency to work for a while then stop working for no reason. Furthermore, the RT2570 driver (such as that for the chipset inside the Linksys WUSB54Gv4) is currently unusable on big endian systems, such as the PowerPC. Cards with Ralink chipsets should not be your first choice.


i hope this helps.

Legolas327 07-03-2008 06:28 AM

I haven't attempted any correction since I first posted because I have it temporarily working with the ndiswrapper. Both replies say that the native kernel drivers should have worked. I gave up on them because when ever I plugged the the PCMCIA card into the slot I would get a kernel crash and have to power down reboot.

I really would like to try the native kernel with out using ndiswrapper if possible I just don't know how to go back to the native kernel.

So what would I need to do to use the native kernel? remove ndiswrapper and then look for what?

Hangdog42 07-03-2008 07:38 AM

I guess that after removing ndiswrapper, you would reboot and look in lsmod to see what driver is loaded. I'm pretty sure that the kernel module name starts with rt, but there are likely a few different possibilities. I think that since you've got an rt2500, the rt2500 kernel module should be there.

prik420 07-04-2008 01:02 PM

based on experience with fedora*, version 9's the least stable right now. i've verified that the rt2500 windows drivers(using ndiswrapper) work better than the rt2500* modules.

here's what u can do to use the kernel module instead of ndiswrapper:
1.update your fedora9 system first, obviously u can use whatever connection u have be it wired or not
2.u'l be prompted to reboot afterward, before that edit /etc/modprobe.d/blacklist and add this line:
blacklist ndiswrapper
3.edit /etc/modprobe.conf-dist and add this line:
alias wlan0 rt2500
4.reboot and try booting the updated kernel, check if you can now associate and connect without any problem.

i've just reinstalled fedora9 last night and just finished updating it this morning, i will check too if the updates made a difference. btw, a week ago i tried installing the updated kernel manually and still wasn't able to connect via wifi successfully.

and also, there's no need to reboot when changing modules for your wifi device. just rmmod the module to be replaced and make the necessary changes to your modules config file then load the module u'll be using.

All times are GMT -5. The time now is 11:17 PM.