-   Linux - Wireless Networking (
-   -   iwconfig cannot set WEP key (

muteki_sykes 05-27-2006 03:04 PM

iwconfig cannot set WEP key
hi all, i'm a newbie here but i've been messing around w/linux for a little while now... i'm trying to get slackware 10 set up on my dell inspiron 600m right now. i have almost everything working; everything but the network card.

i have 2 network interfaces, an ethernet and wireless interface. the wireless is a broadcom 4318 chipset. i have the firmware in place and have compiled the ndiswrapper to interface w/the card. when i did an iwconfig at school (which doesn't have an encryption key) i was able to detect the wireless network but not able to obtain an IP, which i think was because i didn't have a new enough version of DHCP. i got that taken care of.

the problem is when i try to connect at home. i live with my brother and he has the network set up for shared key (is that the problem?) access. he also masks the SSID so that you need the key to get on the network. unfortunately, when i try to enter the key using iwconfig, like this:

iwconfig wlan0 essid myNetwork key [1] \

i get "Error: unrecognised wireless request \"...\""
and it repeats my key back to me. now, of course, all those A's aren't my real key; when i put in the A's, it doesn't complain at all; it simply doesn't detect any network. this means that when i do an iwconfig, no SSID or Access Point is listed.

i have read posts by alot of people who seem to have pretty much the same problem with different cards and distro.'s, but none offered a solution that worked for me.
i haven't gotten back to school yet to check whether i can get an IP or not, so i'm still not sure if that's related, but at least at school the wireless tools detected the network. any words of wisdom would be greatly appreciated.

thanks so much, --Abe

DrEwMoNeY 05-27-2006 03:12 PM

Pretty sure that it is:

iwconfig wlan0 essid "your router's broadcast id"

example: iwconfig wlan0 essid linksys

and for the key it is:



iwconfig wlan0 key restricted XXXXXXXXXXXXXXXXXXXXXXXXXX

this is of course assuming that you have the proper driver loaded for your wireless card.

Good luck

DrEwMoNeY 05-27-2006 03:14 PM

To get an IP you might want to try

dhcpcd wlan0

muteki_sykes 05-27-2006 03:46 PM

still stuck
i've typed both in exactly as above, but i still get the error message.

iwconfig wlan0 essid myBroadcastID
iwconfig wlan0 key open xxxxxxxxxxxxxxxxxxxxxxxxx
iwconfig wlan0 key restricted xxxxxxxxxxxxxxxxxxxxxxxxx

for the first i don't get any messages, and the ESSID remains set to "off/any". for the second two i get the same "unrecognised wireless request error."

dhcpcd wlan0

sits there until i kill it, and

dhclient wlan0

says it didn't get any DHCPOFFERS. what else should i try?

thanks again, --Abe

muteki_sykes 05-27-2006 03:49 PM

i'm pretty sure i have the right firmware b/c i looked it up real carefully and it detects the network at school, i just couldn't get an IP.

DrEwMoNeY 05-27-2006 03:50 PM

First of all what does ndiswrapper -l say?

Second, what does iwconfig say?

One time I had to point the card to the AP first to get it to work. If you know the router's mac, I think the command is:

iwconfig wlan0 ap XX:XX:XX:XX:XX <----router's mac

muteki_sykes 05-27-2006 04:07 PM

ndiswrapper/iwconfig output
i was putting in an 'o' when i should have been putting in a 0. :cry: i switched out the o with a 0 and it detected my network. unfortunately, i forgot to install the 16k stack patch in my kernel and DHCP crashed the computer. i'll let you know how that works out once i get it patched.

again, thanks so much. --Abe

DrEwMoNeY 05-27-2006 05:07 PM

Good Luck and Have Fun!


All times are GMT -5. The time now is 02:55 AM.