LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (https://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   iwconfig arggh.. (https://www.linuxquestions.org/questions/linux-wireless-networking-41/iwconfig-arggh-255203/)

radioradio 11-15-2004 03:22 PM

iwconfig arggh..
 
Newbie warning..
Hi all, just installed Slack 10 - 2.4 and muddled my way thru upgrading my kernel to 2.6.7.

This is seriously wierd, and I have read a lot of iwconfig posts..
I got my Linksys WUSB11 wireless adaptor working using ndiswrapper 0.11 and the windoze driver. The first time I ran iwconfig, I could do :

iwconfig wlan0 essid 'abcde'

and the essid would change to abcde. BUT now NOThing changes when I run iwconfig. wlan0 exists, the lights flash but essid shows up as yyyyyyyyyyyyyyyyyyyyyyyyyyy or something.

I have found iwpriv reset but it does not reset.. Please, there is obviously something making the settings stick but how do I reset or whatever. Or is there a .conf file I should edit...

I should add I help run a Wireless ISP so I am not a wireless newbie, just a linux newbie...

Maybe Slackware is not the best for wireless but the odd thing is, I could edit settings initially but they have apparently now got stuck...

Cheers all.

radioradio 11-15-2004 04:00 PM

Ok I have found a bit more.
a) It does seem related to signal strength
b) My home net does NOT broadcast its SSID (as well being WEP) so I doubt I it will ever associate with it.
c) My network AP (wireless server in the garage) **does** broadcast SSID and the WUSB11 seems to find it. I think I am beginning to understand it a bit more..
d) More (only) problem now is to get the WUSB11 to DHCP an IP addy from my AP DHCP server..

Cheers.

Hangdog42 11-15-2004 09:33 PM

Quote:

d) More (only) problem now is to get the WUSB11 to DHCP an IP addy from my AP DHCP server..

Cheers.

Well, that might be the easy bit. If you're running Slack 10, just issue dhcpcd wlan0 at the command line and hopefully that will get you an IP (careful with the dhcpcd spelling though). Otherwise you can always issue yourself a static IP with ifconfig and set up your router as a gateway with the route command.

I'm not surprised at the signal strength bit. For an SSID to take, the card has to be able to see it. The same goes for the WEP. And you may have to set the WEP before you can set the SSID. However, on my system it is the other way around. Try experimenting with order and see if that helps.

radioradio 11-16-2004 03:33 AM

Ok ... well I have got the WUSB11 to take an IP addy using ifconfig - 192.168.174.40 (or xxxx but I need 192.168.174.**).
I am now struggling with the ROUTE command to setup my gateway which is 192.168.174.1 .... and while I am at it, the DNS which is 192.168.15.1

Further advice MUCH appreciated and thanks already..

PS HOST NAME NOT FOUND is driving me mad....

Hangdog42 11-16-2004 08:42 AM

OK, you can check out the route man page but I think the proper command is:

route add default gw 192.168.174.1


The other bit you are going to want to do is add your ISP's nameservers to your /etc/resolv.conf file. That is pretty easy to do, just open it in a text editor and add nameserver 1.2.3.4 and add as many nameservers as your ISP has.

radioradio 11-16-2004 11:34 AM

Thanks... but..
I get the feeling I am so near now, thanks to your efforts..

I can open a browser and the routing is set up and the browser is obviously trying to resolve the url ---- but it doesn't.

I have a nasty feeling the WUSB11 is NOT associating with my AP - I can log into the AP (using my management system) and see who and what is associated. In the WKiFi display, the Mac of the AP is NOT picked up, and the AP does not show the WUSB11 MAC. Thus no assocation... That may be the cause of the problem..

Any further thought please??
Cheers very much so far.. what annoys me is it is so easy under windoze, but I suppose it is a very steep learining curve ;-))

radioradio 11-16-2004 12:23 PM

IT Finally ocurred to me to grab my Orinoco gold card and iPAQ and do some WiFi sniffing..
With netstumber and WiNic I can actually GET the WUSB11 to associate with my iPAQ but ONLY in AD-HOC mode... The ip addy that comes thru is also in the 169.xxx.xxx.xxx range but that is I suppose becos there is not DHCP server enabled on the Linux system.

The iPAQ does not register the Linux system as an AP but then I suppose it would not, only as a wireless client or an ad-hoc system.

So it seems I am so close... I need to get the Linux system into infrastructure mode for it to associate with an AP but... Oh well, it must be good for the sole..

SO at least the whole thing is working, I get MAC addresses (invented by the Linux system but I don't care ATM) and they are decoded correctly on the iPAQ.

Any further thoughts please?

radioradio 11-16-2004 05:15 PM

WELLLLLL!!!!
This is my first linux post..
Using slack 10 - cheating, using ethernet but at least I **can** network..
I just installed it on my laptop..

Have to try radio tomorrow!!

Hangdog42 11-16-2004 10:11 PM

Congrats on getting the wired bit to work. Now lets see if we can get the wireless working so you can post from Linux while on the sofa with a beer nearby.......

At this point I'm flying a little bit blind. It is possible that your wireless card isn't associating with the AP and the only way to tell for sure is by looking at the output of iwconfig. You might want to post the output and we'll see if it looks suspicious. The other thing to try is if you think you ARE getting an association with the AP, you could try to surf to a site using the IP address. LQO is 64.179.4.149 so if you can access by just that IP, then it is a nameserver problem. If you can't, then it is likely still a problem with the wireless card.

radioradio 11-17-2004 02:42 AM

I'm 99% sure the wireless card is NOT associating - as I can see the output from the AP and it is NOT recorded there...

More work needed (sorry, this is from windoze..)

radioradio 11-17-2004 03:23 AM

WELLLL I'm jiggered...
THIS is my laptop, running Linux, using Orinoco Gold (which appears to be natively supported).
Put in my ip and gw and WHAM it works!!

So - the first card I tried (Buffalo WLI-CB-G54A) which ndis says IS ok, but the drivers don't seem to work - didn't work.

The Orinoco DID

YEEEEHHHHHHHHHHHhhaaaaaaaaaaaaaaaa!!

Hangdog42 11-17-2004 08:19 AM

Excellent.

Yes, the Orinoco chipsets have native linux support. Now if other manufacturers would just release enough info for native linux drivers to be written. Stick with the Orinoco card, having native linux support is definitely going to be a bettter solution.

radioradio 11-17-2004 11:04 AM

One (final haha) question..

How do I (very newbie question) setup linux so when it boots, I do not have to enter ip and gw every time.. That would be more convenient..

Cheers (ps a windoze machine this time ;-((

radioradio 11-17-2004 11:32 AM

I am so high it will require a crane and heavy lifting gear to get me down from the roof....

I followed instructions on ndiswrapper site for my Buffalo card - and that's what I am using now (oh BTW in LINUX).

And I am also access the network via my wireless ROUTER rather than direct...
This is soooooooooooooo cool..

radioradio 11-17-2004 11:33 AM

Can't have 13 posts, - so Orinoco Gold works, Buffalo G54 works (ndiswrapper).
Just have to figure out how to save the config..

And I also setup my email.
Sorry to bore everyone but my faith in ndiswrapper is restored..

Oh and it's also running with WEP enabled, but unfortunately I have to set my router / AP to broadcast SSID for it to be found.


All times are GMT -5. The time now is 03:51 AM.